Skip

Messages on an American iPhone in Greece?
May 15, 2014 8:14 AM   Subscribe

I recently took my Verizon American iPhone 5s outside the country for the first time and installed a Cosmote sim card on it. Immediately all my contacts on the messages app lost their names and only appear as their American phone numbers, e.g. +1 (xxx) xxx-xxxx. How can I fix this?

All the contacts are still in the Contacts app just fine, so nothing is permanently lost. It's just something about installing the European sim card that mucked up the messages app.

If it matters, I'll be in Greece for a few months, so I'd really like a permanent solution. At the same time, I'll be returning to the States after my time in Greece, and I'd like to be able to go back to my Verizon service smoothly. Any suggestions?
posted by crazy with stars to Computers & Internet (4 answers total)
 
It might be unrelated to your SIM card stuff, because I haven't left the US lately and I had the exact same thing happen. How I was able to fix it (after a handful of googling and trying different things) was to go to Settings > iCloud and toggle off and on and off the "Contacts" setting there. Turn the phone off and on. Then go to Settings > General > Reset and tap "Reset Network Settings".

NOTA BENE: I don't know whether resetting the network settings while in a country other than your phone's country of origin will cause problems for your phone recognizing your current SIM card.

I Am Not Your Genius and This Is Not Genius Advice. Good luck.
posted by gauche at 8:21 AM on May 15


I had the same problem for a few work trips. I ended up redownloading all my contacts from iCloud when I had the foreign SIM card and a good WiFi connection.
posted by msk1985 at 8:56 PM on May 15


I had this happen to me in Italy on a local SIM, and I swear there was an international option somewhere in general settings, but I can't find it anywhere in poking around on my own phone now.
posted by mathowie at 10:09 PM on May 15


I have remedied the most irritating parts of this problem, but I'll leave this open in case anyone has a more permanent solution.

What I've done is that for my most frequently contacted people I've added their American number with the country code as another number, which at least gets their name to show up on iMessages, but it's still a little frustrating.
posted by crazy with stars at 12:43 AM on May 22


« Older Where do atheist funerals/memo...   |  I'm trying to plan a last-minu... Newer »

You are not logged in, either login or create an account to post comments



Post