Join 3,557 readers in helping fund MetaFilter (Hide)


Probably the answer is to not text so damn much?
May 6, 2014 2:20 PM   Subscribe

My iMessages keep stacking up/not getting delivered to my phone and I don't know how to fix this. On a typical workday my boyfriend and I exchange hundreds of messages (ugh I know), mostly on our computers. The problem: when I check my phone at the end of the work day, the messages are not there (which is no big deal) but they proceed to download over the next hour or so, preventing new messages from being delivered and churning through my battery at an alarming rate.

Technical details: I have an iPhone 5s on a T-Mobile prepaid plan. He has an iPhone 4 on SmartTalk. We send most of our work day messages from our work computers, which are MacBook Pro Retinas. The stacking up happens whether my phone is connected via wifi or LTE/4G. These are iMessages, not SMS; SMS usually works OK. My boyfriend does not have the same problem; the messages get to his phone at roughly the same time as they get to his computer. Messages are mostly plain text with the occasional gif or emoji. I mostly notice the problem with texts from him but it seems to happen with iMessages to other people too (but I don't use iMessage this way with anyone else, so...).

If I check my messages on my phone regularly (at least every hour or so) I can usually stay reasonably caught up, but if I get busy and don't look at the phone all day, it can take well over an hour to catch up.

I've googled around and checked the Apple forums but I just can't seem to figure out the right search terms to find other people with the same problem (or maybe I'm the only one).

Has anyone else had this problem? Any advice? Is there some secret setting I'm missing?
posted by mskyle to Technology (11 answers total) 2 users marked this as a favorite
 
Try
Settings - messages - send and receive at... And make sure your phone number (or the email address that he is sending imessages to) is selected. And make sure iMessages is turned on.
posted by Crystalinne at 2:25 PM on May 6


Not really an answer to your question, but thinking about the bigger picture... if you're both at your computers, is there a reason you couldn't use email or chat during the work day and only text each other when you're not at your computers?
posted by rabbitrabbit at 2:32 PM on May 6 [2 favorites]


Is there any reason you couldn't turn "SMS with iMessage" off on your phone and just text the old-fashioned way? Besides seeing a green bubble and not a blue one, there's no downside that I know of (Assuming you have unlimited texts, which almost everyone does these days)
posted by drjimmy11 at 2:35 PM on May 6


We definitely could change our behavior, but I really like the platform-agnostic part of the iMessage - I don't need to know if he's on his phone or at his computer when I send him an message, I know he'll get it either way. If the problem is just that iMessage isn't supposed to be used as a chat client, I guess changing platforms/messaging services might be worthwhile.

And the Send & Receive setting has my phone number and the same three email addresses I have on my iMessage account on the computer. (Side note: it takes forever for
posted by mskyle at 2:43 PM on May 6


Not an answer to your question. I've had a similar problem with iMessage, and I wonder if the solution is going to be similar:

My office is in an area where cell phones are not permitted. I have a PC at work and use GMail.

My wife has a Mac at home. Text messages somehow get delivered simultaneously to her iPhone and her Mac. We both have iPhones on AT&T.

I use the trick of texting her via e-mail message ( 1234567890@mms.att.net ). If she responds to such a message from me, either using her Mac or her iPhone, I won't get it via e-mail, but I'll get it later on my cell phone, often not until hours later when I leave the office and turn on my phone. I used to get it via e-mail. The problem seems to have started when she upgraded the operating system on her Mac.

I try to encourage her to use Google Chat during the workday, as that is a fully functional workaround for this problem, but she can't do that using her phone and isn't always sitting at the computer.

I suggested she take my e-mail address out of the same contact with my cell phone number, and create a separate contact with just my e-mail address and a different name. I think that might work, but she doesn't want to do that.

I don't know much about Macs, but this seems to be a new "feature" with the latest Mac OS version.

I'll have to try the "Settings - Messages - Receive At" setting on my iPhone suggested by Crystallinne, and see if that works.
posted by tckma at 2:45 PM on May 6


You can switch to Google Chat/Google Hangouts. It's platform agnostic, with good apps on both Android and iOS (tckma, if she uses Hangouts on her iPhone, that solves that problem too). It doesn't do the automatic switching between sms and web thing that iMessage does though -- it requires a data connection if you're sending a chat.
posted by brainmouse at 3:38 PM on May 6 [2 favorites]


I had a lot of problems with imessage until I did a complete reset of my phone, signing out of icloud, signing back in, turning off imessage, reactivating it, etc.

Have you done all these steps on both of your phones? It may help clear everything up.
posted by modernnomad at 4:33 PM on May 6 [1 favorite]


Yeah. Seconding modernnomad's advice. While I haven't had your specific problem, I have had iMessage be strangely finicky with me until I did a full reset of all the iCloud/iMessage stuff on my phone.
posted by Betelgeuse at 4:45 PM on May 6 [1 favorite]


Yep, I've had the same problem here recently, right down to the constant iMessage on OSX communications with my boyfriend during the day. Logging in/out of iCloud and iTunes and resetting all that stuff fixed it. I did it for all devices simultaneously so I can't say which logout/login was the one that actually fixed it, but it worked.
posted by misskaz at 5:05 PM on May 6


Are you using your work computer in wired mode or wireless? If wired, can you turn on internet sharing? Use the Mac to create a WiFi hotspot, then connect your phone to this network. Make sure you enter some kind of security (if Mavericks, you can use WPA2; Mt Lion may also allow this, but I know that Snow Leopard only gives options for older security modes). Problem solved. Your phone is now on WiFi and you will receive all messages as they are sent, on both devices.

I do this at work so that my iPad (a WiFi only model) will be usable for email, web, etc. as needed.
posted by caution live frogs at 5:51 AM on May 8


I reset the phone and logged out of iMessage on my computer and I thought it might have helped? But I spent so much time futzing with my phone yesterday getting it set back up that I may have been encouraging it to download the messages more frequently. And then my texts started stacking up on the boyfriend's phone, which hasn't happened in months.

My phone is usually connected to my work WiFi network while I'm at work (the computer is on the wired network), so I don't know that setting up a wireless hotspot would help.

I might try and have both of us do a simultaneous complete logout and reset fest this weekend and see if that helps.
posted by mskyle at 8:42 AM on May 8


« Older Does anyone have any recommend...   |  I like Supernatural. In honor ... Newer »

You are not logged in, either login or create an account to post comments