Skip

How to make Chrome forget a "do this for all files of this type" command
April 26, 2014 11:50 AM   Subscribe

I accidentally made Chrome ignore all of a certain file type. How can I fix it so I don't have to use Internet Explorer (yuck)?

Several months ago, I checked the "do this for all files of this type" option in Chrome, and then accidentally clicked ignore. Since then, I've had to use a different browser to open those files, and the only one available to me is IE. Googling showed results for Windows 7, but I'm on 8 and couldn't figure out how to adapt the instructions. Someone please help me.
posted by Captain Cardanthian! to Technology (8 answers total)
 
Try going to chrome://settings/
then click on "show advanced settings", scroll all the way down and hit "reset browser settings". Does that help?
posted by travelwithcats at 1:00 PM on April 26


If you go to chrome://settings then "Show Advanced Settings" there is a section for Downloads and a button for "Clear auto-opening settings"
posted by Fortran at 1:21 PM on April 26


"Clear auto-opening settings"
My version doesn't have it. All I can do for downloads is set a location and click "Ask where to save each file before downloading". Interesting. It's Version 34.0.1847.116 m FWIW

posted by travelwithcats at 1:36 PM on April 26


I might not be understanding entirely, but if you go to the file that you want Chrome to open and right click on it and choose "Properties," there is an "Opens with" option that shows what the current default program is that opens this file type (internet explorer, it sounds like). It also gives you the option to change to a new new default program, and you should be able to select Chrome. If it doesn't show Chrome in the list of available programs, you can still navigate to Chrome on your computer and select it as the default program.
posted by SpacemanStix at 7:45 PM on April 26


What exactly is the workflow here?

Are you clicking a download link for a certain type of file on a website from within Chrome to try to open it? For this, go to chrome://settings, click "show advanced settings" then click "Content settings" (under the privacy section), then scroll down to "Automatic Downloads". Make sure the correct default behavior you want is selected (probably "Ask when a site tries to download files automatically after the first file") and then click "Manage Exceptions..." and delete any site-specific settings by clicking the "X" on the right side of the list.

Are you trying to double click a file on your computer and have it open in Chrome? Right click the file from Windows Explorer, choose "Open with" then choose "Choose default program..." and choose Chrome when it prompts you what to open the file with.

Do you want links from other programs to always open in Chrome? Go to chrome://settings, then click "Make Google Chrome the default browser".
posted by Aleyn at 11:49 PM on April 26


So far none of these suggestions have worked for me. The file type in question is a magnet link that I want to open in uTorrent, but Chrome no longer will do that. Instead, when I click the link, nothing happens. The instructions for Windows 7 had to do with editing some file for Chrome, but it didn't translate to Windows 8.
posted by Captain Cardanthian! at 9:38 PM on April 27


Ok, that sounds like a protocol handler problem, then. Two things you can do:

Go into chrome://settings, show advanced settings, Content Settings, Handlers. Make sure "Allow sites to ask to become default handlers for protocols" is set, click Manage handlers and remove anything beginning with "magnet". This is probably not the issue, but you should check anyway to make sure your bases are covered.

In Windows 8.1, either search for "protocol" from the start screen and choose the "Choose a default app for each protocol" control panel or go to PC settings (Win+C to bring up the charms bar, click "Settings", then "Change PC Settings", then navigate to Search and apps > Defaults > Choose default apps by protocol. Look for the one called "MAGNET" and click the app button beside it to change it to uTorrent. If uTorrent isn't listed as one of the apps that can handle the protocol, try reinstalling uTorrent.

If you're still using Windows 8, you need to use the classic control panel to change this. Go to the desktop, type Win+X to bring up the power user menu, then click Control Panel. Search for "Default" in the search control panel box, and choose "Set default programs". Find uTorrent in this list, then click "Choose defaults for this program". Look for the "MAGNET" protocol in the list and check it. Again, if uTorrent isn't listed as an app that can handle the MAGNET protocol, try reinstalling it.

Hope that helps!
posted by Aleyn at 3:21 PM on April 28


If all else fails, I'd just try reinstalling uTorrent. It will most likely attempt to re-register itself as the protocol handler for magnet links, so you don't have to go mucking around with various arcane settings.
posted by Aleyn at 3:26 PM on April 28


« Older I’ve been seeing physical ther...   |  Coincidence or something real?... Newer »

You are not logged in, either login or create an account to post comments



Post