My Google searches are being invaded by an email address
April 3, 2014 9:34 PM   Subscribe

A few days ago I was searching for an email in my Gmail inbox and entered the email address of the person I knew it was from -- let's say I don't know what I did wrong during this very mundane occurrence, but ever since then "" has been aggressively filling itself in on google-related search boxes in Chrome, preventing me from using Google effectively. How can I make it stop?

Here are all the observations I have made about this behavior:
  • When I type something into the URL box with the intention of searching for it, I go to the Google results page and then, 1-2 seconds later, the search terms disappear from the search box on the Google page and are replaced by "", followed immediately by Google looking like it's updating the search results but actually just returning a blank page.
  • At this point, I can re-enter the search terms in the search box on the Google page (not the URL box) and it will take me to the results and stay there.
  • If I click on one of the results links and then go back to the results page using the back button, it once again quickly reverts to a blank results page with "" in the search box.
  • If I actually search for "" it returns results, not a blank page.
  • In Gmail, the search box fills with "" shortly after I go to my inbox, sometimes written in black over my own Gmail username in grey.
  • If I go to read an email in Gmail and then click on the "back to inbox" button, sometimes "" immediately reappears in the search box and sometimes it doesn't reappear until I click in the search box.
  • I don't have this problem at all when I am using Google Scholar. No appearances of "" whatsoever.
  • I also don't have this problem with YouTube despite being signed in to the same Google account.
Help! What on earth is going on? And more importantly, how can I make it stop? I've got OSX 10.9.2 on an 11" MacBook Air. "About Chrome" says Version 31.0.1650.34 beta, no idea if that is useful.

Things I have tried that didn't help:
  • Restarting Chrome
  • Updating Chrome
  • Restarting my laptop
  • Clearing all of my browsing history/data
posted by ootandaboot to Computers & Internet (15 answers total) 1 user marked this as a favorite
Could you uninstall then reinstall Chrome?
posted by fieldtrip at 10:01 PM on April 3, 2014

This is such a strange problem!

Does it happen when you're signed into the same Google account in another browser?
posted by mekily at 10:02 PM on April 3, 2014

Yeah, I'd try un-linking Chrome from your Google account -- AFAIK, Incognito mode should simulate this, but if it persists in incognito, unlink, close chrome fully, reopen, then open an incognito tab and try.

If that works, pop over to the Google Dashboard and start nuking things - I'd start with nuking Chrome Sync data.
posted by pahalial at 10:07 PM on April 3, 2014

This isn't normal behavior. I'd try disabling all chrome extensions/plugins.
posted by jjwiseman at 10:13 PM on April 3, 2014

What you're getting is Google Instant results in the Omnibox. In previous versions of Chrome, you could actually disable Instant results in the Settings menu. After a while, this was removed from settings, but you could still toggle it by going to chrome://flags, but I think this feature has been disabled since October 2013.

You can either try deleting your Search history, or you could always wait for Chrome to update itself and fix the problem.

In the meantime, you might try using Chrome Canary, which, despite the warnings, is pretty stable.
posted by KokuRyu at 10:45 PM on April 3, 2014

When "" is highlighted, try pressing fn+shift+delete?
posted by bunji at 11:50 PM on April 3, 2014 [1 favorite]

Well, sounds to me like a malware/toolbar program has installed itself.

By the way, I love for internet searches.. (just saying)
posted by Sintram at 12:25 AM on April 4, 2014

You should also, of course, run Malwarebytes or another suitable anti-malware program as a primary defense.
posted by yclipse at 3:46 AM on April 4, 2014

What bunji said: let it auto-complete, then push the down arrow to highlight it, then push delete to remove it from your auto-complete.
posted by devnull at 4:33 AM on April 4, 2014

If this is an Instant Search problem, you can turn that off by going to your search settings in Google (not Chrome, but the website) and selecting "Never show Instant results."
posted by Holy Zarquon's Singing Fish at 5:07 AM on April 4, 2014 [1 favorite]

Given that you're seeing text overwriting existing text, this sounds more malicious than Google Instant. This article suggests steps and software if you want to take a shot at possible malware remediation.
posted by Wyeldfire at 9:13 AM on April 4, 2014

The problem does not appear in Incognito mode and I've turned off Chrome Sync. I then disabled all my Chrome extensions and then turned them back on one at a time. Turns out that somehow the culprit is my LastPass plugin! But I'm so dependent on LastPass that I don't want to leave it disabled. I've submitted a help ticket with LastPass, but if anyone has any further suggestions I'd be grateful.
posted by ootandaboot at 8:07 PM on April 4, 2014

I would search your LastPass archive for the phantom email address, and then if an entry pops up, manually delete it.
posted by rainbowbrite at 10:44 AM on April 6, 2014

Well, it's not just you - I also use LastPass, and out of nowhere today it seized onto a short message I posted on another forum and started filling in every message window on that site with the text of that message. Even attempts to edit exiting replies were overwritten. It's bizarre. I wasn't able to find the text in my vault, which makes me wonder where it was being stored, but I was able to get the behavior to stop by going into the LastPass entry for that site and ticking the box for "Disable autofill".
posted by Holy Zarquon's Singing Fish at 6:09 AM on April 13, 2014

Looks like they fixed it - when I went to LastPass's website to submit a support ticket, it prompted me to upgrade the software to the latest release, and that seems to have fixed whatever craziness was going on here. I turned autofill back on to see what would happen and the bug did not repeat.
posted by Holy Zarquon's Singing Fish at 6:17 AM on April 13, 2014

« Older Pretty much what it says on th...   |  My husband and I are consideri... Newer »
This thread is closed to new comments.