Join 3,561 readers in helping fund MetaFilter (Hide)

Tags:

VMWare: When using VPN my keyboard pretends I'm crazy
March 28, 2014 3:04 AM   Subscribe

New laptop, windows 8.1. No issues. Except when I use my company's VPN through VMWare (Windows 7). Unpredictably, but often, it acts like I'm pressing the C button. But I'm not!

In a Word or Excel doc, I see a bunch of c's, in other applications it does whatever it would do if the C was pressed intentionally. I can stop it by pressing C. A few minutes later, it will happen again.

Note: this does NOT happen when I use my laptop for personal stuff, without the VPN. So I don't think somethings actually wrong with the key or the wiring of the keyboard. The laptop is a Toshiba.
posted by Ms. Next to Computers & Internet (5 answers total)
 
I guess I forgot to add my actual question, which is "what's going on here? Should I contact Toshiba or is this a VMWare-related issue? Or something else entirely?"
posted by Ms. Next at 4:32 AM on March 28


Just to make your question clearer - you are running the VPN client from inside a VMWare guest system running Windows 7, with your host running windows 8.1, right?

It's a little weird that a keyboard issue would be related to the VPN, unless keyboard traffic somehow crosses the network - is there something like a Remote Desktop in play you haven't mentioned? What happens if you start your VM but not the VPN and edit some local documents in Word?
posted by Dr Dracator at 4:43 AM on March 28


I have experienced this using VMs on a machine that I'm connected to via Remote Desktop: I attributed it to the host machine being overloaded combined with a slow internet connection, causing the VM to run slowly and exhibit weird keyboard behavior. It may be that VMware isn't optimized for your laptop, or is consuming too much CPU or memory, but I don't think there's anything wrong with the laptop itself, aside from possibly being too underpowered to run the VM.

Edit: I only experienced this when interacting via the VMware Console -- maybe turn on RDP on the Win7 VM, and connect via Remote Desktop, see if the problem goes away then?
posted by AzraelBrown at 6:09 AM on March 28


Yes, this was using a remote desktop. I'll try some of your suggestions, thanks!
posted by Ms. Next at 8:41 AM on March 28


Your setup looks needlessly complicated - why are you running the VPN and Remote Desktop from inside a VM? Can't you get a VPN client for 8.1?
posted by Dr Dracator at 2:52 PM on March 28


« Older I have an old laptop running X...   |  Looking for a recommendation f... Newer »

You are not logged in, either login or create an account to post comments