Join 3,559 readers in helping fund MetaFilter (Hide)


Ubuntu on my Chromebook. I thought I knew my login but I don't.
March 16, 2014 12:36 PM   Subscribe

I just installed Ubuntu using Crouton on my new Samsung Chromebook. But...

After entering Developer Mode and following the instructions from this video, I reached the end of the installation and the Ubuntu desktop appeared. Yay! Except I ran into an issue immediately.

Since Ubuntu is said to run side by side with the Chromebook OS (Google), I wanted to test the switch to the Chromebook OS using CTRL+ALT+FORWARD.

It worked. Yay again. But here it is...

When I tried to switch back to the Ubuntu OS, I entered CTRL+ALT+BACK. But instead of getting the Ubuntu desktop, I got a black screen asking for a "localhost login". I entered the "primary user" name that I had chosen just moments before at the end of the Crouton installation. That didn't work. The "localhost login" line just reappeared again.

So what is my login? I have no idea.

That's where I'm stuck. (I can work in the Chromebook OS environment but not in Ubuntu.)

Any help would be greatly appreciated.

Thanks in advance!
posted by amusem to Technology (12 answers total)
 
The "localhost login" prompt indicates that there isn't an X-server running on the active teletype. Either your X-server crashed, or somehow the Chromebook is switching down to a different teletype in the process of switching.

Try hitting CTR+ALT+F7 from that black screen. Or maybe F6 - it depends on which tty the distro likes to put its window manager on.

As to the login question: it should accept your primary username, then prompt for your password. That should let you log into a basic Bash shell, provided that something else isn't broken. (Like, say, your primary user account somehow not being in the sudoers group. Which would kinda suck.) If you manage to log in that way, and switching teletypes as described earlier doesn't work, you can try to force the X-server to start with:

sudo startx

Otherwise, you may have to do some more poking. I'm unfamiliar with exactly how the boot process is managed on ChromeBooks - do you boot to a GRUB menu? If so, you can try selecting the "recovery mode" option underneath your basic Ubuntu boot entry. Wait for it to load, select the option to drop to a root shell, and you can do some poking. If, for instance, the password for your primary user account is broken, you can fix it with

passwd youruseraccountname

Since that's a root shell, it won't prompt you for a password to do that.

Good luck! You're a braver user than I am to even try to fiddle with a nonstandard device like a Chromebook.
posted by fifthrider at 12:59 PM on March 16


In Linux, Ctrl-Alt-Backspace is the special key combo reserved for exiting the graphical session and throwing you to command prompt. Or at least it used to be back in the day. That might be a factor here.

Might you actually be at a command prompt in the Chromebook OS?
posted by intermod at 1:05 PM on March 16


Hi fifthrider. Thanks. I would like to try hitting CTRL+ALT+F7 and F6 but there are no F's on the Chromebook keyboard. I will do some more poking. Thanks for the note intermode, but Ctrl-Alt-Backspace doesn't do anything.
posted by amusem at 1:17 PM on March 16


Documentation.
posted by tracert at 1:22 PM on March 16


Is it this prompt, perhaps?

http://www.chromium.org/chromium-os/developer-information-for-chrome-os-devices/samsung-series-5-chromebook#TOC-Developer-mode-BIOS
posted by effbot at 1:23 PM on March 16


there are no F's on the Chromebook keyboard.

That's a tad inconvenient, considering how useful the F-keys are in the various Linuxim. Try a USB keyboard, at least for as long as it takes to troubleshoot, I guess?
posted by fifthrider at 1:23 PM on March 16


Hey effbot. Thanks. Yes it is but I wonder why it appears there. Thanks fifthrider for the USB keyboard idea, I don't have one handy but I'll borrow one if I can't solve this today.
posted by amusem at 1:47 PM on March 16


On my Acer Chromebook, the top row keys are labeled, starting from the left arrow key next to the "esc" key, F1, F2, F3, etc.
posted by zscore at 1:56 PM on March 16


amusem, is the black screen you seen just text on a black background? Or is there a grey box with text fields for username and password on a black background?

(I have a crouton install as well, often when I switch over I have to enter my password because the screensaver lock is on by default)
posted by no regrets, coyote at 2:00 PM on March 16


Also, I'm pretty sure your problem is that you hit "CTRL+ALT+FORWARDS" instead of "CTRL+SHIFT+ALT+FORWARDS". It's taking you to a ChromeOS console instead of back to the Ubuntu desktop!
posted by zscore at 2:01 PM on March 16


Hi no regrets, coyote -- No grey box... I wish.

Hi zscore, thanks, very relevant. But no, the switch does not require the shift key. When I insert it in the command, nothing happens.
posted by amusem at 2:19 PM on March 16


Hey again zscore, I don't know exactly what I did but yes, you're right, adding SHIFT to the mix does it. It now works. I won't go into detail, there are still some weird things. Part of the solution came from clicking and reading your link, effbot. Thanks to all!
posted by amusem at 3:28 PM on March 16 [1 favorite]


« Older Why should I move to Seattle f...   |  My friend is in need of a recr... Newer »

You are not logged in, either login or create an account to post comments