Join 3,572 readers in helping fund MetaFilter (Hide)


How to get Zotero talking to my home Webdav server?
March 7, 2014 11:31 AM   Subscribe

I've set up a webdav service on my home server and am trying to back up my Zotero files onto it. The webdav service seems to work perfectly through a browser or cadaver but Zotero just stalls -- any suggestions?

I would ask this question on the Zotero forums but they refuse to answer questions about webdav configuration. Generally I know enough to make trouble for myself but I am not an IT expert by any stretch of the imagination, so please let me know if I should provide more information.

I already had apache installed so I followed this guide to set up webdav on my computer. The service seems to be working ok. I can add and remove files through a client like Cyberduck and can see them through a browser. When I try to have Zotero sync with it, however, I click "Verify Server" which never finishes -- it just continues until I click "Stop." Here's the relevant part of the logs with personal information removed:

(3)(+0000052): WebDAV file sync is not active

(3)(+0000000): Getting WebDAV password

(3)(+0000007): HTTP OPTIONS for http://username:********@some.thing.com/webdav/zotero/

(3)(+0000095): Date: Fri, 07 Mar 2014 19:23:39 GMT
Server: Apache/2.2.22 (Ubuntu)
DAV: 1,2,
MS-Author-Via: DAV
Allow: OPTIONS,GET,HEAD,POST,DELETE,TRACE,PROPFIND,PROPPATCH,COPY,MOVE,LOCK,UNLOCK
Content-Length: 0
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: httpd/unix-directory


(3)(+0000000):

(3)(+0000000): ===>200<> to http://username:********@some.thing.com/webdav/zotero/


There's nothing obviously relevant after the propfind request.

If it helps, here's the relevant part of the server configuration (from /etc/apache2/sites-available):


ServerAdmin webmaster@localhost

DocumentRoot /var/www/

Options FollowSymLinks
AllowOverride None


Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all


Alias /webdav/ /media/seagate/webdav/


Options Indexes
DAV On
AuthType Basic
AuthName "webdav"
AuthUserFile /etc/apache2/webdav.password
Require valid-user


Thanks so much for your help.
posted by crazy with stars to Computers & Internet (3 answers total)
 
I also see that the server configuration got mutilated by its resemblance to HTML. Sorry, I can fix that if it would help.
posted by crazy with stars at 11:35 AM on March 7


It looks like it's failing to read the directory. Try adding an explicit entry to allow the specific directory. I remember allowing dir listing is a bit fussy for good reason as it's pretty dangerous.

see: http://wiki.apache.org/httpd/DirectoryListings

<Directory /usr/local/apache2/htdocs/listme>
Options +Indexes
</Directory>
posted by sammyo at 5:46 PM on March 7


This put me on the right path -- thank so much!
posted by crazy with stars at 2:19 PM on March 8


« Older Suppose, one person thinks it ...   |  My brother passed away on Mond... Newer »

You are not logged in, either login or create an account to post comments