Join 3,520 readers in helping fund MetaFilter (Hide)


Visual Studio 2010 Deployment Project
February 27, 2014 8:41 AM   Subscribe

I have a simple application that I deploy with a VS2010 Deployment project. However, the application is behaving weirdly in the wild.

The application is a simple .NET executable. Along with the exe, I also ship a number of text files that contain SQL queries. The application reads these files, and executes the queries.

Not all customers need all the queries, so customers delete the files that they don't need.

After they delete the files they don't need, the installer is putting the files back the very next time that they run the application. It doesn't matter if they click the shortcut that the installer places on the desktop or they double-click the EXE directly. The installer launches and replaces the missing files.

I don't want this behavior but have had no luck in my research to try and figure out to disable it. How can I do this?

Moving to another deployment platform (e.g. Installshield) is not really an option at this time.
posted by DWRoelands to Computers & Internet (3 answers total)
 
Are the SQL text listed as 'Application files' and do you have the .NET auto-update functionality turned on?

I'd wager that the .NET update program notices these files are missing and re-downloads them upon launch.
posted by Setec Astronomy at 9:59 AM on February 27


Are the SQL text listed as 'Application files' and do you have the .NET auto-update
functionality turned on?


Can you tell me where specifically to look for the auto-update functionality item?
posted by DWRoelands at 11:11 AM on February 27


Your are deploying a SQL Injection attack app. What is to prevent the sql content from being modified by an end user?

- I suggest you implement the sql as stored procedures. This addresses both security and deployment.

- Barring that, make the files embedded resources in your project. They'd be compiled into the exe and not show up on disk at all.
posted by j_curiouser at 12:59 PM on February 27 [2 favorites]


« Older I need a super reliable car!...   |  I have recently started using ... Newer »

You are not logged in, either login or create an account to post comments