Join 3,572 readers in helping fund MetaFilter (Hide)


iTunes Gracenote Server Error
February 24, 2014 5:41 AM   Subscribe

iTunes keeps hitting a "Server Error" whenever I try to download CD information from Gracenote. Help?!

Tried with numerous CDs, reinstalled iTunes v11.1.4.62, reset iTunes Store cache, checked all the rules on my firewall -- nothing worked. Seen a number of identical questions on the Apple Support Community pages, but with no solution that I could find.

So... what do I do?!
posted by Saxon Kane to Computers & Internet (4 answers total)
 
Is this a new problem? Did it start after a particular software update?

Are you running firewall software you downloaded or purchased (or anything else that monitors your connection, like Little Snitch), using the firewall that's built-in to OS X, or do you have something hardware-based? Or a combination? What did you do when you "checked all the rules" on your firewall?

Have you tried ripping your music with a different application entirely? Maybe give XLD a try; you might have to fiddle with it a little to get the settings where you want them but once it's set up to your liking it's pretty much one-click-and-done, just like ripping in iTunes. It uses freedb or MusicBrainz for track identification.
posted by bcwinters at 6:28 AM on February 24


Here's a work-around to use FreeDB instead of Gracenotes CDDB with OS X. You can do something similar with Windows.
posted by filthy light thief at 8:49 AM on February 24


No updates or anything precipitated the change, as far as I can tell. Seems to be the same thing with other people on the message boards. Something must have happened, but there was no obvious visible change.

W/ the firewall I just checked to make sure it wasn't blocking any ingoing or outgoing requests from iTunes. It isn't.

Will try the freedb workaround.
posted by Saxon Kane at 9:33 AM on February 24


The freedb workaround seems beyond my technical capabilities. Still looking for a solution, if anyone's got one ...
posted by Saxon Kane at 5:08 PM on February 24


« Older We have a pony cart, and are t...   |  I want to take a comma delimit... Newer »

You are not logged in, either login or create an account to post comments