Skip

Sharing a wireless internet connection
January 31, 2014 3:23 AM   Subscribe

While our ADSL line is down, for an as yet undetermined period of time, we are restricted to using public wifi to get online. Unfortunately the signal is weak enough that we can't connect to it on all devices. How can we share this wifi with all our PCs and phones?

We have:

Three PCs (two tower PCs and one laptop, all running Windows 7) and two phones.
One USB wireless receiver which can receive the wifi signal.
A fairly ordinary ADSL wireless router.

What we would like to do:

Share the internet connection of the PC connected to the USB receiver with the rest of the flat, via the wireless router.

Unfortunately:

I can only connect to the public wifi if the LAN connection to the router is disabled. Enabling it has no obvious effect on the reported connection strength, but web pages will no longer load. Bridging the two networks, which seemed like the obvious option, has the same effect.
posted by ArmyOfKittens to Computers & Internet (11 answers total)
 
Maybe something like this Wireless Range Extender. My experience of them hasn't been great, but they're probably ok for basic web browsing.
posted by Leon at 4:13 AM on January 31


Should add that because this is a temporary situation, a software-only solution is preferred. There's got to be a way to take the internet from a USB port and squirt it over our home network...
posted by ArmyOfKittens at 4:18 AM on January 31


Have you looked into Windows Internet Connection Sharing? Configuring that on a desktop PC that has the USB wifi receiver plugged in will get Internet connectivity out to the PC's ethernet port (this PC has to remain on).

From there you want to connect it via ethernet cable to the switched side (since this is an adsl router, it probably doesn't have an uplink port) of the wireless router in access point mode so that it's just acting as a switch for the wired/wireless networks.
posted by RonButNotStupid at 4:52 AM on January 31


Are you sure your wifi router and the public wifi are using different channels? There are really only three non-overlapping channels in the 2.4GHz band (1, 6, 11) and your local wifi traffic might just be swamping the public wifi.
posted by flabdablet at 9:49 AM on January 31


Currently our router's wifi is switched off, so I think it is just a weak signal, probably combined with this being a very densely populated area -- a scan of available networks shows up almost two dozen distinct strong signals.

When I get home I'm going to try RonButNotStupid's ICS suggestion.
posted by ArmyOfKittens at 10:14 AM on January 31


Turning on Windows Internet Connection Sharing for any given network interface turns your Windows box into a NAT router between that interface on the public side and all its other interfaces on the private side. That's what you need in order to hang multiple computers off a single USB wifi modem, but you still have the need to connect all those computers to an interface on the private side of your Windows box. Unless you're happy for that to be done with wires and you have the necessary Ethernet switch, the easiest way to do that will be via an Ethernet cable from your Windows box to your existing ADSL router, then using the router's wifi for local distribution.

Your existing router also does NAT between its public side - (PPP over ATM over ADSL) and its private side, which will typically treat all Ethernet ports and all wifi connections as a single switched subnet; with the ADSL side unavailable, the private side is all that's going to do anything. It will also typically contain a DHCP server, responsible for assigning private IP addresses to all the devices that connect on the private side.

Windows Internet Connection Sharing also creates a DHCP server inside the Windows box for exactly the same purpose. Having two DHCP servers on the same subnet is unlikely to work well. So before you turn on ICS, make a wired connection between your Windows box and your ADSL router, log onto its settings page, and disable its DHCP server.

Next, make sure that the router's SSID (wifi name) is different from that used by the public wifi you're going to connect to with the USB stick, and make sure the router's wifi is not using a channel that overlaps with the one used by the public wifi. The stick is going to be the only device in your house that connects to public wifi - all the others are going to connect to your router's wifi as usual - and you don't want your local wifi swamping the weak public signal.

When you turn on ICS for the wifi stick attached to your Windows box, the Windows box will pick up an IP address for its own Ethernet connection from ICS's DHCP server. The subnet part of that address is unlikely to match the one used by the router itself, which means that the Windows box and the router's administrative web server will no longer believe they're on the same subnet and they won't be able to talk to one another any more. Don't be surprised by that.

What you'll end up with after all this is

* An ADSL router that works like an Ethernet-to-wifi switch but is not itself accessible (factory reset is your most straightforward way to make it accessible again when you need to)

* A Windows box acting as a NAT router between a USB wifi stick on the public side and anything you connect to your ADSL router's Ethernet ports or wifi on the private side

From the public wifi operator's point of view, your entire home network will appear to be one Windows box, probably behind their NAT. That would put two levels of NAT between any of your connected devices and the public Internet, so you might encounter issues if you're running e.g. game servers or BitTorrent clients. Apart from that it should all work OK.
posted by flabdablet at 10:10 PM on January 31 [1 favorite]


Oh my goodness, that is so comprehensive. Thank you so much!

Will be aiming to set this up soon and will report back.
posted by ArmyOfKittens at 11:57 PM on January 31


We have two phones connected via our router. Can't imagine why the other PCs wouldn't connect fine via the same wifi. Success!

Thank you. I'm a just-enough-knowledge-to-be-dangerous computer user, but network stuff makes my eyes cross.
posted by ArmyOfKittens at 12:29 AM on February 1


Network stuff makes everybody's eyes cross. Some of us are just more used to staggering about in that condition than most.
posted by flabdablet at 1:55 AM on February 1 [1 favorite]


One more thing: if you're likely to have to do this dance more than rarely, then whenever the ADSL comes back up and you turn ICS off again, the need to reset your router and re-enter all its settings is going to be a pain in the arse.

If your router has the facility to let you back up its settings to your PC when it's set up as you like it, and restore those after a factory reset, then it won't be a major pain in the arse but a pain all the same.

So it would be worth your while, now that you've got ICS up and running, to note the IP settings in current use by any of your wifi-connected devices. That will let you, next time you're in administrative control of your router, change its own IP settings to match the subnet address and netmask that Windows ICS's DHCP server hands out, but with a fixed host address outside the range managed by ICS's DHCP.

Having done that, the router's admin server won't disappear from your LAN when Windows ICS takes over, and all you'd need to do to put the router back in charge of things after turning ICS off is log onto it, re-enable its own DHCP, and turn your devices' wifi off and on again to make them pick up settings appropriate for the router rather than the now-defunct ICS.

Let me know if that scenario is too lumpy for your present level of cross-eyed navigation comfort :-)
posted by flabdablet at 5:45 AM on February 2


I think I can parse that :)

Already have a backup of the router settings, and screenshots of every option, because I'm paranoid.

You've been a great help with this. Thank you!
posted by ArmyOfKittens at 9:17 AM on February 2


« Older What is my daily food intake m...   |  Can't seem to get some items t... Newer »

You are not logged in, either login or create an account to post comments



Post