Can you use VGA for video and HDMI for audio?
January 25, 2014 9:39 AM   Subscribe

A friend is trying to connect her PC (Windows 7) to a projector for video and a receiver for audio. The projector does not support HDMI, so she's using VGA. The receiver does have HDMI, so she's using that for audio. If she doesn't plug in the projector, the audio plays fine. As soon as she connects the VGA, HDMI audio is no longer an option in the Sound settings and audio starts playing through the laptops built in speakers. Is there a way to have HDMI for audio and VGA for video at the same time?

Running Windows 7 with stock drivers.

Ideal answer would be to make it work, but we might also look at something to convert HDMI (out of the receiver) to VGA into the projector if that's the only way to make it work. If so, do you have suggestions? Seems most want to use power from HDMI, and I'm not sure that would be possible if we're passing it through the receiver. Receiver is an Onkyo. Not sure of the model off hand, but can find out if it matters.
posted by willnot to Computers & Internet (6 answers total)
 
Is there a stereo jack? If so, all you have to do is run a cord from the stereo headphones to the projector. Generally if a device has VGA support, it will do that. Cords are just a few bucks if you do not have one.

Windows gets a little funny when you try to use HDMI for audio only. It wants you to use it for video also, and will disable VGA OR will disable HDMI when you use VGA for audio. This has some to do with the graphics card, but it also has to deal with windows, being well windows. You may find some sort of program to do it for you, though be careful about malware downloading little apps like that.
posted by AlexiaSky at 9:50 AM on January 25


Does it support dual monitors across the HDMI and VGA ports? If so, just have it output to both and I'd expect the video coming into the receiver wouldn't impact anything.
posted by XMLicious at 9:50 AM on January 25 [1 favorite]


To follow up XMLicious's answer - Pressing Windows-P will bring up the projector menu, which will let you put Windows 7 into Projector mode, and one of the choices is duplicating the desktop on each monitor.
posted by Hatashran at 10:04 AM on January 25 [1 favorite]


I'm not sure why you have to use HDMI for the receiver. If the device has a headphone jack, get one of these cables to hook up to your receiver (I haven't seen one yet that didn't have RCA jacks, so I'd be surprised if yours didn't). It's going to be a heck of a lot simpler than jury-rigging something with HDMI.

If the idea is to do some sort of home-theater setup where you want surround audio to the receiver, then I'd try the above advice of making sure the computer outputs to both display ports at the same time. It's possible that this is just a limitation of the hardware, though; most laptops don't have a beefy enough GPU to drive two monitors plus the built-in monitor, so that might be why it isn't working for you. In that case an HDMI to VGA adapter isn't that expensive.
posted by Aleyn at 4:04 PM on January 25


Expanding a bit more on the surround-sound route, you might also check your laptop's manual to see if you can cajole it into outputting S/PDIF, which most recent Onkyo receivers should be able to cope with just fine (check your receiver's manual too, first). If your laptop doesn't have a way to output S/PDIF, you might try getting a USB audio adapter that does.

Honestly though, if surround-sound isn't necessary, the headphone jack-to-RCA cable thing is going to be the easiest and cheapest answer for you.
posted by Aleyn at 4:14 PM on January 25


Headphone to RCA was my first suggestion to her, but she is looking for 5.1 audio. We had also tried mirroring the video, but it still didn't work. Headphone jack does not seem to support optical out. I guess an HDMI to VGA converter may be the best option unless anybody else knows a way to force windows to do what we want.
posted by willnot at 11:23 PM on January 25


« Older I again have time to consume b...   |  The 5x5 Home Work podcast abou... Newer »

You are not logged in, either login or create an account to post comments