Skip

Don't Span Me, Bro
January 14, 2014 3:50 PM   Subscribe

My work computer adds an html tag that I don't want it to add. It happens only on my work computer when I am adding content to a website via a CMS. The text area that I am typing in is - in theory - not supposed to do anything except add plain text. This doesn't happen when I use other computers, just my primary work computer. The tag it adds is: span style="font-size: 14px It is driving me crazy. Any ideas how to stop this span-ness?
posted by davidmsc to Technology (14 answers total) 1 user marked this as a favorite
 
Have you searched the filesystem for that string? It might be buried away in some configuration file for the CMS that is locally stored.
posted by thelonius at 3:56 PM on January 14


What's the CMS? That seems like that'd narrow it down at least some.
posted by Sequence at 3:57 PM on January 14 [1 favorite]


Is it a mac? I had set up a "replacement" on my iPhone that expanded 'href' out to '<a href="' to make it easier to type web links on my phone. When I upgraded my mac to 10.9, it started doing the same thing, because presumably those replacements are synced to iCloud (it was very annoying). I went and turned it off on the mac and it hasn't bothered me since.
posted by tylerkaraszewski at 4:03 PM on January 14


Weirdly, my home computer does this whenever I edit anything in Tumblr using Chrome - the exact same font size, too. It's extremely frustrating.
posted by SMPA at 4:08 PM on January 14 [1 favorite]


The CMS is called Synapse -- used for publishing to a TV news website. Computer is standard-issue Dell desktop.
posted by davidmsc at 5:09 PM on January 14


I don't have answer for you, but this happens to me as well. It also occurs on my work computer, though I'm working with Magento, not Synapse; and it adds a string of url or span styles depending upon what part of the CMS I'm utilizing.
posted by stubbehtail at 5:18 PM on January 14


I'm not sure how you are typing into the text area, but if you are doing copy-and-paste, see if there is a "Paste as Plain Text" menu item instead of "Paste". Alternative, paste the text into a plain text editor (that doesn't do any fancy formatting), then copy and paste from the plain text editor into your CMS, and see if this solves the problem.

(The theory being that some of the formatting got carried over during the copy-and-paste.)
posted by applesurf at 5:26 PM on January 14


Speaking as someone who oversees a lot of content creation in a CMS, my guess is that there is a setting that allows the admin to "filter" the text that's added to the site. Specifically, to nuke from orbit any attempts to deviate from the fucking stylesheet.
posted by bricoleur at 6:27 PM on January 14


What browser?

Is the behavior different if you copy and paste text vs type text?
posted by wemayfreeze at 9:55 PM on January 14


Hmmm. Using Chrome. Will try it with FF and IE tomorrow.
posted by davidmsc at 10:56 PM on January 14


Try resetting the browser (not CMS editor) font size to normal.
posted by cogat at 1:34 AM on January 15


If it doesn't happen in other browsers on your work computer, check your autofill options in Chrome. Just like usernames and passwords, it may have saved the contents of that input box at some point.
posted by FreezBoy at 2:23 AM on January 15


Yeah - I've encountered this, and it is almost always a consequence of pasting text into the CMS. "Paste as plain text" in the CMS usually works, or Ctrl/cmd + shift + v (paste without formatting) in Chrome.

(I would insist that there are times when it does it _anyway_, but that might be human error...)
posted by running order squabble fest at 4:16 AM on January 15


I would additionally recommend, based on my job doing something that sounds very similar, that you paste into an intermediary plain text editor to be completely sure all the hidden tags are purged. Notepad used to be ideal for this, but I think I switched to Notepad++ when Microsoft made it too Word-like.

That particular markup looks very much like Word, by the way. Word is particularly prone to infecting the plainest of texts with hidden tags, in my experience. But of course everyone uses it when they're sending stuff to be published. My workflow used to be, get Word document, copy and paste it all into notepad, save plain text file, close Word document forever. That way no stray tags will creep in!

An added benefit is that you can organise the text layout the way you want it in the plain text, then add the formatting markup in the CMS without having to preview and wait for it to render. It was a trick most people who worked with me picked up after a while. (He says modestly.)
posted by danteGideon at 6:35 AM on January 16 [1 favorite]


« Older Several months ago, after thor...   |  I've been asked at work to com... Newer »

You are not logged in, either login or create an account to post comments



Post