Join 3,520 readers in helping fund MetaFilter (Hide)


Streaming nightmare!
January 6, 2014 7:12 AM   Subscribe

I am admittedly, new to streaming. I have followed every step of this guide. Justin.tv recognizes this stream because when I started it, it showed my streamed desktop as the thumbnail for my channel. But my stream will not actually stream. It just gives me a Failed to Load message. And on top of that, on my broadcast page, it only accesses my camera, which I do not want.

I have tried disconnecting my camera, which caused Justin.tv to yell at me.
I have tried disallowing Flash access to my camera, which made Justin.tv yell at me.
I have started my Broadcast by pressing "Start" on the Broadcast page, and the camera showed its feed. [This is not what I want.]
I have started my stream, and when I press "Start" on my Broadcast page, it comes Online and then immediately goes offline.
I have searched for a setting on Justin.tv that will look specifically for a Desktop stream, but have not found one. I found a website that claimed such a thing existed, but it does not anymore.

Can you help me?
posted by squirbel to Technology (15 answers total) 2 users marked this as a favorite
 
The justin.tv instructions say that your FME should appear as a device. Does it? Did you remember to start FME on your local machine?
posted by sbutler at 12:39 PM on January 6


I did, and it doesn't.
posted by squirbel at 2:30 PM on January 6


OK then, that gets you somewhere. It's possible FME isn't streaming to justin.tv for some reason. Under the "Encoding Log" tab does it say anything informative? In the same place with the "Publishing" subtab, does that looks like it's going to the right place on justin.tv?
posted by sbutler at 2:37 PM on January 6


I thought perhaps the data is getting to justin.tv, since the thumbnail for my channel is of my desktop.

It is set to go to my particular key, the logs look fine to me. But I am a noob, so here they are:

Mon Jan 06 2014 18:46:18 : Selected video input device: CamTwist
Mon Jan 06 2014 18:46:18 : Selected audio input device: Soundflower (2ch)
Mon Jan 06 2014 18:48:14 : Primary - Connected to FMS/3,5,7,7009
Mon Jan 06 2014 18:48:14 : Primary - Network Command: onFCPublish
Mon Jan 06 2014 18:48:14 : Primary - Stream[live_54500398_e66ey1ITgVXhF52PACtzTzzzzzzzzz] Status: Success
Mon Jan 06 2014 18:48:14 : Primary - Stream[live_54500398_e66ey1ITgVXhF52PACtzTzzzzzzzzz] Status: NetStream.Publish.Start
Mon Jan 06 2014 18:48:14 : Session Started
Mon Jan 06 2014 18:48:15 : Audio Encoding Started
Mon Jan 06 2014 18:48:35 : Video Encoding Started
Mon Jan 06 2014 18:50:20 : Audio Encoding Stopped
Mon Jan 06 2014 18:50:20 : Video Encoding Stopped
Mon Jan 06 2014 18:50:20 : Session Stopped
Mon Jan 06 2014 18:50:21 : Primary - Network Command: onFCUnpublish
Mon Jan 06 2014 18:50:21 : Primary - Stream[live_54500398_e66ey1ITgVXhF52PACtzTzzzzzzzzz] Status: NetStream.Unpublish.Success


I modified my key, but otherwise, isn't this how it should look?
posted by squirbel at 3:51 PM on January 6


I honestly think justin.tv is racist toward Macs.
posted by squirbel at 4:02 PM on January 6


Yes, that does look fine. Are you clicking the 'Broadcast' button on the justin.tv website? Don't do that, it's meant for people who want to use an emebed flash plugin (not you).

Does your live stream appear when you just go directly to your "My Channels" page? I didn't try with the desktop capture, but a webcam stream for me from FME to justin.tv automatically shows up in that spot.

PS... you forgot to sanitize your Secret Key in the log file :) Might want to regenerate that and download a new FME config when you get things working.
posted by sbutler at 4:15 PM on January 6


Ok... I removed characters and added z's, is that too little?

Yes, when I opened my channel page, it loads an ad, and then tries to load the video. Then it says "failed to load video."

I had my roommate (chrome book) try to load my channel, but we got the same thing. Then I tried on my iPad, which failed because the justin.tv app never loads videos ($9.99).
posted by squirbel at 4:27 PM on January 6


I'd redo the entire secret if I were you, but you're better off than I thought :)

I'm curious, if you disable the FME video stream does audio come through? What about disabling audio does the video come through? Can you stream your webcam through FME to justin.tv? Trying to narrow down what might be tripping it up. There's a lot of components in the mix here.
posted by sbutler at 4:32 PM on January 6


http://www.justin.tv/sueltate

streaming right now, can you see?
posted by squirbel at 4:33 PM on January 6


I have sourced the video from my webcam through Camtwist [the feeder for desktop video], and it did not show.

I have sourced the video from my webcam through FMLE directly, with no feed.

I unchecked the video feed, and left the audio active. It still did not feed.

All ended with "failed to load video".

I wish there were another streaming service. :(

I'm not looking to spend money, like upstream. :(
posted by squirbel at 4:49 PM on January 6


You have a live feed through the camera now, whatever setup you have active!

But I'm stumpted. One thing that always causes problems with live feeds is codecs. I always do H.264 and AAC. Anything else is often a crap shoot.
posted by sbutler at 4:51 PM on January 6


yeah, I also use those codecs because of their superiority.

But this is frustrating, because it means my fmle is not playing nice with my cam twist - which is the point of all of this!!

I'll keep plugging away at it, thank you for getting me this far!
posted by squirbel at 4:55 PM on January 6


Found the issue! It was with CamTwist. Thank you so much for getting me here!!
posted by squirbel at 5:00 PM on January 6


Hey, no problem. Stayed home from work today because of the cold :) Mind posting what it was for future people Googling?
posted by sbutler at 5:01 PM on January 6


Using Desktop+ is a bad thing. This is the option where you select an individual window to stream. Do not do that.

You have to choose Desktop.

Crop inside FMLE. :D
posted by squirbel at 5:05 PM on January 6


« Older The Peteyjlawsonmobile is dead...   |  Please recommend fiction about... Newer »

You are not logged in, either login or create an account to post comments