WIN7 Permissions, sharing and HTPC, so so much fail.
December 31, 2013 11:21 AM   Subscribe

How can I clear up whatever problem with windows 7 permissions is plaguing my new HTPC?

For a long time I had a crappy Acer Revo running Win 7 as an HTPC, with a 1TB external HDD connected for media storage. I recently upgrade to a custom built i5 HTPC box with a new install of windows 7.

Rather than copy all the media files, I just plugged the external hard drive into the new HTPC. That worked ok, but I encountered a lot of permissions errors trying to play files, even though I though I had taken ownership of the entire drive, with the ower set as my new user account on the HTPC. But I somehow got that mostly sorted, although I still occasionally have to click through a message about permissions.

The real problem comes when I try to shared the external drive with all the media files and access it over the home network from my laptop. I created a new homegroup with the HTPC, then joined with the laptop. I can see the shared external drive on the laptop, and even access the main directory, but whenever I try to access the TV Shows or Movies subdirectory, I get a permissions error. I don't understnad this, because the shared drive has "everyone" with "full control" access, and the Windows help documentation could not possibly be more byzantine.

What do I need to do to (a) clear up whatever permissions errors are still on the HTPC and (b) set whatever permissions need to be set to allow shared access across the home netowrk?
posted by T.D. Strange to Computers & Internet (3 answers total)
 
Apologies for not spellchecking.
posted by T.D. Strange at 11:24 AM on December 31, 2013


Ok, so if I am understanding correctly, you have a Windows 7 "media server/HTPC" box and a Windows 7 "laptop" box. Correct?

Going off that assumption, here are some of the things I would suggest looking into -

1. First, to make things easier, set the same username and password on both machines. By default Windows uses your user account/password to authenticate itself when sharing drives on another machine, so this makes it easier and seemless.
2. Second, login in administrator mode on your server. Press F8 before Windows boots and activate safe mode. Once in safe mode, open Windows Explorer, right click on your external drive (D:\ for example), go to properties -> Security -> Click on Advanced. Look around in the "Owner" and "Permissions" tab and change everything and make sure everything looks right. Set your username as owner, give yourself full permission etc etc. Now, reboot back to Windows 7 Regular mode.
3. On the media server, go to "Control Panel" -> "Network and Sharing Center" -> "Change advanced sharing settings" and enable "Turn on file and printer sharing" .
4. I don't know much about home groups, because frankly, you don't need them.
5. You don't have to create new shares or home groups. Let server ip address be 192.168.1.server. You can access the server drive by \\192.168.1.server\c$ to access C: drive, D$ for D: etc.

If you want, post some screen shots somewhere of the error and other stuff. I can try walking you through it.
posted by harisund at 8:16 PM on December 31, 2013


I don't know exactly how to solve your problem, and if you can find any other simple solution you should go for that. But I had a similar problem of ownerships on my external drives when I switched to a new laptop. I ended up using the cmd terminal window to recursively reset all the ownerships and access controls (ACLs) on all my files. I had to let them run a long time, probably over two evenings.

Like you said, the Windows documentation is hard to follow, so I'll reproduce some notes I took while doing it. The commands I ended up using are takeown and icacls.

Notes:

I think you need to open cmd.exe as Admin first
- type cmd in Win 7 task bar search
- right click on cmd.exe in search result
- pick "Run as Admin"

Run
takeown /f "h:\folder\subfolder" /r

- you can tell takeown to start at the the root folder, say "h:', but you might want to process smaller folders so you can monitor the process a bit better, and not have it running for hour upon hour.

Next run
icacls "H:\folder\subfolder" /reset /t

- icacls won't work properly if you specify the drive's root folder. It also doesn't like it if you specify "H:\*", so you're forced to run it multiple times, at least once for every top-level folder.

So I don't know if these are the best (or even a) solution to you're problem, but if it sounds good that's how to use them.
posted by benito.strauss at 12:00 AM on January 1


« Older I want to do target practice i...   |  Did Matt Smith quit, or was he... Newer »

You are not logged in, either login or create an account to post comments