Join 3,375 readers in helping fund MetaFilter (Hide)


Why won't this NASA site load properly?
December 5, 2013 6:32 PM   Subscribe

Last week, I started getting errors whenever I tried to access the NASA Technical Reports Server from Chrome. And after a few days of it working just fine in Safari, it started doing the damn thing in that browser as well. What's going on here?

The exact error I'm getting is:
Bad Request

Your browser sent a request that this server could not understand.
Restarting Safari seems to have temporarily fixed the problem, but restarting Chrome has not, and I'm worried I'll eventually get locked out in Safari as well.

I need reliable access to this site to do my job. Any ideas as to what might be going on here?

I'm on an iMac running 10.8.5 if it matters.
posted by Narrative Priorities to Computers & Internet (2 answers total)
 
Have you tried clearing all your browsing data in Chrome? Go to Settings, scroll all the way down, click on show advanced settings, click on the clear browsing data button, and tick everything, from the beginning of time, clear. Failing that, do you have any Chrome extensions active?
posted by un petit cadeau at 6:43 PM on December 5, 2013


I run a similar website for another part of the federal government. Have you contacted the site help email at the bottom of the page (help@sti.nasa.gov)? You will most likely get a helpful response. Folks running these kinds of sites really do care about making their content accessible, and really appreciate feedback. I also always am glad when a user reports a problem- it can make it easier to raise the priority of a given bug report.
what would make someone really smile is if you would provide a slightly longer anecdote as to why the site is essential to your job in your bug report. In these tight budget times, those kinds of anecdotes can really make a difference as to what stays and what goes
posted by rockindata at 7:15 PM on December 5, 2013 [2 favorites]


« Older Hello! I've landed an intervie...   |  Please offer suggestions for i... Newer »

You are not logged in, either login or create an account to post comments