Join 3,522 readers in helping fund MetaFilter (Hide)


SMTP Failure
November 27, 2013 3:27 PM   Subscribe

I am trying to do some household computer work for my dad, and his email problems are giving me a fit. Can you, o wise metafilter, help me?

He recently moved from Maine (Roadrunner) to Florida (Xfinity). His Roadrunner account is still active, and is his primary email. His computer runs XP, and he uses Outlook Express to read and "manage" his emails.

Recently, he has complained of getting an error message when sending emails. Specifically, it says: "The connection to the server has failed.

Account: pop-server.maine.rr.com
Server: smtp-server.maine.rr.com
Protocol: SMTP
Secure SSL: No
Socket Error 10060
Error Number 0x800CCC0E

I have read numerous boards, and the information appears accurate. I have tried different outgoing ports, but can't seem to fix this problem. I tried setting up another account on Outlook Express, but the same error occurred.

Please help me!

(Prior, possibly related question here may indicate that he CANNOT keep his email, but would like to have confirmation of this, if it is still true.)
posted by China Grover to Computers & Internet (9 answers total) 2 users marked this as a favorite
 
You usually have to use your ISP's SMTP when you're using an ISP's email. The Roadrunner one only works while you're on Roadrunner. I'm not sure if they're going to cancel his POP account or not, but he's definitely going to need to use his current provider's SMTP server.
posted by Sequence at 3:32 PM on November 27, 2013 [2 favorites]


His outgoing server may require a username and password to be entered. Another possibility is that he may have to use his ISP's outgoing mail server.
posted by The Great Big Mulp at 3:33 PM on November 27, 2013


Comcast/Xfinity won't let you use port 25 for sending emails. I guess I'd work through these assumptions

1. Is his roadrunner acct still active and is his password correct? (have him log in to webmail if they have it, or call them)
2. Does Xfinity allow this sort of email relaying (sending email from rr via xfinity) and if so, under what circumstances? Many ISPs do not allow this at all.

It seems like the configuration is correct but that doesn't mean it will work, necessarily, because of things that are set up on Comcast's end. Should be solvable with a phone call or two.
posted by jessamyn at 3:35 PM on November 27, 2013 [4 favorites]


His RR account does still work; I logged in and sent emails with it.

I'll make phone calls on Friday, to see if that will solve the issue. I'll continue to update as I hear more.
posted by China Grover at 3:57 PM on November 27, 2013


It's probably a port 25 block like jessamyn said. Try changing the SMTP port to 587 instead.
posted by zsazsa at 4:28 PM on November 27, 2013


SMTP relaying is generally no longer allowed by ISPs because it was a mechanism for sending spam. Just change the SMTP address to Xfinity's server and set the SMTP login to be whatever his Xfinity account credentials are. Also make sure the reply-to address is his Roadrunner account so replies aren't sent to his Xfinity account.

One other thing to consider is to use Roadrunner's webmail instead of a mail client like Thunderbird or Outlook Express, bypassing the situation altogether.
posted by briank at 4:44 PM on November 27, 2013


a bit of trawling through TWC's support site uncovered this in which they talk about port 25 blocking specifically and mention that they do allow connections on port 587. in addition to that, I was able to find this from Comcast that lists out which ports they block specifically. they do indeed block port 25 but they do not block port 587. so, you should be able to just change the outgoing mail port to 587 to get past Comcast's block.
posted by mrg at 5:15 PM on November 27, 2013


Unless they've changed it--which they might have, I haven't used RR's email in awhile--RR used to just plain not accept connections from elsewhere, their official support line was that if you want to send email from away from home you should use webmail or the SMTP server where you were. (There wasn't a login process at the time, either, so if they've added the need to login for SMTP then that might be different now.)

Using another server for SMTP has zero bearing on your incoming mail or what mail it shows up as sent from, so long as that's all you change in the client. So if you use pop.oldisp.net and switch to smtp.newisp.net, and your old email was somebody@oldisp.net, that email will still pretty much work like normal. It just gets routed through a different server on its way to the destination. This is why they get locked down so much; spamming with real or fake addresses is very easy.
posted by Sequence at 5:26 PM on November 27, 2013


This is absolutely normal.

Outgoing emails start their journey from your computer by being sent to an SMTP server your computer talks to directly. That server then passes them along to some other SMTP server, which passes them along to another and so on until they get to one belonging to the recipient.

It doesn't really matter which SMTP server your computer connects to, as long as it's got even an indirect connection with the recipient's SMTP server. And because SMTP was designed in an earlier, gentler age, and because the same protocol is used for both accepting jobs from email clients and relaying them from server to server, the original protocol includes no requirement for a computer that opens a connection to an SMTP server to identify and authenticate itself.

Since spam became the majority of email traffic, organizations that run SMTP servers have got quite picky about where they will let connections to those servers come from. If they didn't do this - if anybody in the world could just open a connection to a particular ISP's SMTP server and start handing it mails to deliver - then that server would pretty quickly be spending all its time doing nothing but processing spam.

There are two ways to deal with this: you can make your SMTP server do user identification and authorization before accepting a mail for delivery, or you can make it refuse to accept connections from computers other than those it exists specifically to serve. Most ISPs do both those things.

Authenticated connections happen via two slightly different extended versions of SMTP. One of these is essentially just old-skool SMTP run via an SSL-encrypted tunnel, and is usually available via port 465; the other does a bit of preliminary SMTP negotiation before setting up an SSL session for the rest - this is Transport Level Security or TLS, and you'll generally find it offered on port 587. Most email clients will support both.

Port 25 accepts old-school, non-encrypted, non-authenticated SMTP connections. To protect against SMTP misuse, an ISP offering an SMTP service on port 25 will generally (a) refuse to allow anybody but its own customers to connect to it (b) block all outbound connections from inside its network to port 25 outside it as a courtesy to other ISPs. Which means that if you're going to send SMTP traffic on port 25, you're going to be sending it to your ISP's own SMTP server; and if SMTP traffic is going to flow from your ISP's network to anywhere else, it's going to come from that same server rather than directly from your ISP's own customers.

So you might be able to fix your dad's Outlook Express settings by changing smtp-server.maine.rr.com to smtp.comcast.net. Ten years ago that's exactly what I would have done.

But it might not work. SPF has been invented since then, and there's a good chance that Comcast/Xfinity will be using it in such a way as to prevent anybody using their SMTP server to send mails that aren't from one of their own email accounts. The symptoms there would be that the connection looks like it's working but you get bounces when you try to send stuff, or sent mails just disappear into a black hole.

Which means that the right fix is to continue to use smtp-server.maine.rr.com, but connect to it via port 587 instead of port 25 (this is under the Advanced tab in OE's connection properties window) and check the associated box marked "This server requires a secure connection (SSL)". You will also need to check the box under the Servers tab that says "My server requires authentication" (leave "Log on using Secure Password Authentication" unchecked - nobody uses that), click the Settings button, and click the radio button for "Use same settings as my incoming mail server".

This solution has the advantage that it should continue to work regardless of which ISP the computer uses to get its Internet connection.

I've tested connecting to smtp-server.maine.rr.com port 587 via telnet from my own (not even slightly Roadrunner) computer and it works - I see it announce itself as an ESMTP mail server and it accepts the QUIT command - so I expect it will work for you too.

... may indicate that he CANNOT keep his email, but would like to have confirmation of this, if it is still true.

If he's going to continue to use a Roadrunner email address, he'll need to be paying Roadrunner to keep it alive. I don't know whether Roadrunner can offer him an email-only account (their support folks will know), but since most ISP email services are designed as freebie add-ons to the basic fact of an internet connection rather than particularly competent mail services in their own right, they're generally not worth what you'd pay to keep one going.

My best advice to people who have been using an ISP-provided mail service and subsequently switch ISPs is to dump the old one and start using a new service that isn't tied to any particular ISP, so that they only ever need to experience one episode of cutover pain.

I used to recommend Gmail for this, and that's still a reasonable choice if he'd be happy to keep using it via Outlook Express (Gmail users can send mails via SMTP and receive them via either POP3 or IMAP); it's absurdly capacious, it's free and it has excellent spam filtering. On the downside, operating a Gmail account via the web has now become quite unnecessarily irritating, and Google offers no meaningful customer support at all for its free mail accounts. Fair enough; you get the service level you pay for.

The best value I'm currently aware of in email-only providers is fastmail.fm. I've been using them for a while and so far I've been very happy with them indeed. If your dad has been happy with the kind of piddly mailbox capacity ISPs typically give their customers, he'd only need the cheapest available fastmail.fm account type at $10/year.

Be aware that any globally accessible mail service is going to be a target for password crackers and choose a strong one that you're not using for any other purpose.
posted by flabdablet at 5:15 AM on November 28, 2013 [2 favorites]


« Older I have health insurance, and t...   |  What's the name of this song t... Newer »

You are not logged in, either login or create an account to post comments