Join 3,512 readers in helping fund MetaFilter (Hide)

Tags:

How do I adjust the sound sync on my TV?
August 24, 2013 2:51 PM   Subscribe

When I watch TV, the sound is just a little bit off and it looks like everything is dubbed. What can I do about this?

I don't know what details are important, so here's a whole bunch of information. The TV is an LG 47CS570 47-Inch 1080p 120Hz LCD HDTV. We get cable from Comcast. We have a Tivo, a Roku, and a Sony DVD player.

The TV is hooked up to a Samsug sound bar thingy (I think it's this one). The problem happens when we listen with just the TV's speakers on, and also if we're using the sound bar instead.

The DVD player is plugged into the TV using an RCA cable. The Roku is connected to the TV with an HDMI cable. I can't easily see what the rest of the cables are, but will poke around further if that's significant.

The problem is particularly bad on the Spartacus DVDs we're currently watching, from Netflix. It also was terrible on a Tivo'd "Who's Line is it Anyway" that was accidentally recorded from the standard CW instead of the HD channel; the HD version was slightly better but still pretty bad, almost unwatchable. It happens with every show, as far as I've noticed, but sometimes it's worse than other times -- or possibly it's more noticeable with some shows because of how they're filmed (e.g. more shots where you see the mouth of the person talking).

The sound bar has an "audio sync" setting, but none of the delays seem to work -- in fact, I think it always makes it worse. So possibly the problem is that the sound needs to come faster and the picture needs to be appear slower. A picture delay instead of an audio delay.

Advice?
posted by The corpse in the library to Technology (12 answers total) 1 user marked this as a favorite
 
Does the TV have its own audio sync setting? Mine allows for positive or negative audio delay.
posted by Rock Steady at 3:23 PM on August 24, 2013


It doesn't have audio sync settings, not that I can find.
posted by The corpse in the library at 3:33 PM on August 24, 2013


I don't have your TV but I checked out the menu structure at LG.com-- first I'd try turning off all the visual enhancement options (Noise Reduction, MPEG Noise Reduction, Black Level, Real Cinema, Motion Eye Care, TruMotion) to see if the filters are accidentally introducing some sort of sync issue.
posted by bluecore at 3:58 PM on August 24, 2013 [2 favorites]


Our DVD player had an audio +/- option under the audio setting panel when you went into the "setup" options. You could advance or retard the audio. I don't know if Roku players offer that, though it's possible it might be a setting in the Netflix or Hulu player itself.
posted by yoink at 4:28 PM on August 24, 2013


Weird that it's doing it with internal speakers. Quick searches reveal the following:
- might need to call customer support for firmware update (usually a file that can be downloaded and installed via USB drive, but I don't see any firmware files on LG's site for your model)
- there might some sort of magic
"calibration" time that needs to pass. But this seems... strange to me
- a search through AVS Forums didn't turn anything up, but you might have better luck.

Questions I've gotta ask:
- if everything is disconnected from the TV, is the sound from the TV's speakers in sync with what's on screen?
- how, exactly, are all of your components connected? That is, what cables are used and where are they going?
- would you clarify how things are out of sync, and if it's consistent? That is, is the audio ALWAYS delayed, or is it always such that the picture ALWAYS seems delayed? How does changing the delay on the sound bar affect sync (what are the settings, and as they're increased/decreased, how is the audio/video sync affected)?
- do you have a TruMotion option? Does turning it on/off change things? If so, how?
- do you have a Game Mode picture option? Does turning it on/off change things? If so, how?

Speaking from personal experience, I wish you much luck and minimum frustration. In the end, my AV sync options got fixed with newer HDMI cables, and throwing ALL video sources to a receiver, and a single HDMI cable to the TV. Doesn't look like your sound bar has that many HDMI inputs though.
posted by herrdoktor at 4:35 PM on August 24, 2013


Hey, I noticed that on Whose Line too! It was bad on SD, tolerable on HD, and unwatchable on Youtube.
posted by KathrynT at 5:43 PM on August 24, 2013


I too was going to mention resetting the TV to factory settings, and then if that doesn't help, setting it to video game mode.

I'd bet that the TV is overdoing it with some kind of visual processing. The fact that it happens on SD (dvd and sd Whose Line Is It Anyway) leads me to believe this is true. "Smart" TVs will try to clean up SD signals to make them look a little nicer on the giant screen.

Video game mode (is supposed to) shut all that stuff down.
posted by gjc at 8:01 PM on August 24, 2013


Thanks for all the suggestions. Sitting here watching a DVD of Spartacus, I'm trying:

TruMotion I turned it off and I think it made the sync worse, so I set it back to "low."

Picture Mode: switched to "Intelligent Sensor," and that seems to have helped -- which is weird, I would think that would make it worse, but it's been the best option so far.

Real Cinema: turning it off might have it worse, so I turned it back on.

Various AV Mode settings: Cinema might be better, Sport might be worse, Game might be worse. I left it off.

Watching an episode of "Elementary," on the Tivo, recorded in HD, the sync is bad with the above settings. "Whose Line" is badly synced in Game Mode or not, but it sounds like that might not be just my TV. An episode of "Inspector Morse," Tivo'd in SD, made me realize all those hideous clothes are back in style but also the sync seemed fine.

I can't see how everything is plugged in right now (it's a two-person job and I'm the only person free right this sec because nobody else appreciates how awful this situation is) but I'll investigate ASAP.

> would you clarify how things are out of sync, and if it's consistent? That is, is the audio ALWAYS delayed, or is it always such that the picture ALWAYS seems delayed

The audio always seems delayed. It's worse on some shows than others. This might be because some shows have more time when you see the people talking; if I can't see the person's lips, it isn't a problem. But "Spartacus" has been particularly bad. It could be that DVDs are bad in general and I hadn't noticed because I don't use the DVD player much, and when I do it's usually for kids' animated movies where it wouldn't matter.
posted by The corpse in the library at 9:28 PM on August 24, 2013


A couple of suggestions: one--have you tried updating the firmware? two--have you tried doing a hard reset (or "factory reset") on the TV (there should be instruction in the manual)?
posted by yoink at 9:34 PM on August 24, 2013


Wow, I didn't even consider that the audio would be delayed. I just assumed that the video would be the thing. All my advice is wrong, in that case.

I would start by eliminating the sound bar. Unplug it. Same thing with any other switchers, combiners, etc in the process. Yes, this will be a pain.

Then, proceed to check whether the problem can be narrowed down to one type of input or another.

If you can get your hands on an older television, try plugging the different sources into it and comparing the results. This will help prove that the problem is or isn't the LG tv.

And have you read the manual for the TV cover to cover? When all else fails.... (Seriously though, many AV appliance manuals are terrible. A really important thing can often be buried in plain sight.)
posted by gjc at 2:13 AM on August 25, 2013


In case you're still reading this and haven't solved the problem...

Check if you have the output mode of the TV set to RAW (bitstream) or PCM. The soundbar *may* have better A/V sync when decoding the audio compared to having the TV decode and send the PCM audio to the speakers or soundbar. So if you change the setting to bitstream and output to the soundbar you may have better performance.

You could also check the same on the DVD player to see where the decoding is taking place and if that makes a difference.
posted by TwoWordReview at 1:25 PM on September 13, 2013


Still working on this. A hard reset didn't work. LG customer support didn't work. It doesn't seem to be one type of input in particular. I'll keep trying your other suggestions, thanks.
posted by The corpse in the library at 9:20 AM on November 14, 2013


« Older Does anyone have the settings ...   |  I am trying to identify a tree... Newer »
This thread is closed to new comments.