Skip

Help fix my hotel wireless
March 1, 2013 2:28 PM   Subscribe

Can't get my hotel wireless to work on my MPB running Mountain Lion. Help!

At a hotel in Duluth, MN. Trying to get the wireless to work on my MPB, Mountain Lion. Wireless is working for everyone else and on my phone -- just not my laptop.

The facts:

-Wireless doesn't require a password, but does first require a connection to the hotel's site (like when you sign into Starbuck's Internet).
-In Chrome, I get an Error 107 SSL protocol error.
-In Safari, the site trying to get to the welcome page just endlessly loops and never connects.
-The page trying to connect says: 192.168.100.1/login?username=username&password=password (note that I don't need a username or password -- the router is bypassing this step by filling it in for me)

What I've tried:

-Firewall on and off
-Renewing my DHCP lease
-Restarting the browsers, computer and wireless connection

The internets say to check my Proxy settings, but nothing is checked or notable about the settings.

Help me so I don't lose my mind on this work trip? The front desk wasn't helpful (and it's an issue on my end, so not their fault). Thanks.
posted by Zosia Blue to Computers & Internet (13 answers total)
 
Usually what I do first when traveling is to make a new Network Location. This way you don't have to worry about checking the firewall or DHCP or proxies or whatever—you're starting with a fresh, blank canvas. And when you go home, you can just switch back and not have to worry about getting everything back exactly the way it was.
posted by bcwinters at 2:34 PM on March 1, 2013


Did you turn off the firewall, then reboot? (sorry if that's obvious. It worked for me once in a hotel.)
posted by barnone at 2:34 PM on March 1, 2013


Oh, and zap the pram.
posted by barnone at 2:35 PM on March 1, 2013


A lot of those wireless login pages fail miserably if the first page you try to hit is an https connection. Go to http://ask.metafilter.com first to see if that gives you the login page properly.
posted by advicepig at 2:36 PM on March 1, 2013


Thanks so far. Tried turning off firewall and rebooting, making a new location and connecting to Ask first -- no luck yet. PRAM zap imminent. Will let you know.
posted by Zosia Blue at 2:41 PM on March 1, 2013


What advicepig says.

I would do this:
1. Click here, tell us what happens.
2. If that fails, call the Lobby and ask them. Really - there are paid people there who already know the answer!
posted by devnull at 2:43 PM on March 1, 2013


No luck. I already spoke with the lobby and their best guess was "restart your browser." Since this is something with my computer (I'm guessing), this is beyond their skills right now. Rats.
posted by Zosia Blue at 2:51 PM on March 1, 2013


They have several sub connections in addition to the main connection, and occasionally, one of those will kick in, work for a few minutes, then time out. I'll stop threadsitting. Thanks for the advice!
posted by Zosia Blue at 2:53 PM on March 1, 2013


Hmm. Another thing that worked once was deleting that network before restarting.

Turn your wifi off. In your System Preferences, delete that wifi network from the remembered list of networks. Then restart, start a new location, turn on wifi, add that network.

And pray to the wifi gods.
posted by barnone at 2:55 PM on March 1, 2013


Try this: How To Fix OS X Mountain Lions Wifi Issues.

Maybe try Google's Public DNS? Configure your network settings to use the IP addresses 8.8.8.8 and 8.8.4.4 as your DNS servers or see that link for more instructions.
posted by barnone at 3:04 PM on March 1, 2013


Are you, by any chance, running a popup blocker? If so, turn it off. That's going to prevent the hotel's proxy popup from coming up.
posted by The Bellman at 3:11 PM on March 1, 2013 [2 favorites]


Oh yes, popup blocker, and the AdBlock extension!
posted by barnone at 3:13 PM on March 1, 2013


Thank you, everyone! I left my room for several hours, came back and it just...worked. Maybe it wasn't me after all. Thank you for your suggestions.
posted by Zosia Blue at 7:11 PM on March 1, 2013


« Older I may be, literally, the worst...   |  I would like to landscape usin... Newer »
This thread is closed to new comments.


Post