Join 3,512 readers in helping fund MetaFilter (Hide)


Connecting from Mac OS X 10.8.2 to Windows Server SMB file shares
February 21, 2013 4:56 PM   Subscribe

I'm trying to connect a Mac running OS X 10.8.2 to an SMB share in Windows Server 2008 R2 over a site-to-site VPN but I'm having issues. A Windows XP computer that is in the same network as the Mac does not have a problem mapping a drive to the share.

I followed the instructions here but got stuck at step 3 the 'Connect to Server' window. When I type in smb://SERVERNAME/Documents (where SERVERNAME is the actual server name) then click the connect button another window with a loading bar opens for a second, then it disappears and goes back to the 'Connect to Server' window. There's no error message or window asking for credentials. I tried using an IP address, the hostname, a Windows 2003 share, even a nonexistent IP address and it does the same thing.

The Mac can ping the server and when I do a port scan from the Mac it sees that port 139 is open on the server. I also tried connecting the Mac through PPTP outside of the site-to-site VPN and the same problem happens.

Oh, and when I say IP address, it is the server's internal (192.168.4.x) address. The Mac is on a different subnet (192.168.1.x) connected through the site-to-site VPN.

Unfortunately, I cannot test another Mac in the same physical location as the server because I don't have one. Also, that's another problem - I don't know how to use OS X much, so I don't know if there's a log that I should be checking for more information.
posted by pombiki to Computers & Internet (5 answers total) 2 users marked this as a favorite
 
I think the SMB prefix is outdated.

Use CIFS://serverIP/sharename
posted by pompomtom at 5:02 PM on February 21, 2013


(also: if you're having trouble use the IP rather than the name, to start with...)
posted by pompomtom at 5:02 PM on February 21, 2013


smb://server/share is still valid syntax in 10.8.2, pompomtom.

pombiki, does it do the same thing if you simply enter smb://192.168.4.x to connect to the server? My suspicion is that the share name is being specified incorrectly. (You should be able to choose the share after authenticating to the server's IP address if you don't specify a share name.)
posted by I EAT TAPAS at 5:07 PM on February 21, 2013


Yes, it does the same thing if I simply enter smb://192.168.4.5
Sorry for not mentioning it earlier. I did not try cifs://192.168.4.5 though.
posted by pombiki at 5:20 PM on February 21, 2013


You might get a little more error detail from the command line client: step by step instructions here, and 'man mount_smbfs' will give you a few more options to consider.
posted by Monsieur Caution at 5:29 PM on February 21, 2013


« Older Help me find a great saxophone...   |  How can I use my product key t... Newer »
This thread is closed to new comments.