iDidntAskForThis
February 4, 2013 6:02 AM   Subscribe

My wife's iphone is sending SMS (sometimes) to my ipad's "imessage" app instead of to my phone! Please halp!

My wife has a brand new iphone 5 (on Verizon Wireless).
I have an android phone (also VZW), and a (wifi-only, iOS 6) iPad3.
The ipad is linked to the same email account as my phone is, if that is relevant.
As far as I know, my ipad knows nothing about my phone number.

Normally, when she sends me texts, they properly show up on my phone.
But I went away for the weekend, and when I came home, I had several "notifications" on my ipad from the iMessage program -- which I never use -- with texts that she claims she sent to me over SMS.

How do I stop this behavior? I do not want my ipad intercepting texts meant for my phone, and I'm confused about how they are getting there in the first place.
Is it a setting she has to change in her phone? Or a setting I have to change in my ipad?
Or do we have to get Verizon involved somehow?

Other possibly-relevant facts:
* I did have my ipad with me, but the hotel wifi was flaky so I didn't use it very much. I don't know whether these "lost" texts came in while my ipad was on hotel wifi or not, but I didn't see any of the notifications at the time.
* I also did receive some texts "normally" on my phone from her throughout the weekend. It was just a few messages that went to the ipad instead.
posted by jozxyqk to Computers & Internet (31 answers total) 4 users marked this as a favorite
 
iMessage is an Apple-device-to-Apple-device service meant to save your text minutes by sending messages over a wifi or data connection (it also has other incidental features). This is how it works.

It is likely that somewhere along the way, your phone number was associated with your Apple ID. Follow the steps at the end of the page I linked above to see if your phone number is in the iMessage settings in your iPad. You can then unlink it or turn off iMessages entirely.
posted by payoto at 6:16 AM on February 4, 2013


Also, note that she can tell from her end whether a message has gone to your iPad via iMessage or whether it's gone to your phone over SMS.
posted by payoto at 6:19 AM on February 4, 2013


If i turn off imessages entirely, will facetime stop working?
posted by jozxyqk at 6:20 AM on February 4, 2013


If i turn off imessages entirely, will facetime stop working?

No, just iMessage.
posted by inturnaround at 6:21 AM on February 4, 2013


Also.. how would she know if the message went to my ipad instead of the phone? She just got her iPhone about a month ago after a few years of having Android phones, so I doubt she'd notice unless it was a big red flashing notification.
posted by jozxyqk at 6:23 AM on February 4, 2013


Also.. how would she know if the message went to my ipad instead of the phone?

It's all there in the link above from Apple -- the sent message on her phone will be blue if it went through iMessage, green if SMS.
posted by payoto at 6:24 AM on February 4, 2013 [1 favorite]


iMessages have a speech bubble with a blue background.

Regular text messages have a green background.

It will also say "iMessage" or "text message" at the beginning of the conversation in the Messages iPhone app.
posted by kathryn at 6:25 AM on February 4, 2013


As an editorial note, this is a very bad feature, if it can accidentally send messages to a not-meant-for-texting iOS device.
Is there at least a setting my wife can put in her own phone to say "never use imessage to send messages to this number/contact"?

I don't have my ipad in front of me to check any such settings right now, but I will certainly poke around the settings to see if my phone number somehow got associated with it.
posted by jozxyqk at 6:30 AM on February 4, 2013


As an editorial note, this is a very bad feature, if it can accidentally send messages to a not-meant-for-texting iOS device.

Agreed. IMO, this setting should never be enabled by default on an iPad or iTouch -- iPhones, sure.

Is there at least a setting my wife can put in her own phone to say "never use imessage to send messages to this number/contact"?

No, this is something you have to do from your iPad unless she wants to turn off iMessage entirely.
posted by payoto at 6:34 AM on February 4, 2013


Another thing to check is if your wife has your email address associated with your contact entry on her phone. When I go to send a message to a contact with both a phone number and email address in my contacts list (on my iPhone 5), there are two options: send a message to the contact at the email address or send it to the contact at their mobile phone number.

I suspect that any messages sent to your email address contact would go to your iPad. You could either tell your wife to make sure she always sends messages to your mobile number or, if you like, just delete your email address from your entry in her Contacts list.
posted by Betelgeuse at 6:37 AM on February 4, 2013


Any explanation for why it only might have happened for a subset of texts, when 90% of texts behaved expectedly?
posted by jozxyqk at 6:46 AM on February 4, 2013


(Sorry for babysitting the thread and sorry for more editorial-commentary-toned responses)

And deleting my email address from the contact entry is not really an option; she might want to send me an email from her phone and it's stupid for her to have to manually enter it because of this imessage garbage.
posted by jozxyqk at 6:47 AM on February 4, 2013


Any explanation for why it only might have happened for a subset of texts, when 90% of texts behaved expectedly?

It can only do iMessage when both devices have an internet connection. If your iPad wasn't connected due to intermittent wifi at your hotel, her phone would send the text over SMS.

And deleting my email address from the contact entry is not really an option; she might want to send me an email from her phone and it's stupid for her to have to manually enter it because of this imessage garbage.

I doubt the issue is email because you specifically said that the messages came through on iMessage. The very simple solution to your problem is to disable iMessage on your iPad. In the meantime, if it'll be a while before you can get to your iPad, you can have her:

- disable iMessage on her phone,
- disable iMessage only to send you texts, then reenable it, or
- when she sends you a text, immediately long-press the text bubble to select "send as text message"
posted by payoto at 6:52 AM on February 4, 2013


Also (sorry, just one more), my ipad is set up in such a way that I probably won't see any notifications at all, because I bypass the lockscreen entirely. I use a bluetooth keyboard which instantly unlocks it (from screen-off directly to home-screen) when i hit a key.
The only reason I even checked the notification bar at all was because of another app which happened to pop up a notice about something entirely unrelated, and I dragged it down only to find 5 or 6 "texts" from the previous day from my wife's phone.

Awful. Just awful.
posted by jozxyqk at 6:54 AM on February 4, 2013


I don't know that 'awful' is quite the right word. Apple IDs are meant to be per-person. It sounds like you are sharing the same Apple IDs on both devices — simply having the email portion enabled on both devices is categorically *not* enough to cause this behaviour. This may have happened by accident, or it may be the result of you sharing an Apple ID for some other things and having that info attach to your device as a whole. Do you share apps from the app store, perhaps? Even if you don't, syncing the two devices with the same computer may have caused the iPad to pick up the apple ID from there automatically.

As a test, go to the app store on each device and download a different free app on each that you haven't previously downloaded. The box that pops up asking you for a password will display the email address (which is your apple ID account) above the password entry field. If the same email address appears on both, that's what's happening, so the best thing to do would be to set up a new Apple ID for whoever doesn't yet have one. Is your iPad shared, or is it *yours*? Depending on the answer, it may well be simpler to just disable iMessage on the iPad rather than follow my 'set up a new apple ID' advice.
posted by jaffacakerhubarb at 7:26 AM on February 4, 2013


It sounds like you are sharing the same Apple IDs on both devices.

Nope. We definitely have different Apple IDs. We have never shared them.
I'm not sure how that would have anything to do with the problem anyway.

The target where the SMS is "supposed to be" going is a non-Apple phone (in this case Android, but it could just as well be Windows Phone, Blackberry, or a dumbphone).
The messages apparently (according to the answers so far) only went to my ipad because they were sent at the exact moment my ipad was connected to hotel wifi, and there was this imessage component that I wasn't aware of. And since I wasn't looking at the screen at the time, I never saw any notification.

When we are both home, we'll do some experimenting with imessage enabled/disabled on each iOS device, and see what the proper configuration is so that texts ignore my ipad.

I'm just not sure how my ipad's imessage app got associated with texts to my phone number in the first place, since I have never owned an apple device that was a phone.
posted by jozxyqk at 7:34 AM on February 4, 2013


As an editorial note, this is a very bad feature, if it can accidentally send messages to a not-meant-for-texting iOS device.
Is there at least a setting my wife can put in her own phone to say "never use imessage to send messages to this number/contact"?


For this to happen she has to message you via your email in your contact, not your phone number. It is a little cryptic interface-wise, but I think you're misunderstanding what's happening. She's sending iMessages to your apple ID via an email in her contact for you, not to your phone number, and consequently it gets sent to any device associated with that apple ID.

To see whether this is happening, when you go to the top of a message sequence in the phone's app, and tap `contact', the target of the messages in that sequence is blue. This will either be an email or a phone number. When you send a new message to a contact, you have to choose whether to send it to a number (picking one number of people have multiple) or an email, which will use apple ID if that person has one associated with that email. This is the most cryptic part, as it may not be apparent what this choice entails -- but if she starts a completely new message to you and chooses your phone number, it should always go to your phone. Probably there are actually two message sequences with your name in her messaging app, it isn't clearly indicated without looking at the contact part where exactly each one would send to.
posted by advil at 8:03 AM on February 4, 2013


She was sending the messages in the same exact way she always sends them.
And some of the messages came to my phone as texts, while some of them ended up on my ipad.
I don't think she ever specifically chose one or the other for me as a contact. She wouldn't have done that on purpose.

I figured out one other variable, in the meantime: Since we have used facetime between those devices before, maybe there was some "flag" set on my contact where her phone knew that i had an iOS device and maybe my phone number isn't involved.

Even if it ends up being a simple configuration-change option on the ipad (which I won't be able to verify for another several hours), I am still surprised that they allowed this to be default behavior on wifi-only devices.
posted by jozxyqk at 8:14 AM on February 4, 2013


I had the same problem after the last iOS update. What worked for me was to go to the settings menu on the iPad, select Messages, then Send & Receive and disable the phone number on the iPad. After that, it worked fine for me.
posted by eau79 at 8:35 AM on February 4, 2013 [3 favorites]


if she starts a completely new message to you and chooses your phone number, it should always go to your phone.

This isn't true. If both devices have iMessage enabled and both devices are connected to the Internet, the message will be routed to the iPad through iMessage even if she sends the text to jozxyqk's phone number. This is the whole point of iMessage, to bypass SMS.
posted by payoto at 8:39 AM on February 4, 2013


This isn't true. If both devices have iMessage enabled and both devices are connected to the Internet, the message will be routed to the iPad through iMessage even if she sends the text to jozxyqk's phone number. This is the whole point of iMessage, to bypass SMS.

Just to be clear, the OP's phone is not an iDevice, so this shouldn't be an issue. I stand by my "sending it to the email version of the contact rather then the phone number version of the contact" theory.
posted by Betelgeuse at 9:47 AM on February 4, 2013


I should say, regardless of who is right, turning off iMessage on the iPad should fix the problem.
posted by Betelgeuse at 9:49 AM on February 4, 2013


Just to be clear, the OP's phone is not an iDevice, so this shouldn't be an issue. I stand by my "sending it to the email version of the contact rather then the phone number version of the contact" theory.

Right, and the fact that the phone isn't an iDevice is why the messages from his wife bypassed his phone entirely. If the phone were an iPhone the messages would go both to the phone and to the iPad.

The third post here is a description of the scenario from a Blackberry user who had the same problem.
posted by payoto at 10:13 AM on February 4, 2013


ust to be clear, the OP's phone is not an iDevice, so this shouldn't be an issue. I stand by my "sending it to the email version of the contact rather then the phone number version of the contact" theory.

Yes, this is what I was assuming too, and I also still think this is what's happening, it's just that the UI for indicating this is not very intuitive. Also, I took OP's saying his ipad doesn't know about his non-iDevice phone number to mean that his apple account doesn't know about it either (which would be necessary for the scenario in payoto's link) but if this is wrong OP -- make sure your apple account doesn't have your cell phone.
posted by advil at 10:42 AM on February 4, 2013


And deleting my email address from the contact entry is not really an option; she might want to send me an email from her phone and it's stupid for her to have to manually enter it because of this imessage garbage.

You could set up two contact entries for yourself, one with just your email "jozxyqk email" and another one with just your phone number "jozxyqk phone"
posted by juv3nal at 10:56 AM on February 4, 2013 [1 favorite]


And deleting my email address from the contact entry is not really an option

She doesn't have to delete it, she just has to not pick it when sending a new message. That choice is _always_ offered as far as I can tell, but as I said, it isn't necessarily clear what the consequences of the choice are and it wouldn't be hard to mis-tap.
posted by advil at 11:03 AM on February 4, 2013


Even if it ends up being a simple configuration-change option on the ipad (which I won't be able to verify for another several hours), I am still surprised that they allowed this to be default behavior on wifi-only devices.

It's one of the selling points of the ipad. She is not sending texts to your phone number, she is sending it directly to your ipad using contact she created for facetime.
posted by empath at 11:15 AM on February 4, 2013


The new iOS update last week caused all texts received on my iPhone to also display on my iPad. I didn't change any settings. FWIW.
posted by raisingsand at 11:18 AM on February 4, 2013


You could set up two contact entries for yourself, one with just your email "jozxyqk email" and another one with just your phone number "jozxyqk phone"

This won't solve the problem. Even if his wife originates a text by pulling up the phone-number contact, Apple will attempt to route the text through iMessage as long as jozxyqk's cell phone is associated with his Apple ID and he has iMessage enabled on his iPad.
posted by payoto at 11:32 AM on February 4, 2013


So, I finally got a look at her iphone, and asked her exactly what she did, and it turns out that it might have been a misclick after all (selecting me-by-email from a list instead of me-by-phone-number).
She has 2 different "threads" in her messaging list, one is clearly the separate set of messages that got sent to imessage that day.

So some of my frustration/anger in the thread could be unjustified and based on a misunderstanding of how this system works.
posted by jozxyqk at 4:54 PM on February 4, 2013


In that case, jozxyqk, it sounds like everything is working the way it's supposed to. It's easy to accidentally split a message thread on an iDevice because the name shows up exactly the same, but they're two different threads going to two different contacts you have for that person. Her phone probably let her send the iMessage because it knew your email was associated with an iDevice from your previous facetiming.
posted by MadamM at 6:08 PM on February 4, 2013


« Older Should I be worried about the ...   |  How do I make the softest, clo... Newer »
This thread is closed to new comments.