Why won't Spanish keyboard produce "at sign"?
January 9, 2013 8:12 AM   Subscribe

We have a Spanish keyboard where "@" is on the Q and AltGr is present. I'm on a Win7 machine with Office 2007. I can't type "@" using AltGr+Q, right ctrl+AltGr+Q, shift+AltGr+Q, or right ctrl+shift+AltGr+Q. Please help me figure this out!

I'm trying to help a customer solve this problem, too, but their set-up is different. I'm providing my set-up because I can't even do the most basic test of what's going wrong for them if I can't make this character with this keyboard. I tried in an online form, Notepad, and Word.

After looking at various requests for help and detailed instructions online, I can see that this isn't uncommon, and have tried the following things:
• Verified drivers for keyboard were installed - yes.
• Changed keyboard language (but maybe I didn't do this right?)
• Changed editing & primary language in Word and restarted it (again, maybe there's a trick to this?)

...none of that worked. I didn't restart my machine after installing the keyboard. Maybe I should have? I was able to type all of the first level and shifted characters, no problems.

From everything I've read, AltGr+Q really should have been the end of it, and only tried the other combos based on advice elsewhere. Why isn't this working? What haven't I done? What might be wrong?
posted by batmonkey to Computers & Internet (8 answers total)
 
What language is the keyboard set to in your control panel preferences?
posted by MuffinMan at 8:30 AM on January 9, 2013


What did you change the keyboard language to? On some Spanish keyboards (if you changed it to something else Spanish), the @ is on the 2, and Alt+2 should get you the symbol.

Did you simply enable another keyboard input language without changing to it (i.e., adding English or another Spanish keyboard as one of the inputs, but not actually changing your input method to that?)? Make sure the keyboard language you want is selected down in the lower right (where you should see "EN" or "ES" or whatever language you're looking for). Alternately, you can switch between keyboards using Alt+Shift. (Here is a handy reference if you're not sure you did it right.)
posted by pitrified at 8:32 AM on January 9, 2013


Try using the on screen keyboard to see if it matches.
posted by empath at 8:38 AM on January 9, 2013


I use a Canadian French keyboard and just switched my language settings over to Spanish (Traditional). As with French, the @ is AltGr+2 - could that be it for Spanish?
posted by urbanlenny at 9:30 AM on January 9, 2013


I had it set to Spanish (Mexico) x Latin America. I moved this up to primary position and clicked "Apply". Didn't think to check right bottom corner.

Alt+2 and AltGr+2 didn't work - like I said, the @ is on Q, so that seemed an expected fail.

empath: great idea! Why did I not think of that?

I'll finish the form I'm on now then try y'all's suggestions. Anyone else is welcome to throw in other ideas, too, because what works for me might not work for the person I'm trying to help.
posted by batmonkey at 9:32 AM on January 9, 2013


Yes, on Spanish (Mexico), my keyboard does indeed produce an @ on the Q key with AltGr.

Do your other AltGr characters work as expected? There should be a ¬ produced using AltGr and the key next to the 1 key, which seems to produce a horizontal bar as default and a ° on shift.
posted by urbanlenny at 9:47 AM on January 9, 2013


What about trying ALT-64? That is the actual ALT code for the @ symbol, though I don't know if ALT codes still work in Windows 7. (They work in XP, the last version of Windows I ever tried them in.) In order to use ALT codes, you need to use the numeric keypad on the right-hand side of the keyboard, NOT the row of numbers at the top of the keyboard (above the QWERTY row). Just hold down the ALT key then hit 6, then 4, then release the ALT key and that should do it. I just tried it in XP and it worked.
posted by Conrad Cornelius o'Donald o'Dell at 10:11 AM on January 9, 2013


Just checked - Alt-64 for @ still works in Windows 7.
posted by Gomez_in_the_South at 4:18 PM on January 9, 2013


« Older How do you decide what books t...   |  Sometimes, I am a front-end we... Newer »
This thread is closed to new comments.