Skip

How to hide updates in Facebook ticker?
January 5, 2013 4:34 PM   Subscribe

How do I hide certain updates from the Facebook ticker on my main page? (The ticker is that real-time-updating list of news on the right side of the web page.) In particular, I want to hide updates from Words with Friends (e.g. "Aunt Idontgetsettings played OLD in Words With Friends") and Spotify.

Facebook help claims that one can simply:
1. Click a story you see in ticker
2. Click the menu in the top right
3. Choose "Hide story"

But I the menu doesn't show up for me. When I click any story in the ticker, it pops out with the full story to the left. When I mouse over that popout to the left, there is no menu in the top right. The only thing is an "x" in the top right, and when I click that the only option is "Report story or spam".

Facebook Help also presents an alternative, which is to hide these stories from my Newsfeed. But this Spotify/Words with Friends garbage doesn't show up in my Newsfeed, so I don't have the opportunity to hide it from there.

I'm using Chrome, but had same behavior in Firefox.

Thanks!
posted by bigjoec to Computers & Internet (11 answers total) 3 users marked this as a favorite
 
FB Purity has been a godsend for this kind of thing. With it, I can not only block annoying games invites, but also updates containing certain words. I mostly use it to hide updates from otherwise likeable people who live-blog sporting events.
posted by peppermind at 4:49 PM on January 5, 2013 [3 favorites]


You should be able to go into your privacy setting and manually adjust what the apps have access to and/or who can see the alerts.
posted by DoubleLune at 4:56 PM on January 5, 2013


Thanks for your responses.
Peppermind - I'm looking to accomplish this through Facebook settings. A browser extension would be a last resort.
DoubleLune - I'm looking to hide the spam updates from _other users_ that show up in the ticker on my main page. (All the apps I use, I set to not broadcast anything publicly.)

Anyone know how to accomplish this?

Thanks.
posted by bigjoec at 5:13 PM on January 5, 2013


if you don't want to see comments & likes from your friends go to your 'friends page' and roll over each friend's 'name', then on the window that pops up roll over 'friends' and then click on 'settings'. uncheck 'comments & likes'. i've tried doing this on the main update feed page but for some reason it doesn't always work and i find it works best when done on your friends' page. be warned that it doesn't even always work there either. sometimes their comments & likes still show up after unchecking the settings.

if you don't want to see the ticker at all just collapse it--there is a little gray arrow at the top right of it to do that. that's what i do.
posted by wildflower at 5:24 PM on January 5, 2013


wildflower has the right idea. I think the setting you want to uncheck for Words With Friends, though, is Games. I think Spotify is "Other Activity". You'll have to do this for each person whose activity is annoying.
posted by donnagirl at 6:18 PM on January 5, 2013


What wildflower said. Also uncheck Games.

Also, if they send me a game request, I go to the App Center (you can go there from the left sidebar), find the requested game, and block it.
posted by Doohickie at 9:33 PM on January 5, 2013


If you do get a browser extension, Social Fixer (formally Better Facebook) has been pretty good for me.
posted by titanium_geek at 12:51 AM on January 6, 2013 [2 favorites]


I came to vote for Social Fixer too. A browser extension is going to keep doing what it's meant to do, even if Facebook spontaneously changes its code (which happens with irritating frequency, as I'm sure you've noticed). It's also going to be a hell of a lot easier and simpler than using FB's own settings.

The chap who wrote Social Fixer is also very dedicated to making sure the extension is behaving consistently despite any code changes.
posted by Jilder at 7:18 AM on January 6, 2013 [1 favorite]


Thanks. The Friend->"Settings"->"Types of updates" seems like a usable workaround. After playing with it for a while, I've discovered that to hide "Words With Friends" updates I have to uncheck both "Games" and "Other Activity" for the friend. I think that's acceptable -- I doubt I would ever want any of the updates that would fall under those categories.

It's far from ideal, as I'd like to be able to unsubscribe from all "Words With Friends" content in one go, as promised on Facebook's Help page. Also, I'd like it to be targeted to the offending updated source. But can work with this.

Browser extensions are a much less desirable solution, as I want a browser-independent solution. I use multiple computers, and multiple browsers on each.

If anyone is able to get the behavior described on Facebook's help page (see link in my original post), I'd be interested in hearing about that.

Thanks again,
Joe
posted by bigjoec at 9:30 AM on January 6, 2013


I believe you can also accomplish this from the App Center. If you go to each App/Settings/Posts On Your Behalf you can set it to "Only Me" and it won't spam any of your friends.
posted by Bresciabouvier at 11:05 AM on January 6, 2013


Settings [gear icon] -> Account Settings -> Blocking -> scroll down to "Block Apps" and start typing the name of the app to block. Once the one you want comes up, select it. Has to be done one app at a time, though.
posted by DevilsAdvocate at 4:39 PM on January 7, 2013 [1 favorite]


« Older Traveling to Italy, have quest...   |  I'm fascinated by the smaller ... Newer »
This thread is closed to new comments.


Post