Join 3,438 readers in helping fund MetaFilter (Hide)


Can I make the GoogleVoice connect invisible to a caller?
October 25, 2012 5:55 AM   Subscribe

I've just set up a Google Voice number. When someone calls the number, the person hears something like, "Please wait while Google Voice connects you." Is there a way for the connection to be transparent to the caller, i.e. for them not to know that they're calling a Google Voice number? It seems like there should be but I'm not having any luck figuring it out...
posted by Wisco72 to Technology (7 answers total) 8 users marked this as a favorite
 
Go to google voice in a browser click the gear to get to settings.
Settings>Calls>call screening Select off
posted by edbles at 5:58 AM on October 25, 2012


Then record a voicemail greeting because the default message says something to the effect of "The Google Voice subscriber you're trying to reach is unavailable, at the tone ... "
posted by Gev at 6:19 AM on October 25, 2012


I'm not certain that call screening is the issue. I have call screening enabled for my Google Voice number and callers do not hear that message (or at least I don't when I test it from my other phone). They simply hear the phone continue to ring while I listen to the "You have a call from unknown caller ... to accept, press 1" message.
posted by enn at 6:32 AM on October 25, 2012


I believe it's the combination of "Call Screening" and "Ask Unknown Callers to say their name" that results in the "Please Wait..." message. I believe if you turn off "Ask Unknown Callers" and leave on call screening, it will just ring during while the call screening process is occurring. I may be wrong, however.
posted by jferg at 7:05 AM on October 25, 2012 [1 favorite]


Yeah, turn-off screening.
Also, record a personal greeting (found under the Voicemail and Text tab), for those times the callers get a busy signal, or you have DND turned-on.
posted by Thorzdad at 7:29 AM on October 25, 2012


A word of warning - there's a significant delay introduced by the connection. When I had screening off, sometimes my cellphone would ring once and then go straight to voice mail, and sometimes callers would just give up because they'd listened to several rings before I heard any on my end.
posted by qxntpqbbbqxl at 8:44 AM on October 25, 2012


Is your "other phone" a linked phone to your Google Voice number? If so, this may explain why you don't hear the "Please wait...." message when testing. IIRC linked phones by default go directly to Google Voice voicemail when you call your Google Voice number.
posted by davidvanb at 10:15 AM on October 25, 2012


« Older I would like to request an upd...   |  I have some vacation time to u... Newer »
This thread is closed to new comments.