Skip

Firefox is possessed!
October 17, 2012 11:15 AM   Subscribe

Firefox keeps going back to previous page, but I'm not hitting the back button!

Using Firefox 16.0.1 on Macbook Pro with Mountain Lion (both with latest updates installed). I'll be randomly browsing and for no apparent reason, Firefox will go back a page, but I haven't clicked or swiped anything to have it go back.
FWIW I have had this issue since the previous FF update. I've checked my track pad settings and they are all normal/nothing set to where it should go back a page. This happens when I'm scrolling, when I'm NOT scrolling, when I'm typing, basically just at random.
Basically the only solution I've come up with is to have each page open in a new tab of it's own so I don't have any pages to go back to on that particular tab. But that's getting to be a real hassle...
posted by PeppahCat to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
Have you tried completely disabling the trackpad and see what happens? Could be a bad driver.
posted by Foci for Analysis at 11:22 AM on October 17, 2012


You don't have swipe to navigate enabled in your trackpad settings do you? If so, try turning that off and see what happens.
posted by HuronBob at 11:36 AM on October 17, 2012


You don't have any mouse-gesture add-ons installed, do you?
posted by limeonaire at 11:40 AM on October 17, 2012


There are bugs in Firefox 16. Not sure if it's related to your problem, but why not downgrade to 15.0.1 as suggested, and see if the problem disappears.
posted by weapons-grade pandemonium at 11:47 AM on October 17, 2012


I think the behaviour may be related to this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=640587

All I can suggest is updating/reloading the software, crossing your fingers and invoking whatever computer gods exist to make it right again (that is if none of the suggestions in the thread work).
posted by sardonyx at 1:37 PM on October 17, 2012


I'm also on a MBP using FF on 16.0.1 on Mountain Lion, all updated, no mouse-gesture add-ons. I have the same problem on occasion. To me it appears that I am occasionally getting side-swipe gestures on my trackpad even when I didn't make them. I don't have a solution, but your problem is not completely unique.
posted by immlass at 2:01 PM on October 17, 2012


You could try setting up a new profile and seeing if the same thing happens. I think that's holding down the option key while you start Firefox (I'm on Chrome and having something similar happen).
posted by fenriq at 2:35 PM on October 17, 2012


The delete button can do it too.
posted by colin_l at 2:57 PM on October 17, 2012


Also, make sure your backspace key is not the culprit. Possibly sticking or something pushing on it? On some systems, this is the keyboard shortcut for the back button.
posted by davidvanb at 8:05 AM on October 18, 2012


Tried everything listed above with no results. I suspect it's the bug listed by weapons-grade and sardonyx. Darn you Firefox!
I honestly thought I had some bit of fluff stuck under my trackpad that caused it to click or swipe without my intending to, but after having tried everything under the sun I put it off to the bug. Thanks everyone!
posted by PeppahCat at 7:06 AM on October 19, 2012


« Older Recommendations for houseclean...   |  BC locals, can you get around ... Newer »
This thread is closed to new comments.


Post