Join 3,421 readers in helping fund MetaFilter (Hide)


New Paperweight Anyone?
October 9, 2012 12:20 PM   Subscribe

My Android phone, a Samsung Nexus S, operates on Jellybean 4.1.1. Since the latest update, I've noticed a dramatic decline in the battery life--it will go from fully charged to dead within 3 hours of intermittent use, regardless of whether I'm on a 3G or Wifi connection. How can I optimize the battery life on my phone without losing its functionality?

I bought the phone in January 2011, almost two years ago. It stays on all day if I put it into airplane mode. The battery usage tracker reports that the exchange services are using almost 60% of my battery life. I've done some research and it seems to be a common problem, though I'm not sure if it's due to the OS upgrade (all devices with Jellybean) or just my model's hardware, since Jellybean was designed to play with the newer Galaxy Nexus.

Things I've done:
-turned off Google Now
-restricted background data
-limited location services (I still need to use Maps)
-turned sync off for every Google service except Calendar, Contacts, Gmail and Reader

I don't want to turn off sync entirely, because that defeats the purpose of having a smartphone for me. Ignoring the other problems I'm having with the upgrade (Maps being finicky with the history function, Google search returning a page with unclickable results, slower response times), I'd like to be able to use my phone with some regularity without being slaved to a charger. The battery can get very hot and recharging takes hours, unless the phone is switched off during charging.

Has anyone else been experiencing similar problems? Is there a way to selectively sync (by location or time interval), or make exchange services stop being stupid and a battery hog? Are there any apps I can download to track my battery life better or diagnose the problem? I used to be able to turn my phone into a wifi hotspot and use it with my notebook...those days are long gone.

My phone's not rooted and I'd prefer not to do that, so simpler solutions are better.

Things I would consider doing but are not ideal:
-downgrading to Ice Cream Sandwich
-deleting and resetting Exchange Services
-performing a factory reset
-buying a backup battery to swap out (I'd rather solve this on the software side)

But I will if I have to, so any directions for those would be very helpful. I'm only a basic computer user, no programming knowledge, but I can find my way around instructions. This is a known issue that I've read up on (here, here, and here, for example), without any clear solutions. Unfortunately I can't really call my mobile carrier for help, because the phone comes straight from Google via Best Buy and there's no support for it through T-Mobile. I do love my phone and will continue to use Android, but I'm struggling to keep my phone relevant! Any feedback would be gratefully accepted.
posted by therewolf to Technology (12 answers total) 4 users marked this as a favorite
 
Goto Settings, Battery. What's using all the power? You may have an app that's eating all the battery.
posted by damn dirty ape at 12:26 PM on October 9, 2012


>The battery usage tracker reports that the exchange services are using almost 60% of my battery life.

Sorry, didn't see this for some reason.

I've read something about this bug. I think most people fix it by doing a factory reset and starting fresh or disabling the built-in Exchange and using something like Enhanced Email.
posted by damn dirty ape at 12:28 PM on October 9, 2012


I had this exact problem and fixed it by uninstalling the Mail app.

Have you ever done anything to set up the Mail app? (Not Gmail, just Mail) Do you use it? I had set it up in the past, found that it didn't work well, and had thought I had totally turned off all its settings/sync...but apparently not.

I still use exchange mail through another app, but I went from 6 hours of battery to my battery lasting all day again by doing this.

If you don't use it, it's worth a shot.
posted by another zebra at 12:28 PM on October 9, 2012


Try Settings/Developer Settings/Force GPU Rendering for 2D (I forget the exact name)

If you're bouncing around on your interface a bunch, this might help things. It seemed to do a lot for me, particularly when I was using the phone for a long period of time, both for battery life and heat.
posted by thanotopsis at 12:29 PM on October 9, 2012


I had this exact issue on a Nexus S, and found that reducing the "check frequency" greatly reduced the proportion of energy draw caused by Exchange. What is yours set to?
posted by Adam_S at 12:48 PM on October 9, 2012


No matter how well designed the software is, upgrading from Gingerbread to Ice Cream Sandwich and then to Jelly Bean surely introduced unintended bugs related to already installed apps and settings.

I know you don't want to hear it, but your best bet to restore optimal function is to do a factory reset.

Short of that, the best option is to reset the Exchange account, or at least change your Exchange settings from Push to check less frequently. This means it will only poll the server at the interval you specify, so your Exchange emails will no longer be instant. Gmail still will be.

If you don't use an Exchange account at all, make sure you delete all accounts in the Mail app (not GMail) and then clear data and cache on the Mail app.
posted by trivia genius at 12:58 PM on October 9, 2012


There's an app called BetterBatteryStats that can provide really detailed information. It's a little unintuitive but if you run it for a while and then look at the process or partial wakelock tab you should be able to see if there's a single app or process that has run haywire.
posted by selfnoise at 1:06 PM on October 9, 2012


There is actually a new update to 4.1.2 out today and the Nexus S should be included. Check Settings - About - Software update to see if it is available.
posted by Burhanistan at 1:13 PM on October 9, 2012


I had this exact problem on a Galaxy S (Vibrant) and fixed it. I deleted my exchange account, cleared the cache on the exchange (through settings > apps) and rebooted. I then recreated my exchange account and haven't had it drain my battery since.
posted by demiurge at 2:05 PM on October 9, 2012


Your battery could just be failing, dawg. They go bad.
posted by colinshark at 6:41 PM on October 9, 2012


Thank you everyone for your advice. I honestly had never investigated why exchange services was being so active, since it seemed like a common problem for other people. Turns out I had an old college e-mail address set up on there, which I deleted.

Immediately I noticed the power draw from exchange went from 58% to 45%. Cleared the cache for that app and it went to 40%. Rebooted and it was still around 35%, but by the end of the night it wasn't even on the list of programs that were draining the battery--the screen was back at the top of the list as it should be, and right now it's only taking 20%. I left it off charge last night as a test (before this, would have been stone dead by the time I woke up) and it's still up and running!

I'm very excited about this. I didn't get a chance to use BetterBatteryStats but I had heard about it, so I will look into it if this problem arises again. For now I'm feeling great about the way the battery's going, and I might even look into turning some services back on in a few days. This is good for me but I don't know how people who rely on Exchange for their work or school deal with this; it seems superbly shitty. In any case, thanks for pushing me to actually try to solve this problem!
posted by therewolf at 1:24 PM on October 10, 2012


I know that this question has already been answered but I wanted to add something additional in case someone else is having similar problems and they come across this post. I had the same situation: Galaxy Nexus, installed custom JellyBean rom, started traveling and the battery couldn't stay charged when I was away from home. I had the phone plugged into the wall or computer via usb (original cables) and it said it was charging, but it wasn't. Didn't have the problem at home, so I was wondering about the tower network and such.

Found out it was the USB cable. Battery, JellyBean, USB pin and Apps were all fine. The cheapo samsung usb cable went bad and the only time I had the problem was when I was using my 'travel' cable.
posted by kookywon at 3:41 PM on October 11, 2012


« Older Calling all chemists: I'm tryi...   |  Anyone know what the Italian i... Newer »
This thread is closed to new comments.