IPv6 help on Windows 7 with Airport router
October 6, 2012 8:11 PM   Subscribe

After several years away from Windows, I built a PC with Windows 7 and I'm using it with an Airport Extreme router. On my wireless icon in the tray is a small yellow shield and when I right-click for status I see "IPv6 Connectivity: No network access." I'm getting slow speed tests on my new PC and I think this may be the cause of it. Otherwise, my status shows that my IPv4 has Internet, speed is 130Mbps, and my connection is at high strength. I'll have a long enough ethernet cable to test that out next week but I'd like to get my Wifi up to the speeds that my Macbook gets routinely. My wifi card is the Asus PCE-N15. My Airport has updated firmware, as does my PC wifi card. I'm on Comcast cable internet with a 30mbps tier. Thanks!
posted by rbf1138 to Computers & Internet (10 answers total)
 
IPV6 is a newfangled Internet addressing standard that Comcast (and most other ISPs in the world) don't support yet, at least for end-customers. The lack of IPV6 connectivity does not represent a problem, and even if you could get an IPV6 address assigned, it wouldn't make things faster for you.
posted by killdevil at 8:24 PM on October 6, 2012


Disable IPv6: Go to Network and Sharing Center, select "Change Adapter Settings." Double-click your LAN adapter.

Select Properties. UNcheck "Internet Protocol Version 6"

Hit Okay, and close remaining windows.
posted by Sunburnt at 9:17 PM on October 6, 2012


Comcast is currently rolling out IPv6 but I agree that going to the effort to get it set up is unlikely to be of any help. Best to just disable it for now as Sunburnt suggests, so that the computer doesn't even try to connect that way.
posted by XMLicious at 9:23 PM on October 6, 2012


windows 7 and osx both default to using ipv6 if it's available; if it's not, which it usually isn't, it falls back to using ipv4. This is unlikely to be your problem, but turning it off in the wireless network card settings as sunburnt says will confirm.

Other things to try; in the ipv4 settings, try different dns server settings such as Google dns.
posted by ArkhanJG at 3:50 AM on October 7, 2012


Ok, I've disabled it but like you guys said, doesn't make a difference. I guess I'm still left wondering why I have this yellow alert shield on my connection status. Is that indicative of something that may be causing the slow speeds?
posted by rbf1138 at 6:00 AM on October 7, 2012


On all macs appple does a good job of determining the type of wireless encryption your router is using for you. Windows makes a guess sometimes its wrong. Go check what the encryption is and setup your computer for that.
posted by Rubbstone at 6:34 AM on October 7, 2012


I'm actually not using encryption; just using Mac addresses and only allowing designated devices onto the network.
posted by rbf1138 at 7:08 AM on October 7, 2012


http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/ipv6-no-internet-access-help/6dd90fd2-7c97-4343-a045-8b89e020720f

Some people seem to be disabling tunnel adapters and getting it to work. Goto Device Manager, View | Show hidden devices, expand Network adapters, and disable all the tunnel adapters (6to4, ISATAP).
posted by Rubbstone at 7:29 AM on October 7, 2012


I suggest disabling autotuning. It can cause weird slowdowns.

Open a command prompt (be sure to right-click and run it as Administrator), then enter the following:
netsh interface tcp set global autotuning=disabled
posted by mgr at 9:44 AM on October 7, 2012


I'm realizing this is probably not the source of the problem. I'm wondering if it's the Airport router or some Windows setting. Gah!
posted by rbf1138 at 11:57 AM on October 7, 2012


« Older How do I remove a Mediaplex vi...   |  Is there some sort of online c... Newer »
This thread is closed to new comments.