Join 3,564 readers in helping fund MetaFilter (Hide)


Why, oh, why can't I just get what I see in the preview window?
September 24, 2012 9:44 AM   Subscribe

[Adobe Premiere filter] I have a screencast of a Powerpoint presentation and a webcam video of myself explaining the subject. Using Premiere Pro, I have combined both so that the webcam feed appears as a picture-in-picture in a corner while the presentation runs. However, despite everything looking fine on preview, when I attempt to export the file, the Powerpoint part plays about 10X faster than it should. Help?

I must admit to being a total Premiere newbie — this is my very first semi-serious video editing project. I have managed to figure out by myself what I expected to be the hard part (i.e. actually positioning and synchronizing both video clips), but now I am completely stumped at my inability to export what looks like a perfectly good result on preview. My Google-fu has totally failed me so far, so I'm hoping that the Hive Mind might have the answer.

As I said, the two video clips are correctly positioned and synchronised, and they play together perfectly fine on preview. However, when I attempt to export the file, the "main" video (i.e. the Powerpoint screencast) seems to play about ten times faster than the webcam PIP window. Obviously, this results in the two clips being spectacularly out of sync — so much that, in fact, the presentation is over after just 4 minutes, while the webcam keeps running for another half hour or so.

The video clips are both .avi encoded with Xvid. The screencast is 1280x720 @ 25 FPS, while the webcam feed is 640 x 480 @ 30 FPS. The clips were recorded, respectively, using Camstudio and Debut Video Capture. I am trying to get Premiere to export to H.264, but I seem to have the same issue regardless of which codec I choose for output, including uncompressed AVI.

Might one of the Premiere geniuses in the Hive Mind have any idea what might be causing this sort of behaviour?

Thanks in advance!
posted by doctorpiorno to Computers & Internet (6 answers total)
 
I haven't used Premiere since the late 90s, so I can't offer any Premiere-specific advice. But it might be worth converting the screencast to the same framerate as the webcam feed (or vice-versa, depending on the target framerate for the final output) and then trying to put them together.
posted by primethyme at 10:41 AM on September 24, 2012


I happen to have Premiere open right now. Did you record both clips at the same time or separately? When you look at them in the timeline, are they both the same length? You should have the slides in Video 1 and the webcam video in Video 2. Does the slides track extend all the way to the end of the webcam track? How did you synchronize the two tracks?
posted by echo target at 10:47 AM on September 24, 2012


Not a Premier user, but a video editor - have you tried to make a video mixdown? It sounds like a framerate issue due to the screencast running at 25 FPS vs 30 FPS. Making a mixdown before export might keep the frame rates together. If not, you're going to have to adjust the frame rates like primethyme said.

Let us know how things work out.
posted by packfan88c at 10:55 AM on September 24, 2012


Yay, geniuses at the rescue! OK, let me try my best shot at answering your questions:

primethyme — I did try converting the webcam feed to the same 25 FPS as the screencast using Interpret footage in Premiere, then adjusted its duration to play it slightly faster so that both clips remained in sync. It didn't seem to change the result of the export, though. Maybe both actions just cancelled each other out, if that is even possible?

echotarget — Yes, I recorded both clips at the same time, one using Camstudio and the other using Debut. One is about one second longer than the other — essentially, just the time it took for me to switch to the other program and click the record button there as well. I synced them by looking at the waveform of each clip, placing a marker at the part where I began to speak (the audio is the same on both videos) and nudging the clips in the timeline so that the markers matched. Finally, I trimmed a little bit off the start and end so that both would start at the same time.

packfan88— That sounds like it might help. I'm going to do a bit of research on how to do that on Premiere and report back.

Thanks so much for your advice. I'll keep you posted, and if you have any other ideas, do keep them coming!
posted by doctorpiorno at 12:23 PM on September 24, 2012


To make a mixdown, just put the clip on a timeline on its own, then go to Export and save it out as, say, an uncompressed AVI. Do this with the slides, set the framerate to 30, and maybe turn off frame blending (might insert blurry between-frames). Then import the new 30 fps file, put it next to the webcam feed, and see if it still syncs wrong.

One tip, when you're searching for Adobe help: nine times out of ten, you should ignore whatever results you get from Adobe's official site. They're often unhelpful and inconclusive.
posted by echo target at 12:39 PM on September 24, 2012


The frame rate thing is the first thing that pops into mind, but that wouldn't account for "10x speed playback" unless you are exaggerating; what I would expect would be a eventual de-sync between the two after a few minutes of playback.

I have seen instances where the audio sample rates of 48000Hz and 44100Hz are used in the same project and have it lead to some wacky fun times too.

So choose one or the other and make sure your audio tracks are using the same setting. Normally the program should re-sample automatically upon render/export, though maybe there are some "lock video to sample rate" or "don't resample audio" settings checked somewhere.

This would give you a 10x speed impression if it is happening (bug or otherwise)
posted by Khazk at 12:22 PM on September 25, 2012


« Older I just called TWC to see if th...   |  I gave two weeks' notice at my... Newer »
This thread is closed to new comments.