Skip

Finder not defaulting to show "Name" column - OSX 10.8
September 24, 2012 1:55 AM   Subscribe

In Mountain Lion opening some (but seemingly not all) folders in "List" view, shows the "Date Modified" column on the left of the window, requiring me to scroll further left to see the "Name" column. What preference did I accidentally change?
posted by roofus to Computers & Internet (16 answers total) 1 user marked this as a favorite
 
Click the gear icon at top centre, and select show view options, that will enable you to toggle the display of individual columns. Set it how you want then click "use as defaults" at bottom.

How it got to be different is anyone's guess.
posted by epo at 4:08 AM on September 24, 2012


Also , remember that columns can be dragged to a different relative position by dragging the column name to the column where you want it to appear (in this case you will want to drag the name column heading )
posted by Podkayne of Pasadena at 4:16 AM on September 24, 2012


But note that "Use as defaults" will not override the settings on directories where the columns have previously been specified explicitly in the view options (as you'd expect). All you can do there is change the column settings on those directories which still have it wrong.

To do a system wide reset (I think but haven't tried it) you could try deleting all .DS_Store files but this would remove other preferences like icon sizes and positions.
posted by epo at 4:18 AM on September 24, 2012


Somehow neither of these suggestions does the trick.

In "View Options" the name column isn't an option, as in it's always there, and furthermore the name column can't be dragged, so the name column is always on the far left, even if that's not in view as the window opens.

I'll try and explain once more what's going wrong:

If I make a new folder, or indeed open any folder where I haven't previously specifically scrolled, or if I switch from icon view to list view, the finder by default is showing the "Date Modified" "Date Created" "Size" and "Kind" columns. The "Name" column is there, but off the left side of the window, so I need to two finger scroll to see it. This doesn't change as I minimise, maximise, or resize the window, i.e. the list view always neatly lines up so Date Modified is the left most visible column.
posted by roofus at 5:58 AM on September 24, 2012


What is the "Arrange by" setting (gear icon) for the window in question? Is it Date modified by any chance? If so make it Name (or None) and do set as defaults again
posted by epo at 6:13 AM on September 24, 2012


It sounds as if you are saying that when you switch to list view the view starts in the middle of the columns and that the name column is off screen to the left and the has to be manually scrolled to be seen - is that what you are saying?

If so, that's a behavior I have not seen before. If no one else provides a better solution here is how you can reset your finder to the original defaults:

First close all currently open finder windows.
In Finder "Go" menu, hold the option key and choose Library. Then go to Preferences and trash these files:

com.apple.finder.plist
com.apple.sidebarlists.plist
com.apple.FolderActions.plist
com.apple.FolderActionsSetup.plist

then empty the trash and reboot your machine

When you do this ALL your folder and finder and sidebar preferences will be reset to the default and you will have to set preferences and defaults once again but that's usually not too heinous. The above solution does not explain how you got to your current situation but it does provide a way for you to correct it.
posted by Podkayne of Pasadena at 6:33 AM on September 24, 2012


Podkayne of Pasadena you have exactly described my problem, but I can't find those preference files to trash them.

Monkeying with "Arrange by" does change the order of the lists, but doesn't fix the default columns showing in the visible part of the window.
posted by roofus at 7:26 AM on September 24, 2012


Are you going to the Preferences folder which is inside the Library folder?

When you do get inside the Preferences folder remember to click on the Name column to sort by name which should make it easier to find the above files (and folder). If you still cannot find the files then send me a screen snapshot by mefimail that shows what your finder looks like when you are inside the Preferences folder.

You can also use the search box of the finder once you are inside the library folder to find the files above (one by one) and then delete them one by one. Remember to select the "name matches:" option which will pop up once you start the search
posted by Podkayne of Pasadena at 7:57 AM on September 24, 2012


Well I feel silly - there is a MUCH easier solution ....

1. Open a Finder Window

2. Selevt View... SHow View Options

3. Hold down the Option Key

4. The "Use as Defualts Button" Will Change to a "Restore To Defaults Button" - Press that.

Voila - you should be set back to default settings.
posted by Podkayne of Pasadena at 9:04 AM on September 24, 2012


Hmmm....no dice. That just readjusts to the default columns, but still doesn't change which columns pop into the initial view.
posted by roofus at 9:22 AM on September 24, 2012


I'm at a loss then. I know of no reason why the first column would display scrolled off the left side of the window upon initial presentation.

If the simple way that I mentioned did not work then I encourage you to try the delete files method . The screenshot that you gave me showed that you were not in the actual user library folder (ie the one where you hold the option button down). Get n that correct folder with the option button method, delete those files (which must be there - they are a part of the OS) reboot and best of luck !
posted by Podkayne of Pasadena at 10:01 AM on September 24, 2012


I am also at a loss, the last two things I can suggest are:

- create another account on that machine or use a guest login, see if finder behaves the same way for that login, that will indicate whether the issue affects just your login or the whole machine

- update to 10.8.2 using the combo updater whether or not you have already updated.
posted by epo at 12:32 PM on September 24, 2012


Oh actually, one more thing. It is possible that some changes to the Finder won't take unless the Finder is restarted so use Force Quit to kill the Finder (it will restart) and then see.
posted by epo at 12:39 PM on September 24, 2012 [1 favorite]


OK, deleted all plist files, updated to 10.8.2, and restarted - and it's fixed. Thank you for being persistent!
posted by roofus at 2:34 PM on September 24, 2012


Thank you for being persistent!

It's both my best and worst quality !
posted by Podkayne of Pasadena at 8:06 PM on September 24, 2012


Macs: they just work!
posted by epo at 10:49 AM on September 25, 2012


« Older I just spent one week in Hyder...   |  Where can we find cool-looking... Newer »
This thread is closed to new comments.


Post