Skip

wifi phone DNS
September 14, 2012 8:00 AM   Subscribe

WiFi data issues. My phone (Android) connects to the network and I can log in to the server, but I'm not getting any internet. I'm a bit lost here; I've got access to every setting imaginable, but I dont know what I'm doing. Any help very much appreciated! If I had any hair, I'd be tearing it out.

I'n trying to connect my HTC One S to a Voyager 2110 modem/router.

My phone connects to the network, and I can see its MAC address in the 'Wireless Clients' of the router, but I'm not getting any data. I cannot see the MAC address in any of the other settings; DHCP table, Routing Table, ARP table.
I've tried changing from DHCP to static IP without much luck (or knowledge... I used the primary/secondary DNS server numbers from the router 'overview' as DNS 1/2 in the phone?) and again the IP number is not visible in any of the tables.

The phone connects 90% of the time, but sometimes (generally when I most need it to) it doesnt. Any help is much appreciated.
posted by BadMiker to Technology (8 answers total)
 
Do you have a DHCP server enabled on the router? Do other devices work correctly?

If you want to set it up static, typically you'd follow this logic:

Examine the router's local IP address (probably starts with 192 or 10) and the associated subnet mask. The parts of the subnet mask that are zero are where you have flexibility to define addresses. An example:

Router's local IP is 192.168.1.1 with a subnet of 255.255.255.0

You can define any IP addresses from 192.168.1.2 to 192.168.1.254 on other devices in the network.

With respect to DNS, you can either enter the router's IP address as the DNS server, since typically home routers are configured to reply to DNS queries, or you can enter a public DNS server like Google's (8.8.8.8 and 8.8.4.4).

Most importantly would be the Default Route. This is the address to which the device should direct traffic not destined for the local network (i.e., internet traffic). Again typically you would supply the router's IP address here as well.

All of these aspects are what the DHCP Server function will do automatically for you, though.
posted by odinsdream at 8:35 AM on September 14, 2012


I suppose you should also make sure that you're actually getting local addresses from your modem/router, rather than a public address. If you're not getting an address that starts with 192 or 10, you're probably getting a public address, which would indicate your router is not in NAT mode, which is required for more than one device to exist behind it.
posted by odinsdream at 8:37 AM on September 14, 2012


Thanks.

I've been able to define an IP address for the phone and connect to the router, but I'm not getting any intrenet.

DHCP is enabled on the router, and other devices (and sometimes the phone) work. Currently, with DHCP enabled, the phone says IP address is unavailable.

I'm also not seeing the phones MAC address anywhere on the router's tables, except on 'Wireless Clients'?
posted by BadMiker at 8:41 AM on September 14, 2012


Did you define a default gateway? That's what tells your phone to send internet destined traffic to the router. This is one of many parts that could be incorrect, of course. Your router must be set up to do NAT translation.
posted by odinsdream at 8:44 AM on September 14, 2012


Dammit.

It's working now, but I'm not sure if that was because I changed the settings or whether it was because the router decided to work. I set static IP and entered the 'Gateway' as the router IP: 192.168.1.1 then, as you suggested, used Google's DNS.

Phone's MAC & IP now appear in the ARP table. Is this the table showing how the router is routing traffic?
posted by BadMiker at 8:52 AM on September 14, 2012


ARP tables are used to identify which MAC is associated with which IP on a local network. They're useful for deciding whether traffic should be on one side of the network or the other. I'm glossing over a lot of details here, the Wikipedia article is a good resource.
posted by odinsdream at 11:02 AM on September 14, 2012


Is this the only wireless device on your network? If so, you may have a dying/crappy wireless router. Some amazon reviews (more) of your router report the simiilar issues.

If it works 90% of the time, what is the signal strength when its not working 10% of the time. You may have a reception issue. Some versions of android show 2 bars when there is a marginal signal.

I'm betting crappy router.
posted by damn dirty ape at 11:22 AM on September 14, 2012


My Android phone, I noticed this very week at a friend's house, seemed to have a profound incompatibility with that exact BT modem's WPA encryption algorithm.

Tweaking the modem to use AES instead of (and not in addition to) TKIP immediately solved the problem.
posted by genghis at 6:35 PM on September 15, 2012


« Older I work in West Harlem on 135th...   |  I need housing for a job start... Newer »
This thread is closed to new comments.


Post