Join 3,372 readers in helping fund MetaFilter (Hide)


iCal hiding all appointments
June 4, 2012 9:07 AM   Subscribe

iCal is being a giant jerk. Halp?

I am running iCal (5.0.3) on Lion (10.7.4). I believe everything is updated. About a month ago, I noticed that my iCal calendar was completely blank and panicked—but all my stuff still shows up on my phone, so I figured it wasn't lost at least. But I would really like to see it all on my computer again!

When I try to make a new appointment on my computer, the new appointment thing opens up but then closes as soon as I start typing. The event itself disappears. But if I look on my phone, I do indeed have a new event in that slot.

And when I first open up iCal, I see a brief, tantalizing glimpse of all my appointments while it says it is updating, but then everything becomes hidden again. What gives?

I have these kinds of calendars: iCloud, a couple Google Calendar subscriptions, and Exchange appointments from work. I have tried turning each one on and off, and deleting and recreating those accounts through iCal preferences. But nothing seems to work.

I have no idea how to go about troubleshooting this, and can't find an answer on the Apple support communities (though a couple people have seemed to have the same issue). Any ideas?
posted by peachfuzz to Computers & Internet (3 answers total)
 
Could it just be that that the default calendar is not set up to display, so that when you create an event, it is properly tagged in "home," but as soon as it is created in "home," it's hidden. On the iPhone, the "home" calendar is not hidden, so it shows up nicely?

I.e., if you look at this link, you see different calendars with check boxes selected next to them. Are all of your calendars checked?
posted by Admiral Haddock at 9:34 AM on June 4, 2012


I am not clear from the description if you've tried the obvious: Click on the Calendars button on the upper left side and make sure that all your calendars are checked off.

If they are and it's still behaving this way, create a second user account on your mac and try there. If it's doing it there as well then it's a problem with your Lion installation, if not then it's likely solvable by removing the iCal preferences files and letting it make new ones. They're in your (now invisible) ~/Library/Preferences folder; if you're not comfortable mucking around in there take it to a Genius Bar and they'll help you out.
posted by raygan at 9:37 AM on June 4, 2012


that worked, and perfectly, raygan (the second suggestion to delete the preferences, that is, yes, all the calendars were checked). Thank you!
posted by peachfuzz at 9:55 AM on June 4, 2012


« Older GMAC Mortgage is filing Chapte...   |  I need some help with my Avaya... Newer »
This thread is closed to new comments.