Join 3,373 readers in helping fund MetaFilter (Hide)


Spaces + Chrome = PITA
May 21, 2012 8:37 AM   Subscribe

OSX: What did I do to cause Spaces to freak out when I tear off tabs in Chrome?

Suddenly, and for no discernable reason, tearing off tabs in Chrome occasionally causes my Spaces to switch. My Spaces shortcut is set as control + shift + arrows. I've tried switching the shortcut but it doesn't seem to fix the problem.

Also, once the tab is torn off and on a random Space, I can't grab it and use the shortcut to move it back to the Space it belongs in. What gives?
posted by nathancaswell to Computers & Internet (5 answers total)
 
What version of OS X? (Lion?) Do you have hot corners turned on, and you are possibly dragging the tab too close to the hot corner?
posted by misterbrandt at 10:10 AM on May 21, 2012


10.6.8. No hot corners, I hate hot corners. It doesn't do it all the time, it's like 1 time in 5. It's infuriating.
posted by nathancaswell at 10:48 AM on May 21, 2012


This is a bit of a shot in the dark (doesn't match the intermittent pattern you describe), but:

1. Right click (ctrl click) on Chrome in the Dock
2. Select Options
3. Assign To, set to None

? (from here)
posted by misterbrandt at 11:45 AM on May 21, 2012


This is a bit of a shot in the dark

That didn't do it precisely (the Assign To option is a Lion-only feature I believe) but it did give me an idea of what might be happening.

I have Chrome set to open by default in Space 1 but through the day it occasional migrates to another Space... it seems that my torn away windows, while only occasionally warping off, always seem to shoot back to Space 1. So the solution may be just to always keep Chrome on Space 1. I will try that out for a couple days and see if it fixes it.
posted by nathancaswell at 12:00 PM on May 21, 2012


I have a feeling it's one of my least-favorite undocumented Spaces features: dragging windows to a screen edge for an all-too-brief moment activates space switching.

It's not something you can easily change; however putting this in a terminal window will set the delay to a minute, effectively disabling it.
defaults write com.apple.dock workspaces-edge-delay -float 60 && killall Dock

posted by Mr. Anthropomorphism at 9:41 AM on May 22, 2012


« Older What to do with a loose diamon...   |  Looking for examples of well-d... Newer »
This thread is closed to new comments.