Skip

I Destroyed Firefox. Profile is deleted & It No Longer Works.
May 13, 2012 1:15 PM   Subscribe

While on Firefox (12.0) for my Mac (OS 10.5.8) I hit a mail link which caused my Firefox window to open rapidly window on window ad infinitum. It locked up my mac and I couldn't even get to Firefox Preferences/Tools etc without multiple windows opening on top. I force- quit. I restarted and this did not help. I uninstalled an reinstalled and this did not help. It hit about midnight and stupid and tired, I deleted my entire profile....The whole blasted thing in a rash moment. So unlike available articles on Mozilla for retrieving missing/lost/messed with profiles mine is simply bye-bye by my own hand. I emailed Mozilla and got these instructions: "Try to delete the profiles.ini file *http://kb.mozillazine.org/profiles.ini_file *http://kb.mozillazine.org/Profile_folder_-_Firefox" I don't have the ini file in the locations specified nor elsewhere. This link did not seem to help, either. I tried entering a terminal command for Firefox (cannot find page for that now) and no luck. If I click on Firefox, it says "Firefox is already open, only one copy can be in use." (Nothing else is open and I even restarted the computer a few times.) Any ideas? I like Firefox the best and would like to use it. And yes, I was an idiot to delete things so will take appropriate lashings.
posted by snap_dragon to Computers & Internet (17 answers total) 1 user marked this as a favorite
 
Try creating a new profile? Not sure what the equivalent is for Mac, on windows it's starting Firefox with the -profilemanager switch, e.g. firefox.exe -profilemanager.

See this for Mac: http://kb.mozillazine.org/Profile_Manager

Again might not be relevant on Mac, but in Windows, firefox creates a file called parent.lock when it starts, deletes it when done, and it's existence gives you the in use error.
posted by Boobus Tuber at 2:32 PM on May 13, 2012


I was on that page several times...but can't even get Profile Manager up (if it is even there anymore). Activity Monitor shows nothing active. Yikes.
posted by snap_dragon at 2:42 PM on May 13, 2012


I did the Terminal command (mentioned briefly in description) which is:
/Applications/Firefox.app/Contents/MacOS/firefox-bin -profilemanager -- which gave error and then tried again with the caveat below which said:
"Adding -bin after the application name is necessary on some systems and application versions. If you have problems starting the Profile Manager with one of the above commands, try again using just the application name..."

This did not work, either.
oy, vey.
posted by snap_dragon at 2:50 PM on May 13, 2012


Have you tried completely removing Firefox and all associated files? It's a little unclear what exactly you've done, and I'm not sure if you deleted your FF profile or possibly your Mac user account. The files are spread around in a few places.

Here are few links on removing Firefox: one, two, and three.

Also check Activity Monitor to see if any FF-related processes are running. It'd probably be a good idea to restart at this point as well.

Once you've deleted all traces of FF you should be able to reinstall FF and start over just like a brand new install.
posted by 6550 at 3:28 PM on May 13, 2012


Make sure Firefox is not running. Go to your home folder → Library → Application Support → Firefox. The profiles.ini file should be in there; delete it and the Profiles folder if it exists. Or run this Terminal command:

rm -rf ~/Library/Application\ Support/Firefox/Profiles && rm ~/Library/Application\ Support/Firefox/profiles.ini

Then reopen Firefox. You should see the dialog that asks if you want to import your settings and data from another browser.
posted by tepidmonkey at 3:30 PM on May 13, 2012


@6550 - Tried this, did not work. Don't have plist nor the profiles.ini file. Finder did not find any mentioned in link three. Tried Activity Monitor before but looked again and no Firefox.

@tepidmonkey - Tried but have not profiles.ini.

The problem is my idiotic move of nuking the who profiles folder. Can't seem to get FF up anymore.

Thanks for your advice. I must have done a doozie on this.
posted by snap_dragon at 3:49 PM on May 13, 2012


Hm. Go to your home folder → Library → Caches, delete the Firefox folder, try again.
posted by tepidmonkey at 4:10 PM on May 13, 2012


Did so, reinstalled FF. No luck.

Tepidmonkey, is there any chance I might memail you at a later date (next few days or so)? I think I need to walk away from this after several hours, I feel like Kurtz in Apocalypse Now ("...the horror...the horror....")
posted by snap_dragon at 4:27 PM on May 13, 2012


... or maybe more like Jack Nicholson from The Shining.
posted by snap_dragon at 4:29 PM on May 13, 2012


BTW, it does keep saying "A copy of Firefox is aready open. Only one Firefox can be open at a time."

It does this no matter what troubleshooting steps I have followed from you nice folks. May try tomorrow when the sun comes out and all that.
posted by snap_dragon at 4:31 PM on May 13, 2012


Just skimmed over the current replies, and I the only other thing I can think of is that sometimes the lock file (which Boobus Tuber mentions, but is called .parentlock on OS X) isn't in the profile folder, it's in ~\Library\Application Support\Firefox. Not sure why…

Make absolutely sure (again!) that there's no bit of Firefox running (check in Activity Monitor as 6550 suggested earlier) then, from the Terminal, run:

rm -f ~/Library/Application\ Support/Firefox/.parentlock
posted by Pinback at 5:45 PM on May 13, 2012


Thanks Pinback. I did that too (before) and tried again. Alas, no. There is not Firefox items in Application Support nor Mozilla. No .parentlock.

Will check back later. Tired myself out! Not really sure there is anything more I can do. There has to be something I've missed or whatever. I scoured the Activity Monitor and nothing. There is talk on threads of 'zombie firefox', I think in reference to .parentlock...but I don't have anything. What I didn't delete in the first place (the profile folder entirely), I deleted based on Mozilla's suggestions and here which is cache, anything Firefox (and later Mozilla) in Library/Application Support and so forth.

Something is just...bad (besides the Channing Tatum movie my wife wants me to watch...)
posted by snap_dragon at 6:14 PM on May 13, 2012


I did the Terminal command (mentioned briefly in description) which is:
/Applications/Firefox.app/Contents/MacOS/firefox-bin -profilemanager -- which gave error and then tried again with the caveat below which said:
"Adding -bin after the application name is necessary on some systems and application versions. If you have problems starting the Profile Manager with one of the above commands, try again using just the application name..."
I think that's saying the "-bin" is actually optional. So try it once with and once without.

Also what was the error message you saw please, exactly?
posted by vsync at 11:41 PM on May 13, 2012


terminal msg:

dyld: unknown required load command 0x80000022
Trace/BPT trap

then pop-up box "The application firefox-bin quite unexpectedly. --Ignore/Report/Relaunch"

then again without -bin:
"dyld: unknown required load command 0x80000022" with same popup box
posted by snap_dragon at 5:06 AM on May 14, 2012


That's very odd - that normally happens when trying to run a 64-bit version of FF on a 32-bit version of OS X. What happens when you run …

arch -i386 /Applications/Firefox.app/Contents/MacOS/firefox-bin -ProfileManager

… in Terminal?
posted by Pinback at 3:13 PM on May 14, 2012


Ah, and I see you're on 10.5.8 (I'd assumed 10.6.8, but that's from a different question yesterday). If the command above gets it running, then you should be able to … ah, I dunno - there's no "Run in 32-bit mode" setting in 10.5.x. Try Googling "Firefox" "Leopard" "unknown required load command 0x80000022" for a way of forcing newer FF builds to run as 32-bit on older OS's…
posted by Pinback at 3:18 PM on May 14, 2012


@Pinback - Thanks much for your input. I got home tonight, and I would like the truth to be this: the .ini folder was there even when I looked 32 times before. I took care of it and Firefox opened. I have utterly NO idea. None. I was going to use the profile from my work computer but didn't have to.

I am certain though that readers will think "This guy's an ____", (idiot? sap? unfortunate fellow?) which is fair but they didn't scour my computer for hours. Twilight Zone.

Thanks. If this happens again, I have a place to refer.
posted by snap_dragon at 5:15 PM on May 15, 2012


« Older I move a lot and often. Help m...   |  What short film did I see? It ... Newer »
This thread is closed to new comments.


Post