Join 3,382 readers in helping fund MetaFilter (Hide)


Boot ubuntu to the commandline
April 27, 2012 6:13 AM   Subscribe

Due to my work laptop dying, I installed the gui on my Ubuntu 11.10 server. No biggie except that it seems to have messed up the video mode. My LCD just displays an error. How can I get around this?

Normally I'd ssh from my laptop but that's not possible. It boots to the gui by default and I cannot find how to either stop that (left shift does nothing, Ctrl-Alt-Backspace as well) or to get to single user. All I can Google assumes you have commandline access. Am I screwed until my laptop is fixed?
posted by tommasz to Computers & Internet (14 answers total) 1 user marked this as a favorite
 
ctrl+alt+f1 should get you to a text console
posted by gadha at 6:14 AM on April 27, 2012


I tried that, it oesn't work either.
posted by tommasz at 6:16 AM on April 27, 2012


Ssh from your phone? (assuming thats how you are googling...)
posted by ennui.bz at 6:35 AM on April 27, 2012


Or google: boot grub runlevel 3
posted by ennui.bz at 6:42 AM on April 27, 2012


To make it boot to single-user mode, you can temporarily add "single" to the kernel command line in the Grub (bootloader) interface.

This page may help.
posted by scatter gather at 6:44 AM on April 27, 2012


Ssh from my phone is a possibility if I can get permission to use my non-standard device to access the work wireless. I was hoping it wouldn't come to that given how much t.rouble I have typing on this thing.
posted by tommasz at 6:46 AM on April 27, 2012


I cant get to the grub menu, either. It goes into a video mode my LCD can't handle when grub takes over.
posted by tommasz at 6:49 AM on April 27, 2012


This page may also help.
posted by pipeski at 7:32 AM on April 27, 2012


I cant get to the grub menu, either. It goes into a video mode my LCD can't handle when grub takes over.
posted by tommasz at 9:49 AM on April 27 [+] [!]


That cant be... Unless maybe there is something wrong with your lcd. Grub happens way before x.org shows on the scene...
posted by ennui.bz at 8:12 AM on April 27, 2012


If I hold down left-shift I see "Grub loading." and then my LCD goes blank and pops up a box with "not supported".
posted by tommasz at 8:24 AM on April 27, 2012


Can you boot off the CD you used to install the OS?
posted by introp at 11:32 AM on April 27, 2012


That's what I ended up doing. It's not a real solution but it works. At least I have email and web access.
posted by tommasz at 11:44 AM on April 27, 2012


Step 1: back up anything you're about to change.

Try looking into the settings in /hard_drive_mountpoint/etc/default/grub. If I recall, there's one commented-out line there for forcing console mode and another for forcing resolution in graphical mode. You can uncomment the console mode line. Now you need to re-generate /hard_drive_mountpoint/boot/grub/grub.cfg. Normally you'd just run sudo update-grub, but you're on the LiveCD so that won't do what you'd expect. There are a dozen ways to accomplish this, but I think the simplest is:

Just go edit /hard_drive_mountpoint/boot/grub/grub.cfg by hand for the moment. Back it up, then go find the line that says:
terminal_output gfxsomethingsomething
and change it to the following two lines:
terminal_input console
terminal_output console
Reboot (hopefully into a console-mode GRUB), boot normally, and then run "sudo update-grub" to generate a "legit" grub.cfg

(Disclaimer: not a GRUB guru, but have had to monkey with it enough that I'm fairly comfortable the above will work. If it makes your dog leave you, I apologize.)
posted by introp at 12:23 PM on April 27, 2012


If it's the same problem I had, this fix worked.
posted by KevinSkomsvold at 1:23 PM on April 27, 2012


« Older Sense of Strangulation in Thro...   |  What can I do about mold on th... Newer »
This thread is closed to new comments.