Skip

I wasn't expecting to have to prime this pump
April 22, 2012 5:09 PM   Subscribe

Why does my iTunes have a delay on audio output unless it's "warmed up"?

This is driving me nuts, and I hope one of you fine people can help me. Maybe I should just go to a Genius about this, but I haven't asked a question in so long.

My computer is exhibiting some strange audio behavior. When I'm using iTunes, there's a short lag before the track starts playing. And by that I don't mean I'll try to start playing the track, have to wait a little bit, and then it plays as expected. I mean I'll start playing the track, it'll go for a (very) short time, and then the audio will start after that delay, causing me to miss a little bit.

For a specific example, when I'm playing the Beatles' "Please Mr. Postman", the audio will come in as "-ait!", missing the hi-hat and "w" at the beginning. It's not much of a delay, but it's crucial. And annoying.

To make it even better, this is a problem that's both consistent and inconsistent. It happens all the time, but only if there's been some time since audio has been played. I can play something, get the delay, then immediately play it again and the delay is gone. But if I wait for a while (a minute? 30 seconds? I haven't had the patience to be really scientific about this), the delay will be back. And on top of that, iTunes is the only program I've found that has this problem. Anything else plays fine. And anything can act as the audio primer for iTunes to act fine, too.

I don't imagine it's something with the hardware, since other programs will play audio fine. And iTunes shows the same behavior on audio output in general, like when I have headphones plugged in.

This is a 2011 MBP, model identifier MacBookPro8,2. It's running Mac OS X 10.6.8, and I'm using iTunes 10.6.1 (7). I can't remember when this started, but it's been going on for a while.
posted by cardioid to Computers & Internet (9 answers total)
 
I don't know what it is either, but I have had similar problems with my 2006 MBP still running Tiger, and had put it down to "it's an ancient machine, running an aged OS".... Would be interested to hear otherwise!
posted by FlyingMonkey at 5:15 PM on April 22, 2012


Random possibility: any difference if you go into the Energy Saver control panel and turn off the "Put the hard disk(s) to sleep when possible" setting? (If you're plugged in, change it under Power Adapter, not under battery)

My 2009 MBP running the same OS and version of iTunes does not do this, for what it's worth.
posted by bcwinters at 5:26 PM on April 22, 2012


My 2008 MBP will often show that sort of delay when I fired up music in iTunes not just because my local hard drive might be napping, but if one of the drives attacked to my Airport Extreme is asleep. If I'm in the same rooms as the drives I'll hear them spin up and once that happens no delays.
posted by birdherder at 5:46 PM on April 22, 2012


re: Energy saver.

I knew I forgot to mention something. I took the SSD option, so I wouldn't expect a sleeping hard disk to be the problem. I also wouldn't expect that to be a problem so quickly (after just a minute of audio not playing) or be resolved so quickly (in time to get the "-ait"). Still, it was worth a try. So I tried. And it did nothing.

Speaking of random possibilities, might this have something to do with a too-large iTunes Library? I do have slightly over 30GB.
posted by cardioid at 6:54 PM on April 22, 2012


A 30GB iTunes Library shouldn't be an issue.

Shot in the dark: do you have iTunes Match? I don't think it'd cause the problem you're describing, but maybe?
posted by griseus at 7:02 PM on April 22, 2012


No iTunes Match.
posted by cardioid at 7:56 PM on April 22, 2012


Computer suck. I'm going to list a couple stock "start afresh" answers, maybe someone can offer something better targeted to your problem.

Have you tried re-installing iTunes? If that doesn't work, look for an older version of iTunes online (not through Apple's site, they won't have it).

If it's worth the annoyance, maybe reinstall your OS. Backup first.
posted by victory_laser at 1:57 AM on April 23, 2012


Some forum posts on this topic suggest disabling multiple speakers if you happen to have that enabled.
posted by rongorongo at 5:10 AM on April 23, 2012


As it turns out, this actually isn't an iTunes-only problem. It's just that iTunes a) has the longest delay, b) is the quickest to need the delay, and c) is used so much more than other things that it was extremely obvious.

I've noticed a bit of the delay when using Cog and even in the browser when looking at the YouTube video I gave as an example. So this is something with audio output in general.
posted by cardioid at 9:50 AM on April 23, 2012


« Older My wife and I will (very soon!...   |  Help me plan my first brunch e... Newer »
This thread is closed to new comments.


Post