Foscam+AirportExtreme=MeInsane
April 18, 2012 6:14 PM   Subscribe

For the love of God how do I get my foscam ip camera to work over the internet via my airport extreme?

I having been working on this for at least 6 hours and am losing my mind. I have looked at all the tutorials I can find and none seem to work.

1) I have a Foscam FI8918W
2) Works perfectly locally over wifi.
3) I set up an account at dyndns - the url name with the port # seems to work if the camera is plugged into the airport extreme.
4) If I go on a different wifi network neither the ip nor the dyndns url work.
5) Have tried the surveillance pro app with no luck
6) I have set up a username and pw so its not just the admin one
7) I thought I set-up port mapping correctly - all ports are listed as 83 (although I also tried 80 and 86). Private IP address is the IP for the camera I get when I run ipscanner
8) I tried an ipv6 tunnel and not blocking incoming connections
9) It is set to WPA/WPA2 Personal (heard some cams have a problem with just WPA2)
10) My DynDNS Ip address is the ip address of the camera. I also tried my ip address from whatismyip

Losing my mind - any help would be much appreciated. There was a previous question from about a year+ ago but didn't seem to get a set resolution.
posted by IzzeYum to Computers & Internet (7 answers total) 2 users marked this as a favorite
 
Oh I should add - it does not appear to work locally over the iPhone app - just locally over the computer
posted by IzzeYum at 6:15 PM on April 18, 2012


Also - When I use the app it thinks for a while and then I get two white lines with the no image question mark box between them. Have tried using app with and without username, with ip address and with dyndns url.
posted by IzzeYum at 6:19 PM on April 18, 2012


My DynDNS Ip address is the ip address of the camera

I think this is your problem.

You want the Dyndns account to use your home network's external IP.
posted by pompomtom at 6:30 PM on April 18, 2012


Sorry, I have misread (though you still want dyndns to be your external IP, not the camera's local IP).
posted by pompomtom at 6:32 PM on April 18, 2012


Is your wireless on a different subnet or vlan? And how does the router know what IP address to forward the port to when the camera is on wireless? I assume it changes.
posted by gjc at 10:34 PM on April 18, 2012


Does your ISP block low-numbered ports? Perhaps you should try forwarding port 8080 on the airport to port 80 on the camera.

How is the camera obtaining it's private IP address? If it's getting a DHCP address from the airport, you might have to set up a static ip assignment so that the foscam always gets the same dynamic ip. If you're setting a static ip address on the foscam, is it in the same subnet as the airport?
posted by RonButNotStupid at 4:49 AM on April 19, 2012


just recently set one of these up myself on an airport wifi network. you need to verify the following (in this order):
- your network either has all static IPs or uses DHCP for a range of dynamic IPs
- your camera has a static IP outside of the DHCP range (do not use DHCP), subnet mask is the same as the airport's, gateway and DNS server are the ip of the airport (probably 10.0.1.1 or 192.168.1.1)
- your airport forwards incoming traffic on internal port X to the camera's IP
- your dyndns address is the ip address from whatismyip

for external port, I used a high one (8091); for internal port, 80 is fine. Just make sure the airport is set up to do these translations through the port forwarding settings.

If there is a step above that doesn't make sense or isn't right, please explain and I'll try to diagnose further.
posted by Chris4d at 11:05 PM on April 19, 2012


« Older Are there any simple wireless ...   |  Please recommend novels that d... Newer »
This thread is closed to new comments.