Skip

can't get tasker profiles to import
April 13, 2012 10:48 AM   Subscribe

I can't import any profiles in Tasker. Help!

(I am running Tasker version 1.2.1u1. I have a T-Mobile MyTouch 3G Slide running Froyo.)

I found a profile I would like to use - (http://tasker.wikidot.com/local--files/nightsmsresponder/NightSMSResponder.prf.xml). I download the file (by using "Save Link As", otherwise it takes me to a web page with what looks like code) and it goes into my ./sdcard/download directory. I move it (using AndroZip) to ./sdcard/Tasker/profiles directory.

I open Tasker, go to "import profile", go to /sdcard/Tasker/profiles, and NightSMSResponder.prf.xml is not there. It does not show me anything to be imported.

I have double- and triple- checked the paths (because I have a "Downloads" and a "download" path and can't find them. I created a folder called "Test" in the Tasker directory, and put the .xml file in there. In Tasker, I see the "Test" folder but nothing is in it.

I've had this problem with other .xml files on this site, so it's not a one-off fluke.
posted by Lucinda to Computers & Internet (11 answers total)
 
Try it a different way.

Copy the URL to the XML file you give above, http://tasker.wikidot.com/local--files/nightsmsresponder/NightSMSResponder.prf.xml

Go to that URL in your phone's browser.

The browser will offer to open the URL either in the browser itself or in Tasker. Choose to open it in Tasker.

Tasker will then save it to the XML file to the right directory on your phone and give you a message that it's done.

Then go into Tasker and hold down on the "Profiles" tab in the menu in the upper left until the Options window appears. Choose "Import."

It should take you right to the very folder where you downloaded the file. On my folder, it's /mnt/sdcard/Tasker/profiles, which is different than what you give above.

Choose the file you just downloaded. It shoujld now appear among your Profiles.
posted by Mo Nickels at 11:49 AM on April 13, 2012


On re-read, it sounds like you need to reset the way your Browser app handles XML files. Follow these instructions for the Browser app. After that, it should present you with a choice when going to an URL for an XML file and should not simply show it as code.
posted by Mo Nickels at 11:55 AM on April 13, 2012


I followed the instructions you posted for the Browser App, but it is already set as the default application.
posted by Lucinda at 12:03 PM on April 13, 2012


The Browser app should not be set as the default application, though. What you're doing by clearing those defaults is making sure that the Browser app gives you a choice when you visit XML files. You're not currently seeing that choice, right?
posted by Mo Nickels at 12:07 PM on April 13, 2012


In other words, you want Tasker to handle the download, not the Browser app.
posted by Mo Nickels at 12:08 PM on April 13, 2012


When I go to the "Launch by default" section under the application info in Tasker, the button is greyed out and it says "No defaults set."
posted by Lucinda at 12:17 PM on April 13, 2012


If I long-press on the download link, I get "save link" as an option. It downloads the file and saves it as a .xml file. If I long-press on the notification that the file was downloaded, I get the option to "Complete action using" AndroZip or Tasker. If I choose Tasker, it says "Sorry, this content cannot be handled by Tasker".
posted by Lucinda at 12:21 PM on April 13, 2012


"When I go to the "Launch by default" section under the application info in Tasker, the button is greyed out and it says "No defaults set.""

That's not what you should do. As I wrote above, you want to do that for the BROWSER app, not Tasker. You want the Browser to stop handling the XML files as if they were web pages.

"If I long-press on the download link, I get "save link" as an option. It downloads the file and saves it as a .xml file. If I long-press on the notification that the file was downloaded, I get the option to "Complete action using" AndroZip or Tasker. If I choose Tasker, it says "Sorry, this content cannot be handled by Tasker"."

That's not really the best way to get these profiles --download them, don't save-as them -- but the "cannot be handled by Tasker" message is also unexpected behavior. Tasker should be handling that file if you've reset the browser's "launch by default." At least, it does on my phone, but then I likely have a different (newer) web browser. I have the same version of Tasker on the same phone but I am running Cyanogenmod 7.2-RC-1.
posted by Mo Nickels at 12:29 PM on April 13, 2012


(Actually, that "save link" method should be the same as downloading.)
posted by Mo Nickels at 12:30 PM on April 13, 2012


Have you tried downloading the file to your desktop computer, mounting the phone as USB storage, then copy the file over? If you do that, also try to copy the file to the root level of the USB storage and see if the file is visible there.
posted by Mo Nickels at 12:32 PM on April 13, 2012


Got it - I e-mailed it to myself, set the default to Tasker when I downloaded it, and it imported and appeared. Yay!
posted by Lucinda at 12:44 PM on April 13, 2012


« Older What can I expect from this un...   |  YANMP (perinatologist) and I w... Newer »
This thread is closed to new comments.


Post