Join 3,572 readers in helping fund MetaFilter (Hide)


How do I get audio streaming Netflix to my tv?
April 10, 2012 6:24 PM   Subscribe

How can I get audio while streaming Netflix through my PC to my tv?

So, I can't get any audio while streaming Netflix. I'm running Windows 7, and my PC is connected to my tv with an HDMI cable. Computer sounds are audible through the tv (e.g. at startup), and the picture is great. But I can't get any audio from the movie. Anybody have any idea what's up with this?
posted by Fists O'Fury to Computers & Internet (5 answers total) 1 user marked this as a favorite
 
What kind of PC do you have? On mine (a Dell Inspiron laptop), the sound is dependent on whether I have the PC or the TV set up as the primary display.
posted by something something at 6:28 PM on April 10, 2012


I have had a similar experience as something something using a Dell Windows XP laptop from about 2006-07. So try that and if it doesn't work, we'll dig deeper.
posted by OnTheLastCastle at 6:35 PM on April 10, 2012


Does your TV have some sort of pass-through mode for HDMI? IIRC HDMI can pass video, audio, or one or the other. A setting might need to be changed for both.
posted by calistasm at 7:26 PM on April 10, 2012


My cousin's HP laptop gave the sound to the PC or the TV, depending on which screen (display) the player was on when playback began.

I don't know how Netflix is done on a PC-- is it in a windowed player? (setting aside the almost certain fact that one can fullscreen it)?

Do your TV and Monitor work as one big extended Desktop? If so, make sure you move the Netflix player/window to the TV before starting playback.

Another thing-- when you plug your HDMI into your TV, does Windows create new devices, e.g. sound and video devices? You may need to go to your volume controller and set the audio playback device as the TV's sound device. (Volume controller settings or Advanced, or however it's done-- or go through control-panel -> sounds)

good luck
posted by Sunburnt at 7:52 PM on April 10, 2012


Thanks everybody. Problem fixed, but, sadly, tired, cranky and frustrated, I didn't make changes incrementally, so I can't say what exactly did the trick, but I think it was just making sure that all my drivers were up-to-date. Duh.
posted by Fists O'Fury at 1:46 PM on April 11, 2012


« Older I just moved. Everyone in the...   |  I'm throwing myself over a fin... Newer »
This thread is closed to new comments.