Help me disable automatic brightness adjustment on my windows 7 htpc.
March 25, 2012 12:14 AM   Subscribe

I use Windows 7 Media Center to timeshift basketball games and it works fine, except that after a commercial break where there is a bright white commercial, the brightness is shifted down, and the subsequent footage is too dark. This happens at record time but I'm not sure exactly what is causing it or how to disable. My capture card is an ati tv wonder 600 pci.
posted by Manjusri to Computers & Internet (2 answers total)
 
That's a common problem with many (if not all?) of the ATI analogue capture cards from the last 2~3 years. It's due to the AGC (automatic gain control) time constant & gain settings of the card & driver.

I'm struggling to remember or Google the exact details, but IIRC it's something like:
  • Cards up to early revisions of the 600 / 650 were OK.
  • Under XP, later revisions suffered from the AGC issue that causes that blooming, but it could be partially solved by installing an earlier driver version and setting the gain manually in the Video Proc Amp settings.
  • Under Vista & above, later revisions suffer from the AGC issue - but the current drivers have all the manual settings under Video Proc Amp blanked out, the earlier versions of the XP driver can't be coaxed to work, and there's not much you can do.
My only suggestion would be to get a better card, but I'm not sure whats readily available these days that isn't ATI-based, apart from the more expensive Hauppage / Grass Valley (Canopus) devices.
posted by Pinback at 2:29 AM on March 25, 2012 [1 favorite]


Thanks! Always amazed by in depth answers here.
posted by Manjusri at 1:29 AM on March 28, 2012


« Older What's a good car for city liv...   |  Hi everyone, I live in Seat... Newer »
This thread is closed to new comments.