Join 3,374 readers in helping fund MetaFilter (Hide)


Wifi + Android = Disaster (ok, that's an overstatement)
March 17, 2012 12:05 AM   Subscribe

My wifi connection is driving me insane. I mean this literally. It is making my mobile reboot, freeze, etc. I offer a reward to anyone who solves this riddle.

I'm honestly sorry to post here some mundane question about mobile connnectivity, but I don't know where else to turn. If anyone can help me resolve this, I I will send you a bar of the finest Dutch chocolate.

I have a Samsung Galaxy Ace. For some reason, whenever it is connected to my home wifi (and the wifi in a few other places), it will spontaneously disconnect itself and do a soft reset. This happens about every five minutes.

I sent it out for repair three times -- this final time they told me that nothing was wrong with the device itself. As an illustration, the phone company connected me to their own wifi network and nothing happened. The connection stayed perfectly.

If I keep the wifi connection off, the phone works fine.
The wifi works fine for all the other innumerable devices in my home.

I really appreciate any expertise you guys might have.
posted by mateuslee to Technology (18 answers total)
 
I might try changing the channel of your wifi. Can't hurt. It once solved weirdness for me that there was no explanation for.
posted by whatisish at 12:14 AM on March 17, 2012


Settings -->Wireless and network settings --> WiFi Settings
You will see Wi-Fi and Network Notification on screen along with your Wifi networks below.

On this screen click on Menu (Left touch button to the middle-Home button)

You will see two options popped up -- Scan and Advanced
Select Advanced here and you will go to Advanced screen
Select Wi-Fi sleep policy. -- You will probably find "When screen turns off" selected. Select "Never" here.

DO NOT SELECT Cancel here. Hit the back button and you will be back to Advanced screen.

Now return to Home and you are done...

It worked for me with Gingerbread OS.
posted by karathrace at 12:30 AM on March 17, 2012


@ Karathrace -- The mobile is already sent to keep wifi on always. And this problem happens even when the screen is on, when I'm in the middle of an email or something...
posted by mateuslee at 12:38 AM on March 17, 2012


Have you upgraded to gingerbread?
posted by karathrace at 12:56 AM on March 17, 2012


Also, download the 'load monitor' app. That should help.
posted by karathrace at 12:57 AM on March 17, 2012


@ karathrce - Yup, I'm on gingerbrad.xwks2 and just installed LoadMonitor. My load is 8.30. High load!
posted by mateuslee at 1:09 AM on March 17, 2012


OK, it just happened again -- the load monitor was 12 before it did a soft reset and kicked me off wifi.
posted by mateuslee at 1:13 AM on March 17, 2012


XWKT7 is the gingerbread version you want to update to from kies.
posted by karathrace at 2:13 AM on March 17, 2012


I don't understand what you mean. by "kies". Do I need an update?
posted by mateuslee at 2:49 AM on March 17, 2012


Samsung Kies is the Samsung PC app that lets you back up your phone and do firmware updates. Worth a try.
posted by samj at 4:39 AM on March 17, 2012


You don't say what make and model your wireless router is. Assuming that there's nothing wrong with your phone hardware, there's really only one other variable involved in this problem, and that's the wireless access point.

Just because the wifi works well for all other devices in your home doesn't mean that those router settings aren't toxic to your phone. It could be provoking some latent protocol bug in your phone's software which isn't in the other devices. This could be anything: maybe it doesn't like 802.11 G+N mode. If it's in N-only mode, maybe it doesn't like the wide band support. If you're using WPA2, maybe it doesn't like AES-only mode; try switching back to TKIP+AES.

Try stripping it all the way down to minimal settings (no encryption, factory-base settings, 802.11 mixed mode) and see if the drops still occur. If they don't, congratulations, the wireless router hardware hasn't gone bad. Disconnecting each time (switch wifi off on the phone), add options back in to the router configuration one at a time. See if you can identify the exact change which causes the phone to start dropping your connection.
posted by Suddenly, elf ass at 8:44 AM on March 17, 2012


Along those lines, I seem to remember something about some wifi chipsets on low-end Androids playing best with routers set to 802.11g using WPA or WPA2 with AES. If there's a setting on your router that disables 802.11n (assuming it's n-capable) or is 802.11g-only, try setting that.
posted by zombieflanders at 10:05 AM on March 17, 2012


Does your WPA pre-shared key have spaces in it? Shouldn't matter in the slightest. Sometimes does though.
posted by flabdablet at 10:21 AM on March 17, 2012


Have you tried restoring the phone to factory settings i.e. no added apps? It could be a buggy app or some sort of bad interaction.
posted by ennui.bz at 11:44 AM on March 17, 2012


Something similar happened to me with my SGS i9000

This solution worked for me - your milage may differ
Try this... In some Samsung firmware the wifi only worked when a static IP address worked (apparently).
posted by Dub at 12:34 PM on March 17, 2012


Try a static IP address.
posted by PickeringPete at 8:09 PM on March 17, 2012


Dub, you did it. Holy cow, I'm sane again... no more annoying dropped connections. I will send you a MeFi mail to arrange shipment.
posted by mateuslee at 1:30 AM on March 18, 2012


Yay for our team!
posted by Dub at 5:36 PM on March 18, 2012


« Older How can I create my own custom...   |  Homemade chocolate recipes sou... Newer »
This thread is closed to new comments.