Join 3,572 readers in helping fund MetaFilter (Hide)

Tags:

Help me find the question mark on my keyboard!
February 15, 2012 9:47 PM   Subscribe

I~m having an issue with my Mac keyboard not working properly with a PC running Windows XP. My punctuation is all screwy and I can~t figure out how to fix it. Hope me please!

My Mac desktop called it quits yesterday, and a wonderful neighbor offered her older PC so I can still surf the web & do my work. Unfortunately, there seems to be some disagreement between the Mac usb keyboard I~m using (pictured here) and Windows XP pc. Specifically, the 6 keys to the right of the P, L and . keys. Where I should be getting a slash and a question mark, I~m getting ; and : (not so hard to figure out), but my the two keys above are giving me çÇ and ~^ where I should be getting my (semi)colons and double & single quotes. (The quotes are on the key under the escape key, I just noticed.) But I can't find the question mark! The keyboard options in the control panel aren't any help.
Does anyone know if there's a fix for this, or am I going to be stuck asking questions that look like statements until I pony up for a new keyboard.

Thanks in advance!
posted by biddeford to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
If you're up to writing a little script, then AutoHotkey should allow you to map your keys wherever you want.
posted by koeselitz at 10:03 PM on February 15, 2012


Make sure your XP is set to use a US keyboard. The çÇ etc makes me think it is set for a Canadian or other non-US keyboard. Out of the box the Mac keyboard will map perfectly except for the missing keys like the Windows or Print Screen keys.

It has been many years since I've used XP but I think the keyboard setting safe in the control panel area under keyboards or international.
posted by birdherder at 10:11 PM on February 15, 2012 [2 favorites]


I agree with birdherder, but I'm going to go with Portugese (Brazilian).
posted by aloysius on the mixing boards at 10:26 PM on February 15, 2012


Fuck, I linked to the wrong one. I meant this one.
posted by aloysius on the mixing boards at 10:27 PM on February 15, 2012


Thanks, koeselitz. I'm going to give AutoHotkey a try. I think that~s pretty much exactly what I1m looking for.

berdherder & aloysius: From what I can see, all the XP settings are for US English, although the control panel for keyboard operations says that I~m using a Microsoft driver (the previous owner & I haven~t loaded any drivers; we both have plug 'n' play usb keyboards.) What is this 'Ç' symbol, anyway: Is it Canadian currency:
posted by biddeford at 10:48 PM on February 15, 2012


It's c cedilla.
posted by sbutler at 10:51 PM on February 15, 2012


The international keyboard will remap the righthand keys as well. If there's a two-letter icon near the clock in XP, you can click or right click on it and change it to English in the Language Bar and characters will go back to the correct mappings of US English.
posted by birdherder at 11:05 PM on February 15, 2012


Thank you birdherder! It turns out the keyboard was set to Portugese, after all. (Good call, aloysius on the mixing boards!) It's nice to have my punctuation back. Thanks everyone!
posted by biddeford at 11:42 PM on February 15, 2012


« Older Please recommend software for ...   |  This is one for the design-hea... Newer »
This thread is closed to new comments.