Join 3,364 readers in helping fund MetaFilter (Hide)


iMac trackpad and keyboard aren't working
January 28, 2012 9:05 PM   Subscribe

I just got an iMac, but the wireless trackpad and keyboard aren't working.

I’ve tried clicking the power buttons on the trackpad and keyboard. This causes the green light to show up, so they’re not out of batteries.

The trackpad and keyboard were working before when I was registering the computer, etc. But they stopped working after I migrated my old computer’s files onto the new one. So now I can’t get out of Migration Assistant.

I can’t call Apple Support because it’s closed, and I haven’t found the answer on the Google.

Any ideas?
posted by John Cohen to Computers & Internet (22 answers total) 1 user marked this as a favorite
 
do you have bluetooth turned on on your iMac?
posted by Pants! at 9:17 PM on January 28, 2012 [1 favorite]


I don't know how to tell. I assume so, since the keyboard and trackpad were working before.
posted by John Cohen at 9:18 PM on January 28, 2012


Yeah, it sounds as if the migration may have imported a Bluetooth preference file that leaves it either switched off or not discoverable. If you have wired peripherals on hand, you might be able to resolve it following these directions to trash your old Bluetooth .plist file. (A wired mouse may suffice if you have auto-login for your user account.)
posted by holgate at 9:22 PM on January 28, 2012


Perhaps you need to re-pair the devices? The computer should automatically go into pairing mode if no Bluetooth devices are detected and no USB devices are attached.

To put the Bluetooth devices into pairing mode, hold in the power button to turn off the device, release, then hold in the power button until the indicator light flashes.

The computer will then detect the device. Follow the onscreen instructions to complete the process.
posted by RandyWalker at 9:24 PM on January 28, 2012


I have lost the bluetooth connection before. Do you have a wired USB mouse handy? Check in the Bluetooth section of System Prefs, & see what's up there. There's also a checkbox you can tick in the Bluetooth section to show bluetooth status in the menu bar, for easy access. Then, every device will be listed in a menu, with a sub-menu where you can connect or disconnect.
posted by Devils Rancher at 9:25 PM on January 28, 2012


If you have wired peripherals on hand...

I don't.
posted by John Cohen at 9:26 PM on January 28, 2012


Can you get to it via screen sharing from whatever machine you're typing this on?
posted by Devils Rancher at 9:28 PM on January 28, 2012


hold in the power button to turn off the device, release, then hold in the power button until the indicator light flashes.

The computer will then detect the device.


I've tried this, and the light flashes, but it still doesn't work.
posted by John Cohen at 9:29 PM on January 28, 2012


Can you get to it via screen sharing from whatever machine you're typing this on?

I don't know how to do that. (I'm typing this on a MacBook Pro, OS 10.6.8.)
posted by John Cohen at 9:31 PM on January 28, 2012


In the Finder sidebar (left side of a Finder window) of your MacBook Pro, is the new machine listed under the "shared" section? Select it there & see if it'll let you share the screen. If so, you can control the iMac remotely.
posted by Devils Rancher at 9:43 PM on January 28, 2012


Screen sharing may be visible in the Finder under "SHARED": "X's remote desktop on Y". If not, you leave it till the morning, beg/buy/borrow a cheap USB mouse and keyboard (thrift store will do as long as they have USB and not PS/2 connectors), and use those. Or try a 24/7 Duane Reade if you're desperate.
posted by holgate at 9:45 PM on January 28, 2012


There is no "shared" section in the finder sidebar on my MacBook Pro.
posted by John Cohen at 9:49 PM on January 28, 2012


Drat. That's because there's no shared machines available, alas. you only get the heading if there's at least one machine available for sharing. I was only hoping it might have showed up there, but you would probably have had to turn on sharing in the iMac prefs. I believe it's off by default on new machines. Sorry, without a USB mouse, I'm outta ideas.
posted by Devils Rancher at 9:54 PM on January 28, 2012


Yeah, the only thing I've done with this iMac is doing the migration and then getting to the Finder. I haven't set up anything.
posted by John Cohen at 9:56 PM on January 28, 2012


For now, maybe you could shut it down and re-start holding down the "R" key? This should allow you to boot up from the recovery partition.
posted by bonobothegreat at 11:07 PM on January 28, 2012


But the "R" key is on the keyboard that doesn't work.
posted by John Cohen at 11:11 PM on January 28, 2012


Then you could just hold down the power button on the back of the machine to turn it off. Then turn it back on again.
posted by Effigy2000 at 11:25 PM on January 28, 2012


I just got the keyboard and trackpad to work by turning the computer off with the power button, then turning it back on. After the startup, it automatically searched for the devices.

The migration doesn't seem to have worked, but whatever.
posted by John Cohen at 11:26 PM on January 28, 2012


Oy! Sorry about that (I'm up past my bedtime).

This article says that you can reboot from an alternate drive using an apple remote (by holding down the menu button). I don't know if this means the recovery drive is accessible.
posted by bonobothegreat at 11:27 PM on January 28, 2012


(Actually the migration did work — I just had to sign into the account associated with my old computer and always use that one.)
posted by John Cohen at 7:30 AM on January 29, 2012


My apologies if you already know this, but if you set up an account to get started with your iMac and then there's a secondary account that is the one you'd actually like to use, you can just delete the first account from the "Accounts" section of system preferences. I've done this before and wound up with one account called j and one called jessamyn because I did some of the Migration stuff in a different order than Apple was expecting. So, assuming your main account is an Administrator [if not, go through the steps to make it an administrator] log in as the account you want to keep, go to System Preferences > Accounts, click the little lock in the lower left corner, select the account you want to remove from the lefthand column [make sure you have any information/data out of it] and click the minus sign. You'll get a confirmation screen that asks if you want to delete it entirely or just archive it. If it's your "I had this for five minutes" account you may want to just nuke it. This is also where your login options live and you can set the computer to start up in your main account so you don't have to, if you don't want to, log in every time you turn the machine on but you'll still need the password to do admin stuff.

In any case, sorry if you already know all this, but it's stuff I wish someone had told me when I was first moving to a new Mac. Let me know if you could use a backup USB mouse just in case, I literally have a closet full of them here.
posted by jessamyn at 8:02 AM on January 29, 2012


Jessamyn is correct, but it is always good to have a second administrator account on your mac. Just in case your account gets borked.
posted by Gungho at 10:27 AM on January 29, 2012


« Older I'm having pelvic pain. You a...   |  Hello Everyone! I am 28 an... Newer »
This thread is closed to new comments.