Skip

Windows 7 thinks I am connected to a projector and my laptop screen is black. How can I force it to return to normal?
December 30, 2011 5:52 AM   Subscribe

Windows 7 thinks I am connected to a projector and my laptop screen is black. How can I force it to return to normal?

Some potentially important details: I am running Windows 7 using Bootcamp on a MacBook Pro. This may be part of the problem because I was trying (without success) to connect my laptop to a projector while on the Windows side.

Out of desperation I chose the option to connect to just the projector (rather than mirroring the screen). This turned the screen black and now I am stuck in this limbo. I can't flip the setting back.

I can boot into Windows safe mode and access the system, but at first glance there seems to be little I can do there to fix the situation. But hopefully that's where one of you come in!
posted by jeremias to Computers & Internet (6 answers total)
 
In Windows 7, the key combination Win+P (which on the Macbook is Apple+P) toggles through projector only, no projector, mirror, and extend desktop.
posted by maxim0512 at 6:13 AM on December 30, 2011 [1 favorite]


what maxim0512 said, Win+P, hit the right arrow once and hit enter. I imagine that should do it.
posted by zombieApoc at 6:24 AM on December 30, 2011


Function key plus F8, until it goes back to normal.
posted by vincele at 6:42 AM on December 30, 2011


If the above fails, one scorched-earth method would be to boot into safe mode, go into Device Manager, remove the display device, and reboot. You might need to reinstall the Boot Camp driver package afterwards, though.
posted by neckro23 at 8:32 AM on December 30, 2011


There are basically two methods for dealing with this. You can tell Windows which screen you want it to use (the Windows-P / Connect to a Projector method), or you can tell the laptop not to expose a second display (vincele's function key method) which should force Windows to use the only one remaining to it.

The specific order of the Connect to Projector (Windows-P) options is Computer Only, Duplicate, Extend and Projector Only. Having brought up the Connect to Projector prompt, the left and right arrow keys will navigate between these options and Enter will select one.

The only one that leaves the computer screen black is Projector Only, which is what you'll currently be set to. So you need to log on blind, then press Windows-P, then press right arrow once to wrap around from Projector Only to Computer Only, then press Enter.
posted by flabdablet at 8:42 AM on December 30, 2011


Yep, Apple+P did it. I had known about the the Function + f8 option previously and that actually didn't work when I tried a few days ago. But for some reason the Apple+P shortcut never made it into my brain's databank and that did work.


Thanks all!
posted by jeremias at 11:50 AM on December 30, 2011


« Older I am trying to buy an EMDR dev...   |  MS Access 2010 Help - I need t... Newer »
This thread is closed to new comments.


Post