Join 3,494 readers in helping fund MetaFilter (Hide)


All my Big Bang songs look the same!
November 10, 2011 2:37 AM   Subscribe

How do I get Windows 7 to display Chinese/Japanese/Korean characters on a non-administrator account?

I'm running Windows 7 Home Premium. East Asian characters display as boxes in Itunes when I'm using my normal non-administrator account.

If I log in as the admin account, they display fine, so I know the correct font and language support is installed.

- The system font is Segoe UI for both accounts.
- The characters display fine in web pages and in Word documents, but not in Notepad or in Explorer.
- To be clear, I don't want to switch the UI language using a Language Pack. I just want to correctly display those East Asian unicode characters which I know are present in the Segoe UI font.
- It works just fine on the administrator account on the same machine!!!!

How do I get them to display correctly on the non-administrator account?
posted by dave99 to Computers & Internet (1 answer total)
 
Go to your Control Panel, select Clock, Language and Region, select Regional and Language Options, select Install or Uninstall display Languages.
posted by Yellow at 4:11 AM on November 10, 2011


« Older hi, i live in south west victo...   |  My pc is infected with trogan ... Newer »
This thread is closed to new comments.