Join 3,497 readers in helping fund MetaFilter (Hide)


Need help decoding an Ioncube file...
November 7, 2011 8:21 PM   Subscribe

I need help decoding an Ioncube file...

I've inserted thousands of listings into an installation of phpMyDirectory and now I get an error on my site saying...

Fatal error: Allowed memory size of 33554432 bytes exhausted in /home/public_html/mysite.com/includes/class_database.php on line 149

All I want to do is increase the maximum memory usage within the file from 32MB to 64MB or more but I can't because the file is encoded...

There are services online where you can pay for this but I don't feel I should have to pay for something that should work, all I want to do is change a couple of numbers in the file but I can't even read it...

If anyone could give me some advice on how I can get this done for free I would greatly appreciate it.

I've tried downloading software for this but it seems impossible, I've spent a couple of hours doing so but can't find anything...

If someone knows how to do this could you please upload the file to MegaUpload (it's really easy) and give me a link to it? I would greatly appreciate it..

Thanks in advance
posted by Bacillus to Computers & Internet (17 answers total)
 
I've tried to get phpMyDirectory support to increase the size of the "Allowed Memory" but they don't seem to want to do it for me...
posted by Bacillus at 8:24 PM on November 7, 2011


Have you tried changing the memory limit at the server level in php.ini?
posted by odinsdream at 8:25 PM on November 7, 2011


I don't know if I can, it's on a shared server... can I access this through FTP?
posted by Bacillus at 8:31 PM on November 7, 2011


I guess I could try this, could this work?
posted by Bacillus at 8:33 PM on November 7, 2011


Ask your webhost for sure - this should be a fairly standard thing.
posted by odinsdream at 8:40 PM on November 7, 2011


I'll ask them... But I thought the problem was with the class_database.php file, where I can increase the memory from there...
posted by Bacillus at 8:45 PM on November 7, 2011


I've still emailed my hebhost about it...
posted by Bacillus at 8:48 PM on November 7, 2011


If you can't access the php.ini file directly, you can try setting it directly in your .htaccess file.

For example:
php_value memory_limit 32M

Note that this depends on how your shared host is set up and may not work.
posted by madajb at 8:50 PM on November 7, 2011


The php.ini and .htaccess methods are going to take precedence over the script values, if you're able to set them.
posted by odinsdream at 8:58 PM on November 7, 2011


I tried to change the .htaccess memory_limit but got the following error...

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@drdoctordb.sextoystar.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
posted by Bacillus at 9:00 PM on November 7, 2011


Have you tried contacting the server administrator at Sex Toy Star?
posted by odinsdream at 9:03 PM on November 7, 2011


Not yet, I'm doing that now...
posted by Bacillus at 9:20 PM on November 7, 2011


I tried creating my own php.ini file and redirecting .htaccess to it but I get an error saying phpMyDirectory needs Ioncube to run... I there anywhere I can find a php.ini file with Ioncube enabled?
posted by Bacillus at 9:35 PM on November 7, 2011


You might be able to put the Ioncube loader in your home directory, add a reference to it in your php.ini, and have it work, but that's going to depend upon a) knowing the OS of your hosting server so that you upload the correct binary extension; b) your host's policies for user-provided extensions.

Have you tried creating a phpinfo file to see what exactly is available on your host?
posted by holgate at 10:13 PM on November 7, 2011


> I tried to change the .htaccess memory_limit but got the following error...

> Internal Server Error

Your web host is using suPHP, in which php_value is not a valid .htaccess directive. They will probably have some solution involving letting you have a custom php.ini. You just need to ask.

> Fatal error: Allowed memory size of 33554432 bytes

...is 32 megabytes, which is a bit stingy. If they won't let you have a little more, get a different web host.
posted by evariste at 7:38 PM on November 9, 2011


> I there anywhere I can find a php.ini file with Ioncube enabled?

Yeah, on your server. Info from someone else's php.ini likely won't work. The path to Ioncube and other PHP extensions will vary among web hosts, as will the version. Make a text file, call it info.php, and put it this in it:

<>

Copy it to your web root, then visit yourdomain.com/info.php. Look for "Configuration File (php.ini) Path" and then ssh in to your server. Copy the file over ssh if you have access to it. If you don't have access to it, well, talk to your web host. This is a pretty normal request.
posted by evariste at 7:44 PM on November 9, 2011


Code should have looked like:

<?php phpinfo() ?>
posted by evariste at 7:45 PM on November 9, 2011


« Older I'm spending nearly $400/month...   |  If I get attached to people ea... Newer »
This thread is closed to new comments.