Join 3,440 readers in helping fund MetaFilter (Hide)


Upgrading a friend's computer from XP to 7. I recall that simply copying files to a second internal drive resulted in some permission problems. How do I avoid this?
November 7, 2011 4:16 PM   Subscribe

Upgrading a friend's computer from XP to 7. I recall that simply backing up files to a second internal drive resulted in some permission problems. How do I avoid this?

Specifically, I recall that when I upgraded, documents in the "My Documents" folder weren't accessible, as I was no longer user admin of old computer.

My friend doesn't have the sense to know where all his files are and wants to simply back up the boot drive by copying it wholesale to another internal drive before the formatting and OS upgrade.

How do I avoid the user/permission problem?
posted by sisquoc15 to Computers & Internet (5 answers total) 3 users marked this as a favorite
 
An easy way would be to -- before copying the files -- format the backup drive as FAT32, which doesn't store permissions. Of course doing so would delete any files that were on the drive before you formatted it, so make sure it's empty before doing this.

But if he copied the files to a NTFS drive all he would need to do, as admin of the new computer, is to "Take Ownership" of the new files. You can do this all in one shot by right-clicking the folder, clicking Properties, then Security and then Advanced. In the Owner tab there should be a button that says "Take Ownership", which will likely show a UAC prompt. This will be applied to all files and subfolders in that folder.
posted by Simon Barclay at 4:25 PM on November 7, 2011


Windows Easy Transfer is actually remarkably easy.
posted by flabdablet at 6:55 PM on November 7, 2011


I just upgraded one of my laptops with an SSD and re-installed Windows. I put the old drive in a caddy and connected it via USB. When I tried to open the user directory, Windows told me that I didn't have permission and asked me to grant access or cancel the operation.

I let Windows take ownership of the files and after a couple of seconds I could access the files in question. Windows will now let me access the files and has not asked me this question again.

The only thing to be aware of when copying files in this way is to ensure that they are not encrypted, as it is possible to be permanently locked out. Encryption is not enabled by default, so this shouldn't be a problem for your friend.
posted by NordyneDefenceDynamics at 4:00 AM on November 8, 2011


On the old computer, make sure encryption is off first of all. Second, just turn off the option [that is somewhere I can't remember] that asks you to "keep my files inaccessible to other users of this computer". I do not use this option, and have never had permission issues that weren't easily fixed. But I have heard of people who have had those permission issues when they do use that option.

Finally, what you should probably do is right click on the user's folder under documents and settings and change the permissions to allow everyone full access, and make sure none of the user objects have "deny" set.

Another thing that used to work on older versions of Windows (and probably still works, but I'm not sure) was that if you had permission issues, you could create a user on the new OS that had the same name and password as in the old OS. An easy way is to make sure the "administrator" account is active.
posted by gjc at 5:11 AM on November 8, 2011


if you had permission issues, you could create a user on the new OS that had the same name and password as in the old OS.

That works for access to network shares, but it's of no use for access to "foreign" hard disks. Using an administrator-level account to take ownership of the folders you want is the only reliable method there (this is of course a hostile act if it's somebody else's hard disk and they're going to want to use it on their own machine again).
posted by flabdablet at 8:27 AM on November 8, 2011


« Older Can anyone tell me about terro...   |  Will someone tell me what's wr... Newer »
This thread is closed to new comments.