Join 3,382 readers in helping fund MetaFilter (Hide)


Optimize video playbook black (2006) MacBook
November 1, 2011 11:09 AM   Subscribe

Black 2.0GHz MacBook (2GB memory) from 2006 -- it's been repurposed as a Netflix playback machine. I have it connected to a VGA adaptor to a 19" widescreen monitor and it plays back Netflix in a browser and we also watch DVDs on it, and we also play AVIs with VLC. The problem: video is just slightly choppy. Just choppy enough to be annoying. Tried Chrome and also Safari to do the playback. How can I squeeze more video performance from this laptop to avoid the slight choppiness? I have a feeling if I can improve it just slightly that would be a big win.
posted by artlung to Computers & Internet (26 answers total)
 
Is the monitor mirrored or an extension of the desktop? Is the video choppy for everything or just Netflix?
posted by The Lamplighter at 11:14 AM on November 1, 2011


Other than making sure you're not running a bunch of other stuff inadvertently at the same time, more RAM and faster hard drive is about all you can do to make a laptop faster.
posted by mhoye at 11:16 AM on November 1, 2011


What's your internet connection like? I would think this has more to do with the quality of streaming video than any other factor here.
posted by mazola at 11:16 AM on November 1, 2011


I'm using a 2006 iMac (same speed, same memory) and yeah, performance is.... borderline. I've found that it works better if 1) you're using Snow Leopard instead of Leopard, 2) Hulu works better than Netflix, which works better than Amazon Video, and 3) performance over a wired connection is a lot better than over wireless.
posted by Oktober at 11:17 AM on November 1, 2011


Is playback choppy when viewed on your laptop screen as opposed to the monitor? What about in-browser vs. full-screen?
posted by mkultra at 11:18 AM on November 1, 2011


I have the same laptop, and I agree, it's getting just so slightly long in the tooth. These days, I just use it for light web surfing and some iTunes, and a little word processing. I never upgraded to an SSD. I think 2GB RAM is the max on these (1,1 Macbooks, no?).

I don't think there's much to do that can improve this model...
posted by Admiral Haddock at 11:25 AM on November 1, 2011


How are you connected to the internet? Hard wired or using the built in airport?
posted by iamabot at 11:25 AM on November 1, 2011


As a cheap possible solution:

1) free up space on the hard drive
2) repair it with disk utility
posted by zippy at 11:29 AM on November 1, 2011


Hmm, looking at your laptop's specs, you've got the model with the "Intel GMA 950 graphics processor with 64MB of DDR2 SDRAM shared with main memory". This integrated video chip was widely panned as virtually unusable for video you actually want to watch, and one of Apple's worst design decisions in recent years.
posted by mkultra at 11:38 AM on November 1, 2011


I have the same macbook and tend to think that my playback performance is hindered more by the speed/quality of the Internet connection than by the CPU of the machine. If possible, make a wired connection to your router.

Also, use your ISPs DNS settings instead of Google DNS or OpenDNS, as those mask your location and can result in streaming from a server that is physically further away.
posted by cp7 at 11:41 AM on November 1, 2011


THANKS ALL! Appreciate the feedback. Some answers and clarifications:

Netflix is choppy. DVD not choppy. Come to think of it, have not played an AVI on this machine yet.

Internet connection WiFi - and on MacBook pro no such issue. I may connect it to ethernet regardless.

Running Lion, actually. Just rehabbed this Mac.

Playback on the laptop screen also somewhat choppy. Just enough to irritate me. My wife notices it sometimes.

Yes 2GB RAM is maxed.

Airport/WiFi not Wired.

30GB free on the hard drive or thereabouts (I want to say it's 80GB HD?)

Will try Disk Utility.

Not using an OpenDNS solution for this machine. Using base Time Warner, with a standard, I want to say Cisco/LinkSys router of maybe 4 year vintage.
posted by artlung at 11:50 AM on November 1, 2011


I had a similar problem, albeit with bit older Powerbook G4.

I had narrowed the problem down to Flash video, as I was able to play .avi, and .mov files fine, as well as DVD's. The choppy video playback occurred whenever flash player was involved, which is most of the video that you'll encounter on the internet (youtube, hulu, netflix, etc.)

This is pertinent because Flash video is notorious for using gobs and gobs of CPU power. If this is indeed your problem, there is little you can do to solve the issue since the CPU and GPU of your machine are not upgradeable. You can check this for certain by trying to replicate the issue while you have Activity Monitor running. On my old machine, the fans would spin up within seconds of pushing play on a youtube video.

I had moderate success by downgrading to a previous version of Flash player. Although, if I recall, this was a slightly dodgy process, as I had to go through an odd third party shareware site to find an older version of flash player.

Some of the big internet video providers have begun to offer an HTML5 video solution, but alas, I caved and purchased a new computer before I could test that.

One last thing: It looks like OS X Lion requires a MINIMUM of 2GB of RAM to work. That may be an issue too.
posted by teriyaki_tornado at 12:40 PM on November 1, 2011


I'm pretty sure the component for Netflix is Microsoft Silverlight rather than Flash. When I'm required to update for Netflix, it's always Silverlight and not Flash. Is there an option to use other playback mechanisms for Netflix on a Mac?
posted by artlung at 12:49 PM on November 1, 2011


My guess is it's the wireless transport, try it hardwired. Streaming performance combined with a marginal machine can add a lot more flakiness than you think it would.
posted by iamabot at 12:50 PM on November 1, 2011


Boot camp and run Windows on it. Silverlight runs much better on windows (assuming Mac netflix still requires it).
posted by wongcorgi at 12:53 PM on November 1, 2011


Flash video is much more CPU intensive than ordinary video, mainly because it can't / won't make use of your video chips YUV -> VGA conversion or scaling abilities.

Flash does everything in RGB space on the CPU so it can mix in UI elements before blitting a frame to the video chip: effectively it just uses the video hardware as a dumb framebuffer. On top of that it has to transfer the entire fullscreen image over to the video chipset every frame, whereas an ordinary video player (DVDs say) can just blit the YUV-encoded frame and let the video hardware deal with the YUV->RGB conversion & scaling the it to the screen size.

It wouldn't surprise me to find that Siverlight was doing the same as Flash for much the same reasons: My guess is that the slow RAM your laptop has, combined with the shared memory video architecture means that there just isn't quite enough memory bandwidth to reliably throw all these full screen images around.

If you can find a way to download the NetFlix files & strip the DRM off them, then you should be able to watch them in a "real" movie player just fine.
posted by pharm at 1:53 PM on November 1, 2011


I don't know if this would apply to a Mac. When I used to run Netflix on my laptop I improved performance markedly by killing a bunch of add-ons, like the Skype thing that turns phone numbers clickable etc. For a while I had perfect picture but then it began to degrade again for mysterious reasons. Eventually I got a Roku box (their top of the line one is only about $100) and now the picture is perfect.

One thing I tried before getting the Roku was running the Netflix Windows Media Center player--and that was definitely better. That's a player that operates independently of any browser. There may be a Mac equivalent you could try.

Finally, there are a host of wireless DVD and Blu-Ray players you can buy that will also do Netflix streaming.
posted by yoink at 2:18 PM on November 1, 2011


Netflix uses a buffering scheme that should avoid choppy video even if your network is lagging behind. It adjusts the bandwidth if it starts to see dropped packets and would start buffering again if your network was the issue.

I think the issue here is that Silverlight's Mac implementation only uses OpenGL 2.0 for hardware acceleration of video. Your card only supports OpenGL 1.4 so you're not getting any of the benefits of your video card. I don't know that there's a solution for this. You might try using an application like Plex - it may take Silverlight's video and implement its own acceleration.
posted by dosterm at 2:39 PM on November 1, 2011


Thanks for all the tips folks! I'll be trying out some of the suggestions tonight. I'm also going to try some other browser combinations and try to slim down the browsers themselves.
posted by artlung at 4:19 PM on November 1, 2011


I had the same problem with Netflix streaming, and found that for me, the solution was changing my screen resolution to 800 x 600. I wrote about it in this previous AskMe, which you might want to read through for other ideas. The poster of that question found that turning off the HD worked for them (that didn't solve my problem, though).
posted by Houstonian at 3:26 AM on November 2, 2011


If you cut the screen resolution, then you're massively reducing the memory bandwidth required to paint the scaled frames (since they're being scaled to a smaller size) and since this Mac apparently uses system memory for video memory, that means less contention for memory bandwidth with all the other demands of video decoding. So that makes complete sense Houstonian.
posted by pharm at 2:11 PM on November 2, 2011


the one thing I got to try last night was switching from Chrome to Safari and that actually seemed to improve it.

the thing about setting pixel resolution to 800x600 surprises me, but it makes perfect sense - like optimizing settings for a game. I think the way I'm setting resolution is giving me a bias -- the lowest res is something like 1024 wide - - I think the listing in the top bar is not showing me all i can use -- I bet using the actual monitors pref pane will let me try the smaller resolution.

thanks for checking back folks - i really appreciate it!
posted by artlung at 2:14 PM on November 2, 2011


So here's what I've done and have playback working well:

- Using Safari instead, with no other tabs open, ever, I restart Safari daily
- I removed the RSS bookmarks in Safari
- resolution 1280x800 on the laptop screen
- resolution 1280x1024 on the monitor (75Hz)
- I made sure not to have another account logged in (for fast user switching)
- I created a "netflix" account and disabled all startup items except Rowmote
- I positioned the laptop closer to the WiFi base station
- For any Netflix movie I make sure to turn off HD
- I make sure NO other programs are running, and I only allow one folder to be open

The other account I had logged in, typically, had a bunch of periodic updating things running - usually gmail and greader, and I also have apache and mysql running in development tools.

It's not scientific, but basically creating a dedicated account and ONLY using that account, and not having any additional geegaws running seems to have done the trick. I think also assuring I was running at 75Hz made a big difference.

Thank you ALL for helping validate the problem and to get me thinking about the problem deeply. I hope this thread helps someone else in the future.
posted by artlung at 10:50 AM on November 6, 2011


Don't run the monitor at 75hz unless it's an ancient CRT. Use 60hz.
posted by The Lamplighter at 3:02 PM on November 9, 2011


Why do you say that?
posted by artlung at 3:21 PM on November 9, 2011


LCD monitors run at 60hz and aren't really able to display 75hz. The monitor may be able to convert to 60hz but that will introduce judder (subtle hitches in the motion) and certainly won't help anything run more smoothly.
posted by The Lamplighter at 12:40 AM on November 11, 2011


« Older Where can I find Joppie Saus i...   |  Why don't I like new people an... Newer »
This thread is closed to new comments.