Join 3,414 readers in helping fund MetaFilter (Hide)


Frequently dropping wireless
October 25, 2011 10:30 AM   Subscribe

My wireless connection keeps dropping every few minutes. Eee PC, Windows XP, roommate's Macbook does not have this problem.

I've got an Eee PC laptop running Windows XP. We have a Motorola Docsis 3.0 and a Belkin N300 Wireless N router.

Every few minutes, the internet stops working, and we have to "repair connection" to get it back again. We have only had this problem since moving to our new house with the new modem and router setup. In our previous apartment, our modem and wireless setup worked fine. Our roommate's Macbook does not have this problem.

This is a very frustrating problem that has been going on for months. Any advice or help would be appreciated. If you need to know more tech specifics, ask and I will let you know. Thank you guys so much in advance!
posted by moonroof to Computers & Internet (6 answers total)
 
Tech question: how far away is your Eee PC from the router, and through how many walls/floors? How about the MacBook that's working? Have you moved the Eee PC to about 5-10 feet of the router with direct sight lines? Have you tried relocating the router to somewhere else to avoid interference issues?

This stinks of signal issues, and the Eee PC losing signal. It could be interference, other networks causing trouble or a bad wireless card/antenna in the Eee PC.
posted by Mister Fabulous at 10:42 AM on October 25, 2011


This exact scenario (repeated dropping with new wireless set-up, but only on my computer, not others) happened to me very recently. It turned out that I needed to download a bunch of software updates and drivers for my computer that I'd neglected, and to disable the setting that allows my computer to turn off my wireless device to save power. YMMV.
posted by willbaude at 11:02 AM on October 25, 2011


Definitely suggesting you update and double check power settings. Sometimes, especially on laptops, it can get ridiculous with the things that will get shut down to save power. And those things don't always come back up with the power.
posted by Samizdata at 12:41 PM on October 25, 2011


Make sure that you have Wireless Zero Configuration disabled as well, it searches for new networks every few seconds, and has been known to interfere with your current network connectivity while doing so.
posted by Sphinx at 1:36 PM on October 25, 2011


If you have wireless security cameras in your new place, make sure you're not in the signal path between them and the receiver(s).

Sad voice of experience here.
posted by Lynsey at 2:13 PM on October 25, 2011


Re-installed the WLAN drivers and now it is working like a charm. Thanks everyone!
posted by moonroof at 4:56 PM on October 30, 2011


« Older So I started writing online co...   |  Help me be the best product de... Newer »
This thread is closed to new comments.