Join 3,376 readers in helping fund MetaFilter (Hide)


Why can't iCal on my Mac behave like it does on iPhone and iPad?
October 17, 2011 5:39 PM   Subscribe

I am embarrassed to have to ask this, but I have apparently completely forgotten how to get multiple Google calendars to show up in iCal in Lion.

Here is the situation:

When I go, in my web browser, to Google Calendar, I see the following calendars:

Appointments
Work
UMC
and my wife's Google Calendar, which I subscribe to.

However,

When I open iCal in Lion, I see:

Google:
- Appointments

Subscriptions
- UMC
- Wife's Calendar

Here is all I ask:

I'd like to get the Work calendar to show up in iCal so I can add and delete items from it.

Here is what I really don't understand:

All my calendars show up beautifully and perfectly on my iPhone and my iPad.

Please help. Thank you so much.
posted by 4ster to Computers & Internet (6 answers total) 4 users marked this as a favorite
 
Oh, also, I'd like, if at all possible, to do this without using iCal's Delegates function. Thanks.
posted by 4ster at 5:42 PM on October 17, 2011


I struggled with this last week.

The calendar setup used to be configured in iCal itself.

But now, you need to add the calendar-owning accounts to the System Preference called "Mail, Contacts and Calendars."

And in that way it's now exactly like your iPad and iPhone, where you use the system Settings for "Mail, Contacts, Calendars" to add/change calendars. You don't do it within the Calendar app.
posted by rokusan at 2:53 AM on October 18, 2011


rokusan: Thanks for your help, but sadly when I do this, I still only get the "Appointments" calendar.
posted by 4ster at 5:03 AM on October 18, 2011


Once you've got the setup that rokusan suggested, go back into your Preferences in iCal. Click on the 'Gmail' account in the sidebar. Then select the 'Delegation' tab in the right panel. From there, you should see a list of all the calendars you have access to from your Gmail account. Click the checkboxes for the calendars you want to see, and you've got it!
posted by duien at 9:03 AM on October 18, 2011


Sorry, go the the 'Accounts' section of your iCal preferences.
posted by duien at 9:05 AM on October 18, 2011


Well, here is what actually worked for me. I found it here:

2. Open Preferences in iCal and select "Accounts"
3. Click on the "+" button to add a new account
4. Select "CalDAV" from the Account Type menu
5. Type your user name (important: do not add the "@gmail.com" part or it will just duplicate your main google account).
6. Type your password
7. Replace the section in all caps with the ID from step 1, then copy and paste this to the server address field. (NOTE: do not add "https://" to the beginning of the address)

www.google.com/calendar/dav/REPLACE_THIS_WITH_THE_CALENDAR_ID_FROM_STEP_ONE/user/
posted by 4ster at 11:51 AM on October 18, 2011


« Older Springerle cookies in Buffalo?...   |  Looking for information on int... Newer »
This thread is closed to new comments.