Skip

I can't hear you over how awesome XBMC is (I wish)
September 28, 2011 2:01 PM   Subscribe

Background music and effects are way louder than voices in XBMC, so much so that I have to get up and turn the volume down every time theme song or music comes on during TV shows or movies for fear of disturbing neighbors (not to mention that they're uncomfortably loud).

The volume normalization that's part of my sound card doesn't seem to do much. It seems to be a problem when I play the videos in VLC as well, so it must be the audio stream of the file itself.

I don't really get how equalizers work, could that do anything? It doesn't seem like XBMC has anything built in that could do this either, and google hasn't turned up any plugins.

Has anyone else encountered this problem? Is there anything I can do to fix it?
posted by Strass to Computers & Internet (12 answers total) 1 user marked this as a favorite
 
Is it possible that your setup thinks you have a center channel speaker and you don't? That's where voices are usually routed.
posted by The Bellman at 2:13 PM on September 28, 2011


I do have a center channel, although my left and right are way bigger speakers. I've tried boosting the center channels DB level in my audio level setup and it helps a little but doesn't fix the problem...
posted by Strass at 2:33 PM on September 28, 2011


I seem to observe the same phenomena on all my media, even my Netflix on Roku or PC. When watching movies I am constantly turning volume down for music and special effects, then turning it up so I can hear the voice dialogue. As other poster states, make sure you have PC/sound card configured for the correct speak arrangement. Try plain stereo.
posted by nogero at 2:40 PM on September 28, 2011


I was going to say the same thing as The Bellman. Just as an experiment, what happens when you tell the Xbox you only have stereo (two speakers) sound? If that doesn't at least make things useable, I think possibly your center speaker is shot.
posted by Nattie at 2:41 PM on September 28, 2011


It's the way that the audio is encoded down to stereo.

Since voices on most movies/HDTV are encoded to the center channel. When you download something from Bittorrent, play Hulu/Netflix, or some other sort of video content, that center channel content is getting canceled somewhat when it's dumped down to stereo. Some voice content is present in the stereo channels, but there's a phase differential that comes into play when you duplicate the center content on those channels.

TL;DR, it's the way the video is encoded.
posted by chrisfromthelc at 2:56 PM on September 28, 2011


Does your soundcard support virtual surround sound? Does it happen when you play regular DVDs?
posted by empath at 3:14 PM on September 28, 2011


It sounds like you're listening to the L-R channel of MS encoding. It could be a problem introduced during transcoding (when the version your playing was converted from the source video), but if it's happening to everything it could also be a matter of channels being mixed improperly by the decoder, or even something like having your audio-out set up improperly. Look for settings like "joint stereo", which does this sort of mixing.
posted by AzraelBrown at 7:00 PM on September 28, 2011


I set it to stereo and it helps but now nothing at all is coming out of my rear speakers. Is there a way to keep both?
posted by Strass at 7:05 PM on September 28, 2011


I had this same problem on my XBMC install. The issue is that XBMC has no sort of dynamic range compression built in. This is a much lamented omission that will hopefully be corrected in a future version.

In any case, you can solve the problem easily enough assuming you're using Windows 7. Here's what I did:

Open Control Panel
Click Sounds
Select your default speakers on the Playback tab and click Properties
Click Enhancments
Check the box marked Loudness Equalization
Optional: Click Settings after checking Loudness Equalization and play with the release time. Basically, this affects how long the dampening will last on sudden loud noises.

Since enabling this I've had little to no problems with sudden volume bursts on my XBMC install (which I use exclusively all media playback on my HTPC - DVDs, Blu-Rays, music, etc).
posted by sprocket87 at 12:21 PM on October 1, 2011 [1 favorite]


"which I use exclusively for all media playback..."
posted by sprocket87 at 12:22 PM on October 1, 2011


Oh, and I don't know what you're using for a stereo amplifier / receiver, but decent, newer receivers have compression control built in, which would probably be superior than Windows' built-in compressor anyway. Worth taking a look at your stereo receiver's manual to see if it has that.
posted by sprocket87 at 12:25 PM on October 1, 2011


Sorry for the quadruple post: After reading some more on the XBMC forums it looks like a compression control was actually added in a recent build (recent as in four days ago)!

So, you've got options :)
posted by sprocket87 at 12:28 PM on October 1, 2011


« Older Recently I obtained (for work-...   |  I'm looking for an anti-custom... Newer »
This thread is closed to new comments.


Post