Join 3,436 readers in helping fund MetaFilter (Hide)


Laptop is great, desktop is crawling.
August 19, 2011 11:57 AM   Subscribe

I'm at the end of my tether trying to sort out this internet connectivity issue.

I've been through bureaucracy hell getting this new 25 meg Charter Cable internet line installed.

Laptop sitting right next to me is finally getting full connectivity. Desktop has the same upload speed (3.5megs) but its download speed is about 300k on speed tests. Laptop is getting 28 megs / sec compared to desktop 300k. Same upload speed.

Drivers are all updated. This is a new problem. No idea where to start.
posted by lazaruslong to Computers & Internet (16 answers total)
 
Are they running the same OS?
posted by introp at 12:01 PM on August 19, 2011


Is this over a wireless or wired link? If it's wired check your ethernet card settings on your desktop vs what your switch/router supports. One may be set to duplex or auto, 10MB, 100MB, 1GB, etc, and the other side might not support that negotiation. Also try changing out the ethernet cable.
posted by white_devil at 12:06 PM on August 19, 2011


Its a wired link straight to the modem. Adapter is at full duplex. Tried with a different cable, same result.

Laptop is running 7, Desktop is running Vista Home.
posted by lazaruslong at 12:09 PM on August 19, 2011


How do I find out what setting are supported? The modem is a Cisco DPC3010 and my network adapter is a generic nVidia.
posted by lazaruslong at 12:12 PM on August 19, 2011


Could you run an Ubuntu live cd and try the connectivity? You don't even need to burn it on a cd, an USB flash drive can also be use.

Also, I would troubleshoot any AV, firewall or other security software.
posted by Foci for Analysis at 12:19 PM on August 19, 2011


Second'ing trying a Linux live CD of some sort. It could be a number of things but the biggest suspicions are 1. Vista Home's TCP/IP tuning settings are very different from 7's, and/or 2. very different hardware capabilities (your desktop has a tremendously crappy Ethernet chip/driver/etc.). Trying a whole new OS off a bootable CD will help divide the problem space.
posted by introp at 12:21 PM on August 19, 2011


K gonna do that. Will update.
posted by lazaruslong at 12:30 PM on August 19, 2011


This is somewhat a shot in the dark, but perhaps you could try disabling any QoS settings on your network adapters and/or modem/router too (if you can get to the router configs). Turn off any IPv6 (Toledo, 6to4, etc) temporarily. Basically this is to accomplish two separate things: a) to make sure traffic is not being throttled locally and b) to make sure you're working strictly with IPv4 traffic just to rule out any routing issues with your modem/router.
posted by samsara at 12:38 PM on August 19, 2011


You could try using the USB port to connect and that would help isolate the cause. USB Driver.
posted by white_devil at 12:46 PM on August 19, 2011


Using the USB port to connect the modem?
posted by lazaruslong at 12:49 PM on August 19, 2011


Yep.Manual.
posted by white_devil at 12:51 PM on August 19, 2011


I don't have many details, and this is an anecdote without a full diagnosis, but I have a Vista laptop that gets miserable download speeds when I connect it to my Cisco gigabit router with a wired connection. It would get perfectly normal speeds when I plugged it in to my old 100 Mbps router, the wireless connection was fine, and XP computer plugged into the router got normal speeds, but something about connecting the laptop to that Cisco router slowed downloads to a crawl. A quick Google search indicates that some people have had difficulty with Vista and gigabit ethernet. I can't say if that's your problem, and I never resolved my issue, but it's a possibility.

(If it turns out that Vista is your issue and you implement a fix, please let us know. I still have that old laptop and I wouldn't mind hearing if there is a fix.)
posted by Tehhund at 1:04 PM on August 19, 2011


I changed the duplex settings on the adapter from Full Duplex to Auto Negotiation and it fixed the problem.



After 2 weeks.


Thanks all.
posted by lazaruslong at 2:22 PM on August 19, 2011


I just want to say that although the fix came quickly, I really did do a ton of work and troubleshooting on this with 2 different techs over 4 appointments and 2 weeks. Its just strange to me that the issue of duplex settings never occurred to me, or was suggested by a tech. But yeah. I guess these fancy modems require auto duplexing. Instant fix.
posted by lazaruslong at 2:36 PM on August 19, 2011 [1 favorite]


For future reference. Autonegotiation must be set on both sides for it to work, Autonegotiation is mandatory for Gigabit connections. At lower 10/100 Megabit speeds, both sides must still be the same, one side auto and the other side non-auto fails miserably. Duplex mismatch is the #1 cause of problems. Setting manually anything but auto is a bad idea and should only be used as a last resort, and both sides must be set to the same settings.
posted by zengargoyle at 2:51 PM on August 19, 2011


At lower 10/100 Megabit speeds, both sides must still be the same, one side auto and the other side non-auto fails miserably.

Worse -- it tends to fail invisibly until the link is put under load. The problem is that the side locked to 100/full doesn't autonegotiate, and the side that's set to autonegotiate can't see a partner, so it defaults to 100/half. You get a link that looks like it's working fine at low usage (because you're much less likely to have a collision), but has really lousy performance when you try to pass data at high speed. Since it never actually fails hard (i.e., complete failure to pass traffic), it's easy to overlook.

Locking both sides to full duplex has its uses, especially in an enterprise environment where you've got a server that's permanently connected to a switch, and if it's older gear that doesn't always autoneg reliably. End-user workstations should never, ever have speed and duplex locked, which may be why it never occurred to any of the techs (although it certainly should have).
posted by McCoy Pauley at 5:56 PM on August 19, 2011


« Older We're currently addressing wed...   |  I work at a desk 10 to 12 hour... Newer »
This thread is closed to new comments.